Can't use Elements 15

New Here ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

Elements 15 is only installed on one other device and I am not signed in on that device.  When I install it on my new computer, it says that the serial number is active on too many other devices and I need to deactivate some.  But when I go to my account on Adobe.com and find that product, it says that it is not activated on any devices.  Help?

Views

33

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

Please go to Adobe Customer Service and only ask to have your activations reset (make sure to sign in to your Adobe account first and allow popups on your browser):
https://helpx.adobe.com/contact.html?rghtup=autoOpen will automatically open the chat window.
Type "Agent" in the chat box to bypass the chatbot and be connected to a person.

You may also be able to contact Adobe by phone:
https://helpx.adobe.com/contact/phone.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

LATEST

I've moved this from the Using the Community forum (which is the forum for issues using the forums) to the Download and Install forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines