CS6 for MacOS High Sierra

New Here ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

I am a photoshop newbie, I am currently using photoshop 2020, running a MacOS High Sierra and purchased  an inksketch package that requires CS6 or older, how do I get CS6 on my MacOS High Sierra? or is it even possible?

 

Tx

TOPICS
Installation , New user

Views

32

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

Apple did not maintain backward compatibility, so try this to install old programs
https://helpx.adobe.com/creative-cloud/kb/install-creative-suite-mac-os-sierra.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

Note that if you do not already own CS6 for the Mac, you will not be able to buy it. It hasn't been sold in years.

 

If someone contacts you saying they're from Adobe and can help you acquire or install CS6, do not respond. They are scammers.

 

You also want to avoid ebay. If they're selling multiple copies, they probably bought OEM-licensed copies that are illegal to resell. Adobe will eventually catch that and shut the program down. If they say they're selling their personal, used copy but they're not willing to transfer the license, that indicates they probably don't own the program. Both seller and buyer have to fill out paperwork to transfer a license.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

LATEST

You are in a precarious place with your mixture of apps and systems. Best not to mess with anything. You've now added something that needed 8 year old software - best to chalk this up to experience - check system requirements carefully, especially as your stuff is neither up to date nor really old.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines