install fails - asks for update internet explorer

New Here ,
Jul 23, 2021 Jul 23, 2021

Copy link to clipboard

Copied

Have the Elements 2019 that i'm trying to install on a Surface with Win10 after a reconfig of the operating system.

 

I get the error message that i need to upgrade to internet explorer 11 to process, but the surface is using MS Edge. Any suggestions for a workaround here?

TOPICS
Installation

Views

170

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 23, 2021 Jul 23, 2021

Copy link to clipboard

Copied

Photoshop Elements doesn't seem to have a requirement, but Premier elements seems to require IE, Firefox, or Chrome ( https://helpx.adobe.com/premiere-elements/system-requirements/system-requirements-older-versions.htm... ).  Have you tried downloading one of those browsers to see if you can proceed?


If not, have you tried downloading IE just to have it for the installation: https://www.microsoft.com/en-us/download/details.aspx?id=41628

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2021 Jul 23, 2021

Copy link to clipboard

Copied

It's Premier Elements 2019.

 

Tried to install IE11 now that you linked to, and have Chrome from before. No good. Same error message.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 23, 2021 Jul 23, 2021

Copy link to clipboard

Copied

I don't know if PSE 2019 is compatible with new Surface devices.  It might be too old for your machine.

https://helpx.adobe.com/in/photoshop-elements/system-requirements/older-versions.html

 

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Hi.

 

Have received a tip to contact Adobe support and has correspondence there. But they use an email adress like this - AdobeCareInc@outlook.com. Is this a known email adress to you in this forum?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

LATEST

Adobe doesn't use @outlook.com.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines