Install previous versions when you register for the first time

New Here ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

Hi!

I just registered to Adobe Creative Cloud. I work on mac with system version macOS High Sierra 10.13.6, it is impossible to update it because the computer can't take it. Therefore, a lot of softwares in the actual AdobeCC collection are not compatible.

I would like to know if it is possible to install a previous version of some softwares that would be compatible with this OS? If so, how can I do it?

Some of the softwares I am interested in: Photoshop, Illustrator, InDesign, Premiere Pro, After Effects, etc.

Thanks in advance

Pierre

TOPICS
Creative Cloud , Installation

Views

117

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Dec 16, 2021 Dec 16, 2021

Pierre, I am very sorry, but if the computer is unable to run a modern version of macOS, then I would recommend you follow the process listed in http://helpx.adobe.com/x-productkb/policy-pricing/cancel-membership-subscription.html to cancel your membership.  I did check your account, and you have less than two days to cancel the membership before you incur a penalty for canceling.

 

Please wait to subscribe until you have access to a computer capable of utilizing the current release of our app

...

Likes

Translate

Translate
Adobe Employee ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

Pierre, I am very sorry, but if the computer is unable to run a modern version of macOS, then I would recommend you follow the process listed in http://helpx.adobe.com/x-productkb/policy-pricing/cancel-membership-subscription.html to cancel your membership.  I did check your account, and you have less than two days to cancel the membership before you incur a penalty for canceling.

 

Please wait to subscribe until you have access to a computer capable of utilizing the current release of our applications and services. You can find the system requirements for each of the Adobe applications included with a Creative Cloud membership at https://helpx.adobe.com/creative-cloud/system-requirements.html.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

Thank you for this follow up, Jeff. It’s unfortunate, indeed, that Adobe does not allow it’s customers to install older versions that may be suitable for older systems. I am working in partnership with another person. Previously, she was the one who subscribing to the Creative Cloud suite and it was through her that we could connect our two computers to it. Her computer operates with the same system as mine. Because she did not uninstall the latest compatible versions of the Adobe suite CC, she can now use them again through my account. Personally, I had to temporarily uninstall them from my computer and today I can't go back and reinstall them. Frankly, this is deplorable. We all wish we could afford the latest models of computers and software, but when we can't, we would appreciate that companies like yours to act in an eco-responsible manner and allow all of their customers to have access to their services. It wasn't that long ago that Creative Cloud made it possible to downgrade multiple versions of each of your software. I cannot explain to myself why this is no longer possible. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 20, 2021 Dec 20, 2021

Copy link to clipboard

Copied

LATEST

Two people using one account is against the license policy. You both need a paid account to use the CC software, unless you have one of the business accounts that doesn't have personal ownership.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 16, 2021 Dec 16, 2021

Copy link to clipboard

Copied

Your operating system (mac OS High Sierra)  is 5 versions behind and too old to support modern software.

 

Adobe expects customers to have modern CPU & GPU with an OS that's no more than 2 versions back.

- https://helpx.adobe.com/photoshop/system-requirements.html
- https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html
- https://helpx.adobe.com/pl/after-effects/system-requirements.html
- https://helpx.adobe.com/premiere-pro/system-requirements.html

 

Recommended Work Stations for Premier Pro:

https://www.pugetsystems.com/recommended/Recommended-Systems-for-Adobe-Premiere-Pro-143/Hardware-Rec...

 

Nancy O'Shea, Product User & Community Expert
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
express Get Adobe Express free

Easily make social graphics, flyers, logos, and more from thousands of free templates.

Open on the web
Free to use, no download required