My PS Elements got a bug in it on downloading and it won't open

New Here ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

When I downloaded my PS Elements 2021 there was a connection loss on the wifi and evidently it did not load corectly. When I sign in it just keeps recycling the sign-in and never opens.  What do I do so I can use it?

Views

27

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

I've moved this from the Using the Community forum (which is the forum for issues using the forums) to theDownload and Install forum so that proper help can be offered.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

LATEST

Uninstall, download it again, and install again.

You may need to use the Cleaner Tool:

https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines