Photoshop not compatible with my system (SSE 4.2 problem)

Community Beginner ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

Hi,

It seams that i was to quick to celebrate my new acquisition. Creative cloud gave me 1 option to install Photoshop 22.2 (compatible, Photoshop 23.11 is not compatible). I've installed the version provided but when i tried to open it gave an error ("Error at loading of ippCV library"). It's my bad that i did not check the fine print regarding system requirements, so my Phenom 1100T (6 core) is good but it's missing SSE 4.2 and above. But then why did Creative Cloud gave me the option to install an older version, there was no incompatibility message (like the one from version 23.11) so i took it to face value.
I've checked here (https://helpx.adobe.com/photoshop/kb/known-issues.html#ErroratloadingofippCVlibrary) and it suggested that i should install an older version of Photoshop (v21.x), but it seams that i don't have that option since the versions stop at v22.0 .
I see to paths here, either i have the option to install a compatible version (v21.x) or i'll be asking for a full refund since i can't use your Photoshop. I hope i can install an older version.
If there are any questions or you need additional information please let me know.

Mike

TOPICS
Installation , New user

Views

341

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Feb 11, 2022 Feb 11, 2022

I've solved my problem! While it was with the help of a chat bubble, it wasn't in the place directed by Jeff. Going on a hunch i went into my account to Support History and there i had a little link at the end of a statement pointing me to contact support, i clicked that and surprise surprise the chat bubble appeared (i have adblock on and native pop-up blocked on, no problem there). There was a small hiccup with v21, since it uses the old Internet Explorer for the installer, that gave an error

...

Likes

Translate

Translate
Community Expert ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

In the Creative Cloud Client directly you can go back only one version.

In your case your have to contact the Adobe support to get the download link for a compatible version that you need.  

https://helpx.adobe.com/contact.html?rghtup=autoOpen&mv=affiliate&mv2=red

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

Thank you for the info Axel. I hope that someone for Adobe can help me out here, cuz trying to communicate with them directly is a nightmare from the site, all help links point out more or less to the same place.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

MegaWoTHD, if the chat window does not open or is unresponsive when you click on https://helpx.adobe.com/contact.html?rghtup=autoOpen, then you will need to use a different device to contact our chat team.  Only by establishing a chat session will be provided a temporary link to download the installation files.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

Hi Feff and thanks for helping out.

I hope that ins't the case, since i can't see any chat pop-up on my PC on Chrome and Firefox, i've even tried on my Android phone. We could use my email, if i get my login code there i'm sure it's safe enough to get other download links as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

I am sorry to hear that, MegaWoTHD, the inability of the computer to contact us could lead to other connection problems later. 

 

Please make sure that pop-up blockers are turned off, scripts and cookies are allowed, and verify there are no additional settings turned on in the web browser that could be actively blocking your ability to contact us. 

 

Please also bookmark https://helpx.adobe.com/download-install/kb/common-network-connectivity-issues.html, which provides additional suggestions on resolving connection errors.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

I'm unsure what you mean about "problems later". I'm talking to you right now (contact made), i've installed the program (no connection problem), what exactly problems are you referring to?
Well then this is a major problem. I'v tried 3 browsers, ensured that they all allow pop-ups, no adblockers and yet still no chat. Keep in mind that i have no problem with other sites when it comes to chat pop-ups.
Before asking for help i've goggled the problem as i usually do and it turns out that you have some "bugs" when it comes to helping with this problem. Bug number 1 is when you advise people to go to Help and check system compatibility when they can't even open Photoshop (this "help" was spammed every time) and then (2) you have older customers updating to a version that is not compatible with your blessing (as in my case). You clearly thought about this since i was not able to install the latest version, so there is no excuse here.
In conclusion, if i can't make your chat work, i won't be getting the link to an odder version of Photoshop?

 

PS: I see that i've butchered your name earlier (Feff), i do apologies for that, fast fingers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

No, MegaWoTHD, all you are doing is posting in a public discussion forum accessible to anyone with Internet access.

 

You will need to establish a secure chat session at https://helpx.adobe.com/contact.html?rghtup=autoOpen and speak with a member of our support team to request a copy of the installation files that will work on your computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

While this is a public forum, i'm having a discussion with an official Adobe employee (your title is "Adobe Employee").
You are doing exactly what i've explained, you are spamming a non solution over and over expecting a different result.
If you are unable to help, allow another employee to take over.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

LATEST

I've solved my problem! While it was with the help of a chat bubble, it wasn't in the place directed by Jeff. Going on a hunch i went into my account to Support History and there i had a little link at the end of a statement pointing me to contact support, i clicked that and surprise surprise the chat bubble appeared (i have adblock on and native pop-up blocked on, no problem there). There was a small hiccup with v21, since it uses the old Internet Explorer for the installer, that gave an error regarding being out of date (smart). With further assistance from support i was directed to a site explaining this exact problem with 3 solutions, i picked the last one were you download an .exe file (setup file) that you simply paste over the original, thus bypassing the update error (link to Adobe article below). With all this i was able to finally install Photoshop v21 and the latest Lightroom and Camera raw (it seams these two are fine with my old processor).

 

Summary:
1- Open chat bubble (anyway you can)
2- Explain that you need Photoshop v21
3- Go to the following link and download the .exe file from Solution 3 (https://helpx.adobe.com/tech-comm-suite/kb/deprecated-internet-explorer-10-with-ims.html)
4- Paste new .exe file over the original setup file.
5- Install Photoshop v21
6- DON'T UPDATE PHOTOSHOP!!!

 

Hope this helps anyone with my problem, or similar.
Take care!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines