Windows 10 Elements installation problems

New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

I have a practically new machine for which W10 was intalled from new, a Dell OptiPlex 7070. All updates have been installed. Ituses only SSD's.

I have a valid license for Photoshop Elements 17, which I used to run without problems on my previous old W7 machine.

However, trying to download it and install on the new machine it says that installation is incompatible with my operating system and W11 is needed.

Surely that cannot be correct? That a product that worked perfectly on a W7 machine now won't work on a three month old W10 one?

Help please!

 

TOPICS
Installation

Views

111

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

is your os 64 bit?

 

p.s. check carefully.  i don't think there was a pse 17

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

There was a version 17.

This is from my account:

Version17.
PlatformMultiple
Registration DateOct 19, 2018

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

What are the complete computer specs, including hard drives (how many, what kind, what is on each, what capacity, and how full)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz 2.90 GHz

RAM 16GB

64-bit operating system, x64-based processor

Windows 10 Pro, 64Bit

Version 21H2

Install date 19/‎09/‎2021

C: Drive, SSD 474GB, 22GB used

F: Drive, SSD 1GB, 73.4GB used

E: Drive, Western Digital spinnng rust, 1GB, 236MB used

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Correction!

C: Drive, SSD 474GB, 22GB used

F: Drive, SSD 1TB, 155GB used

E: Drive, Western Digital spinnng rust, 1GB, 236MB used

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

if your default web browser is ms ie, change it (at least temporarily) to a different one that has tls 1.2 support.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Photoshop elements 2019 is version 17

 

By far the easiest solution is to download and install the Creative Desktop Application, then photoshop elements 2019 should install.

 where it says download it directly

https://helpx.adobe.com/download-install/using/download-install-new-computer.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Take a GOOD look at the message. I suspect it doesn't say you need Windows 11. Does it say you need Internet Explorer 11?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

LATEST

Ding! I think you're right. I'll try angain and check.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines