Adobe Apps are Showing as Not Compatible to Update

New Here ,
Oct 22, 2020

Copy link to clipboard

Copied

I am unable to update my adobe apps to the most recent versions, all I get is "Not Compatible" and a message prompt to update my system. My system is 10.13.6, that seems to fall under the "later" port

TOPICS
Creative Cloud, Installation

Views

340

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 22, 2020

Copy link to clipboard

Copied

Most of the latest apps need 10.14, or later I suppose. You can verify the system requirements of the apps you need at the following

https://helpx.adobe.com/creative-cloud/system-requirements.html

-Manan

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more