Highlighted

Adobe Creative Cloud is needed to resolve this problem. However, it is missing or damaged

Explorer ,
Oct 12, 2014

Copy link to clipboard

Copied

Creative Cloud will not run without throwing up a window "Adobe Creative Cloud is needed to resolve this problem. However, it is missing or damaged. Please download and install a new copy of the Creative Cloud". I download the app and run the installer, and it simply throws up the same window over again... "Adobe Creative Cloud is needed to resolve this problem. However, it is missing or damaged. Please download and install a new copy of the Creative Cloud". I'm stuck in a loop! Can someone help me urgently please? I'm on system 10.9.5

We now have this kb article which goes through solutions to this issue:
Error: "Adobe Creative Cloud is needed to resolve this problem"

TOPICS
Creative Cloud

Views

33.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe Creative Cloud is needed to resolve this problem. However, it is missing or damaged

Explorer ,
Oct 12, 2014

Copy link to clipboard

Copied

Creative Cloud will not run without throwing up a window "Adobe Creative Cloud is needed to resolve this problem. However, it is missing or damaged. Please download and install a new copy of the Creative Cloud". I download the app and run the installer, and it simply throws up the same window over again... "Adobe Creative Cloud is needed to resolve this problem. However, it is missing or damaged. Please download and install a new copy of the Creative Cloud". I'm stuck in a loop! Can someone help me urgently please? I'm on system 10.9.5

We now have this kb article which goes through solutions to this issue:
Error: "Adobe Creative Cloud is needed to resolve this problem"

TOPICS
Creative Cloud

Views

33.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 12, 2014 1
Adobe Employee ,
Oct 12, 2014

Copy link to clipboard

Copied

Hi tiff_meek,

You can try the steps:

For Mac

Go to Applications-->Utilities-->Adobe Installers.

Uninstall Adobe Creative Cloud.

** If it says application is running in the background then open Activity Monitor and close the process of Creative cloud.

111.jpg

Once the creative cloud is uninstalled then follow the below mentioned steps:

Please go to Library

    1. Click on Finder then Click on Go and Go to folder

1111.png

    2. Type /Library and click on Go

Screen Shot 2014-10-11 at 6.22.29 pm.png

    3. Go to Application Support and Adobe and then delete OOBE folder.

    4. Redo Step 1

    5. Type ~/Library and click on Go

    6. Go to Application Support and Adobe and then delete OOBE folder.

    7. Go to https://creative.adobe.com/products/creative-cloud?promoid=KLYVF

Download Adobe Creative cloud, Install it.

If the above steps do not work. Try enabling root user account and then try to open Adobe Creative cloud.

Enable root user: Enabling and using the "root" user in Mac OS X

Thanks,

Nikhil Gupta

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2014 1
New Here ,
Feb 11, 2015

Copy link to clipboard

Copied

I went through the whole process you mentioned and I still get the same error ... "Adobe creative cloud is needed to resolve this problem. However, it is missing or damaged. Please download and install a new copy of the Creative Cloud from 'http://www.adobe.com/go/adobecreativecloudapp'."

I have tried everything, including uninstalling all of my apps. Please help me. I am a professional Graphic/Web designer and have been an Adobe user since 1987. I have never had any problems like this. Creative Cloud has been a nightmare from day 1. I have done lots of research on the web and found a zillion people who are having exactly the same issue. I have clients anxious for their projects, and this is costing me a fortune, and if I start loosing clients, I am going to be very upset. I cannot exist without Adobe Products.

Please help me get rid of this error forever.

Robert

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 11, 2015 4
Community Beginner ,
Aug 16, 2015

Copy link to clipboard

Copied

Same here - CC works, but I still have to get past the "missing or damaged" error message.  I have tried all of the "fixes" listed above and nothing seems to work!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 16, 2015 0
New Here ,
Apr 21, 2015

Copy link to clipboard

Copied

I have the same issue in Windows 7 with the latest update from Adobe. Solution required asap.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2015 0
New Here ,
Apr 21, 2015

Copy link to clipboard

Copied

Same here !

Need a solution urgently !!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2015 0
New Here ,
Jan 13, 2017

Copy link to clipboard

Copied

The key step seems to be doing this as a root user.

I went through these steps and had success:

1.  Download the:

- Creative Cloud Uninstaller   https://helpx.adobe.com/creative-cloud/help/uninstall-creative-cloud-desktop-app.html

- Adobe Creative Cloud Cleaner Tool   https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

- Creative Cloud Installer   https://www.adobe.com/au/creativecloud/desktop-app.html

- Application Manager Installer 10.0_all  https://www.adobe.com/support/downloads/product.jsp?product=170&platform=Macintosh

2. Enable the root user and password for the problem computer.  https://support.apple.com/en-au/HT204012

3. Log in as the root user and uninstall Creative Cloud using Creative Cloud Uninstaller.

In both /Library/Application Support/Adobe and ~/Library/Application Support/Adobe, (if still there) also delete:

- OOBE folder and contents

- AAMUpdater folder and contents

- AdobeApplicationManager folder and contents

4. While logged in as root, re-install Creative Cloud using Creative Cloud Installer.

5. Also, re-install Application Manager using Application Manager Installer 10.0_all.

6. Log out of root user, log in as your normal (admin) user.

7. Creative Cloud desktop should now be available. The desktop application may update itself to the latest version.

In my case, the list of apps displayed was not accurate, but at least all of my apps functioned properly. If you need to delete and re-install other apps, use the Adobe Creative Cloud Cleaner Tool to remove them.

8. Lastly, disable the root user account.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 13, 2017 5
New Here ,
Feb 21, 2017

Copy link to clipboard

Copied

This process worked for me without using the root user approach.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2017 0
New Here ,
Feb 23, 2017

Copy link to clipboard

Copied

Following the steps using root access is the only thing that worked for me. Thanks for posting a fix.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2017 0
New Here ,
Jun 28, 2017

Copy link to clipboard

Copied

Worked for me using a mac with Sierra

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 28, 2017 0
New Here ,
May 31, 2018

Copy link to clipboard

Copied

it worked for me when i used the Adobe Creative Cloud Cleaner Tool. Thankks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 31, 2018 0
New Here ,
Apr 15, 2015

Copy link to clipboard

Copied

Same issue here. Suggestion didn't work either. Have you found a solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2015 3
Contributor ,
Apr 15, 2015

Copy link to clipboard

Copied

same issue here - except on 10.10.3 and it was all working great right up to the 10.10.3 update... ( i made a post about it before i saw this one...)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2015 1
Community Beginner ,
Apr 20, 2015

Copy link to clipboard

Copied

I have the same problem. Very annoying to say the least

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2015 1
Adobe Employee ,
Apr 20, 2015

Copy link to clipboard

Copied

You can check the resolution in Can't Install Creative Cloud on New iMac/Yosemite,

The following

1. OOBE.

2. AAMUpdater.

3. AdobeApplicationManager.

needs to be deleted or renamed.

Regards

Rajshree

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2015 4
New Here ,
Apr 21, 2015

Copy link to clipboard

Copied

doesn't work for win 8.1 pro. any other solution?

cc cleaner also doesn't work

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2015 0
New Here ,
Apr 21, 2015

Copy link to clipboard

Copied

Windows 8.1

I have used the CC Cleaner again, cleaned the Adobe ID CC 2014 (or something like that) as well as the Adobe Creative Cloud Desktop, downloaded the today's installer from:
=> https://creative.adobe.com/products/download/creative-cloud?version=2.8

..and now it's working again, but it doesn't recognizes my installed products...so basically I now have to uninstall and reinstall everything...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2015 0
New Here ,
Apr 21, 2015

Copy link to clipboard

Copied

So - for me it's working again ! Tried again today in the morning and now it seems to work - just need to re-install all of my Adobe Apps (CC and non-CC), which sucks, but at least it's running again.

What I did - basically I deleted everything from my system that was Adobe related (except Non-CC Lightroom + Flash + Reader) and manually deleted some directories that seem to be related to either Adobe Application Manager which both the normal un-install routine and the cleaner tool left behind.

This is what I did yesterday as well - except, that today I also gave it a try and de-installed Premiere Elements 12 and PhotoShop Elements 12 ....

After that I ran a couple of registry cleaning cycles with CC-Cleaner and tried re-installing the CC Desktop App - now it's working again and I am just downloading PhotoShop & Co.

But honestly Adobe -> That is just annoying ! Obviously the update was messsed up and it was still pushed out ...

Not the first time, the CC Desktop App caused issues - so dissappointed by this whole cloud/CC thing ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2015 0
New Here ,
Sep 21, 2015

Copy link to clipboard

Copied

I used the Migration Assistant to my new Mac which led me to the same error message. The steps listed in the link (Can't Install Creative Cloud on New iMac/Yosemite) fixed the issue. Thanks for the info.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 21, 2015 0
New Here ,
Jan 01, 2017

Copy link to clipboard

Copied

Im a mac user & I could not get the Creative Cloud app running. It was giving me an error telling to reinstall the Creative Cloud app which was not working. Tried deleting the creative cloud app from folder and reinstalling, but it never worked. Tried using the uninstall link to uninstall the Creative Cloud App it gave me an error telling there are other Creative Cloud apps that needs to be uninstalled prior to uninstalling this app. And when trying to uninstall any other Creative Cloud app like photoshop it gave me an error telling you need to launch Creative Cloud App to uninstall the photoshop.

Basically a loop where i need Creative Cloud app to uninstall Photoshop while Photoshop & Lightroom need to be uninstalled prior to Creative Cloud being uninstalled. But thank you Rajashree Bhattacharya, your solution worked.

I deleted OOBEfolder & AdobeApplicationManager folder.

(Could not find a folder AAMUpdater but a couple of files inside AdobeApplicationManager folder with that name but diff extension)

Then reinstalled again & voila it worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 01, 2017 0
New Here ,
Apr 20, 2015

Copy link to clipboard

Copied

OMG, me too! I just had a message to update and then got into this same loop. I've tried everything and cannot resolve the issue. I hope someone can come up with an answer for Windows 8.1.  Dead in the water here and not a happy camper. HELP!!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2015 1
New Here ,
Apr 20, 2015

Copy link to clipboard

Copied

same here. (quiting the adobe services/tasks in the task manager and restart installation doesn't work)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2015 0