Can't Install Adobe XD

New Here ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Here is my error code. Please someone link me to a solution involving my specific error message. I am installing through creative cloud and every single other app updates and installs fine.

 

Exit Code: 191
-------------------------------------- Summary --------------------------------------
 - 2 fatal error(s), 2 error(s), 0 warnings(s) 

FATAL: Error (Code = 191) executing in command 'AddUWPAppxCommand' for package: 'UWPAssets', version:37.1.32.2
FATAL: Error occurred in install of package (Name: UWPAssets Version: 37.1.32.2). Error code: '191'
ERROR: hdhelper exe at C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\HDBox\HDHelper.exe failed to install UWP app with error code 1 - OS Message: C:\adobeTemp\ETR510.tmp\1\SparklerApp\SparklerApp.appx#@#OS_Error_Code: 0x80073cf3#@#OS_Error_String: Windows cannot install package Adobe.CC.XD_37.1.32.2_x64__adky2gkssdxte because this package depends on a framework that could not be found. Provide the framework "Microsoft.NET.Native.Framework.2.2" published by "CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x64 processor architecture and minimum version 2.2.27912.0, along with this package to install. The frameworks with name "Microsoft.NET.Native.Framework.2.2" currently installed are: {Microsoft.NET.Native.Framework.2.2_2.2.27405.0_x86__8wekyb3d8bbwe Microsoft.NET.Native.Framework.2.2_2.2.27405.0_x64__8wekyb3d8bbwe Microsoft.NET.Native.Framework.2.2_2.2.27912.0_x86__8wekyb3d8bbwe Microsoft.NET.Native.Framework.2.2_2.2.27912.0_x64__8wekyb3d8bbwe Microsoft.NET.Native.Framework.2.2_2.2.27011.0_x64__8wekyb3d8bbwe}
ERROR: Failed to install UWP Appx Package with error C:\adobeTemp\ETR510.tmp\1\SparklerApp\SparklerApp.appx#@#OS_Error_Code: 0x80073cf3#@#OS_Error_String: Windows cannot install package Adobe.CC.XD_37.1.32.2_x64__adky2gkssdxte because this package depends on a framework that could not be found. Provide the framework "Microsoft.NET.Native.Framework.2.2" published by "CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x64 processor architecture and minimum version 2.2.27912.0, along with this package to install. The frameworks with name "Microsoft.NET.Native.Framework.2.2" currently installed are: {Microsoft.NET.Native.Framework.2.2_2.2.27405.0_x86__8wekyb3d8bbwe Microsoft.NET.Native.Framework.2.2_2.2.27405.0_x64__8wekyb3d8bbwe Microsoft.NET.Native.Framework.2.2_2.2.27912.0_x86__8wekyb3d8bbwe Microsoft.NET.Native.Framework.2.2_2.2.27912.0_x64__8wekyb3d8bbwe Microsoft.NET.Native.Framework.2.2_2.2.27011.0_x64__8wekyb3d8bbwe}
-------------------------------------------------------------------------------------

.  

TOPICS
Activation, Installation

Views

68

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Morelimo, the rest of the installations work because they are not relying on the Universal Windows Platform to complete the install process. Please see https://helpx.adobe.com/xd/kb/fix-error-code-191-when-installing-xd.html for steps you can take to correct the error.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Ive completed every step besides the folder permission step, nothing. Currently trying to change folder permissions but the  'allow deny' options are greyed out.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

I am sorry to hear that, Moreiimo. Please begin a chat session at https://helpx.adobe.com/contact.html so that direct assistance can be provided.  Please expect to be asked to repeat the troubleshooting steps you have previously performed to correct Error 191.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

It says you are missing the .NET Framework from Microsoft. I don't know why but I think you can download it from here https://dotnet.microsoft.com/download/dotnet/thank-you/runtime-aspnetcore-2.2.8-windows-x64-installe... (for 64-bit Windows). Don't download from anywhere except Microsoft.com !

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Didnt work.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines