Can't update Creative Cloud Desktop Error 507

Explorer ,
Jul 11, 2020 Jul 11, 2020

Copy link to clipboard

Copied

Currently on Win10 Pro 64-bit Version 1909 OS Build 18363.900   

 

Currently on Creative Cloud 5.2.0.436

 

Anyway my new Camera Raw 12.3 is missing some critical functionality, like crop & rotate. I thought no problem, maybe i just need to update it via Creative Cloud. Creative Cloud does say its up to date, but creative cloud is having its own issues in that it won't update / install. It gets to about 30% then fails with an error of 507, which according to Adobe Support is 

Error code 507: Unable to install the product update as the volume is offline.   


I do not have my install on a disconnected drive. 

 

Everything is installed on my C: drive.   Everything on my PC is working perfectly well. 

 

To Troubleshoot, 

 

I have disabled all Anti Virus and Malware applications.

 

I have obviously restarted during all these processes

 

I have used the AdobeCreativeCloudCleanerTool.exe to remove the Creative Cloud and re-installed the Creative Cloud, which it does.. However then when it goes to update, it just fails over and over again around the same time. 

 

So i'm stuck. I really rely on Adobe Camera Raw, when working in Photoshop, as i visible stamp image then make slight adjustments such as my crops in Camera Raw.  

 

Hopefully someone at Adobe has answers, cos the error message itself is bogus. 

 

(Edited By Moderator to remove attached images. See images below in a reply by the OP)

TOPICS
Creative Cloud, Installation

Views

2.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Sep 16, 2020 Sep 16, 2020
After many, many hours on the phone with Adobe Support and finally getting engineering involved, I think I (with Adobe help) have finally solved this problem and in the end it was simple. Close Creative Cloud desktop app by File > Exit Creative Cloud Search for powershell in Start Search Right click and Select Run as admin Paste this command in the powershell windows:  Get-AppxPackage -all AdobeNotificationClient | Remove-AppxPackage -AllUser After this is done. Try to launch Creative Cloud and...

Likes

Translate

Translate
Participant ,
Aug 20, 2020 Aug 20, 2020

Copy link to clipboard

Copied

No solution here. In fact I was so annoyed by the lack of update I stopped all Adobe processes except Genuine Software Check and the Genuine Software Invoker, or something like that. Using autoruns (a MS app) I filtered for just Adobe and unchecked everthing except the Genuine Software entries. Boots up faster. No problem running PP/AE/PS/AI, dynamic link is fine - everything is normal except I don't have the Adobe bloatware hogging resources and I check for updates manually. When I open a PDF doc the Acrobat Updater sneaks back into the startup. Hate that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

After many, many hours on the phone with Adobe Support and finally getting engineering involved, I think I (with Adobe help) have finally solved this problem and in the end it was simple.

 

  1. Close Creative Cloud desktop app by File > Exit Creative Cloud
  2. Search for powershell in Start Search
  3. Right click and Select Run as admin
  4. Paste this command in the powershell windows: 
    Get-AppxPackage -all AdobeNotificationClient | Remove-AppxPackage -AllUser
  5. After this is done. Try to launch Creative Cloud and update it

 

Note, we had gone down the path mentioned in another post regarding registry entries for "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\PackageVolumes" and removing some of those.  That wasted a ton of time and broke other apps I had from the app store.  It also cause the method aboave to fail badly.  Finally I restored the registry and did the above and it worked first time.  CC updated with no errors and all 'seems' fine.  Hope it sticks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

Thanks Calphalon, i can confirm this poweshell command worked for me ! I'm finally updated. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

That did it for me, too! (I had to re-boot the system before Creative Cloud took notice of the changes.)

Thanks a lot!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

I'd been on numnerous calls and remote sessions with Adobe trying to fix the error 507 problem and had many things tried with no success, but this simple powershell solution fixed the problem I had been seeing for over a month. THANK YOU for posting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Finally! A solution that works. Many thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Oh my gosh!!! ....this FINALLY worked.....and it was easy after all....thank you so much Calphalon!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

I hope Adobe techs take note.  Whatever was causing the problem and whatever this fixed, Adobe needs to know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Nicely done! Thank you for the brilliantly simple solution Calphalon, and thanks to the engineering team and Adobe support for the assist. Adobe is taking advantage of some smart people in this forum, but so am I, so...

Best to all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2020 Sep 18, 2020

Copy link to clipboard

Copied

Thank you very much Calphalon. After more than six months of not being able to contact Adobe support and solve this problem, this solution worked. It's unbelievable how bad Adobe tech support is. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

Thank you very much, this also solved the update problem with error code 507 for me, too!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

This worked for me, on windows.  I've never poked at powershell before, but "Get-AppxPackage -all AdobeNotificationClient | Remove-AppxPackage -AllUser" did the trick.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Sharing this link to the solution with the FB community - Caliphon you have saved us all from daily annoyance! 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

Great, worked fine! Thanks for it!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

Calphalon you are amazing!! Thank you for posting this - it did the trick. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2020 Nov 05, 2020

Copy link to clipboard

Copied

Worked like a charm here too! Thanks for your assistance.

Note to self: powershell >< command line.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

genius. thanks for that @calphalon, it worked first time. irritating that i had to search for 30 minutes, waste time on adobe's own suggested fixes, reboot my computer, interrupt my editing... next time I have a problem I'll search the community first.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

Just began having this problem. Thanks for the hardwork, Calphalon! In more than 20 years of using Adobe products, it's usually been users who have had to find and share solutions for systemic issues. It's unfortunate, but I appreciate your work!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

LATEST

Worked perfectly!! Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Wow!  It worked for me.  A few weeks ago I had a very nice Adobe tech spend like 2 hours with me on this issue.  He even did a remote access and finally  gave up.  Kudos to you and whomever at Adfobe helped youy figure this out.!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2020 Oct 05, 2020

Copy link to clipboard

Copied

Thank you. This 507 error problem is just resolved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

This solution might have been extremely easy to implement (it solved the problem for me!) but it clearly was a real headache to figure out. I thank all those who put in the time and effort to get this one resolved!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2020 Nov 04, 2020

Copy link to clipboard

Copied

Many thanks worked a treat. Peter

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines