Highlighted

CC Installer: JavaScript is disabled. Please enable JavaScript and try to sign in again.

Community Beginner ,
Oct 16, 2019

Copy link to clipboard

Copied

I'm currently unable to get Creative Cloud Installer to get past logging in with this error:

JavaScript is disabled. Please enable JavaScript and try to sign in again.

javascript error.png

 

I believe I have the latest Java installed and running well on my fully updated Windows 10 on all my browsers. So I'm a bit stuck.

 

This is possibly connected to my original problem whereby Premiere, After Effects and Lightroom were unable to connect to Adobe for verifiying my account, so basically locking me out. Photoshop and other apps still worked fine. So I'm attempting to do a fresh install of everything, but am now stuck at the very first step!

 

 

 

 

 

Internet Options > Security > Custom Level > Scripting > Active Scripting > Enable

 

After doing that I stopped getting the error, and the tech who helped me via chat told me I could disable it once again, after the install finishes.

 

 

Views

5.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CC Installer: JavaScript is disabled. Please enable JavaScript and try to sign in again.

Community Beginner ,
Oct 16, 2019

Copy link to clipboard

Copied

I'm currently unable to get Creative Cloud Installer to get past logging in with this error:

JavaScript is disabled. Please enable JavaScript and try to sign in again.

javascript error.png

 

I believe I have the latest Java installed and running well on my fully updated Windows 10 on all my browsers. So I'm a bit stuck.

 

This is possibly connected to my original problem whereby Premiere, After Effects and Lightroom were unable to connect to Adobe for verifiying my account, so basically locking me out. Photoshop and other apps still worked fine. So I'm attempting to do a fresh install of everything, but am now stuck at the very first step!

 

 

 

 

 

Internet Options > Security > Custom Level > Scripting > Active Scripting > Enable

 

After doing that I stopped getting the error, and the tech who helped me via chat told me I could disable it once again, after the install finishes.

 

 

Views

5.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 16, 2019

Copy link to clipboard

Copied

JAVA is not JavaScript.  2 entirely different things.  JavaScript must be enabled in your browser -- Chrome, Firefox, MS Edge, Safari, etc...  See link below.

https://helpx.adobe.com/x-productkb/multi/enable-javascript.html

 

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 16, 2019

Copy link to clipboard

Copied

This doesnt work. Im having the same issue and adjusting all the broswer settings didnt do anything.

 

Plus this is a seperate wndow completely unrelated to any interenet browser so Im not sure how this solution would ever work.

 

Does anyone else have any other ideas?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 21, 2019

Copy link to clipboard

Copied

Same problem here. Spent an hour on the phone with Adobe support today. Clearly explained the problem at the start; they insisted on taking over my computer and painfully slowly going through all the steps I had done earlier in the day, only to get to this spot. They tried updating Windows at that point, which took quite a while and they finally said "Call us back when it's updated."
Of course it finished updating as soon as they hung up, but it's an hour+ wait for a call back. And, when I tried installing CC, I once again ended up at this "Javascript is disabled" prompt.

Adobe, when will you quit messing around with your own special installer and just go with the standards??? 😞

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 15, 2019

Copy link to clipboard

Copied

Hi, 

 

Did anybody find a solution for this? I have had the same thing happen today and I cannot find a solution. All of my browsers are enabled. I cannot even uninstall the programs due to the same error appearing over and over again. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 16, 2019

Copy link to clipboard

Copied

I think we fixed this by turning off all the ad blockers I had on my browser. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 07, 2020

Copy link to clipboard

Copied

I don't have any ad blockers on my browser. This answer does not suffice. You corrected your own error with a pretty bad solution in my opinion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 07, 2020

Copy link to clipboard

Copied

Ad blockers are one type of script blocker.  There are many others.  When scripts are blocked, things don't work as expected.

 

 

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 27, 2020

Copy link to clipboard

Copied

Internet Options > Security > Custom Level > Scripting > Active Scripting > Enable

 

After doing that I stopped getting the error, and the tech who helped me via chat told me I could disable it once again, after the install finishes.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 13, 2020

Copy link to clipboard

Copied

This worked for me!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 29, 2020

Copy link to clipboard

Copied

|| Internet Options > Security > Custom Level > Scripting > Active Scripting > Enable

 

This worked. Thanks much for the suggestion!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 16, 2020

Copy link to clipboard

Copied

This also worked for me. Thank You!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 05, 2020

Copy link to clipboard

Copied

WTF!
I just waisted three hours of my life.
(oh well, three hours of my boss...)

Having tried all fancy Adobe Creative Cloud uninstaller-tools and sh** to finally get to the javascript-screen.

I do have Brave, Firefox, Chrome, Edge and Explorer on my computer. And there is 1 that i don't use. That one is also the one that has the most strict safety rules applied. For some reason M$ wants us to use Edge (you know, with the gossip homepage) instead of Internet Explorer. IMHO that one is the most vulnerable browser of all modern browser *which is a joke in itself*

But, the Adobe Cloud uses that MSIE for registering. (though it tries to use Chrome (which is *not* my default browser) for the normal installation). And it uses MSIE for verification at startin up any adobe-app.

 

Now i've set my MSIE to security level "I'm bending over, please use the vaseline i've supplied and come over" and Adobe finally lets me install their software.

I'm an Adobe fanboy, but this is ridiculous!

Thanks to this thread i've found out what the problem was as other errors where without defining Javascript as the problem.

Thanks adobe....

.. back to the drawingboard perhaps??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 07, 2020

Copy link to clipboard

Copied

This reply is quite a few months removed from the initial problem, but I had the same Javascript Disabled message when trying to run Premiere Pro. After a few attempts to correct the issue from what was suggested in the other Replies, I thought about other programs I had recently downloaded (on a Windows 10).  I had installed Rush a few days ago. I uninstall Rush, restarted computer. I ran Adobe CC and had to sign in with my credentials for the first time since installing Adobe CC a number of months ago. Once that was done, Premiere Pro started without the Javascript Disabled message. Is there a correlation? Don't know, but the problem was resolved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 28, 2020

Copy link to clipboard

Copied

Found a solution.

 

Just had this problem and thought I post my solution in case anyone finds this thread and needs help. I had to enable JavaScript in the Internet Explorer browser settings. I have no idea why Adobe goes through Explorer. I have Edge, Chrome and Firefox installed, but it didnt work until I enabled it in Explorer. 

 

The instructions of how to enalbe it is here: https://support.microsoft.com/en-us/help/3135465/how-to-enable-javascript-in-windows

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 29, 2020

Copy link to clipboard

Copied

Thank you SO MUCH! I've just spent and hour trying to find this answer and your link fixed it! I can't believe that it looks for IE to have javascript enabled. It's ridiculous but thank you for finding the answer!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...