Creative Cloud service fail

Explorer ,
Aug 04, 2020 Aug 04, 2020

Copy link to clipboard


Hi. I've been a CC subscriber since 2015.  I ran into the "You have to login" loop because the CC desktop app is broken. I broadcast every day and last week I ended up accidentally broadcasting my email address (luckily my password doesn't show) because the CC server failed mid show and suddenly Photoshop had to close because I "wasn't a registered user".  I got so flustered because I was live and was scrambling to get back to my painting I didn't think about the fact that I was broadcasting my login to the whole world... That sucked.

The CC app then said it was broken and needed to be reinstalled. 


I did all the things: I hit repair (That didn't fix the problem)... then I uninstalled and reinstalled (That didn't fix the problem).  Then I downloaded the CC cleaner (nope).  Then I did the renaming of the two folders in my /Users directory, ran cleaner and did the uninstall reinstall...  And that worked for a week or so.

But this morning Photoshop wouldn't open because it couldn't verify that I was a legal user of this program again (It is saying "Are you connected to the internet?"... since I'm posting this on the Adobe website right now, I'm guessing I AM connected, I can even deduce that I'm connected to Adobe). 

When did the CC server get so militant? I remember being afforded at least 30 days to verify when my internet went down or something went weird in the past (Which it did often, but usually it stabilized inside the 30 day period). As it is, I'm going live today without Photoshop because it's unreliable.  That's not a good thing for software that I have paid more for than any other software I have ever owned.  

Why doesn't the uninstall remove everything? Why am I renaming folders that are left behind when it's uninstalled?  Why does it then REuse those broken folders when it reinstalls?!? 


Now, that I have ranted for a bit (Sorry), can anyone help me on a solution for this?  I've run the cleaner.  I've uninstalled and reinstalled. I've even done the "Rename the two directories to "old" and then run the install again" thing (I don't remember how it all went, but I did every step and that seemed to fix the problem).   Yes, my subscription is up to date.  Yes, I checked no more than 10 minutes ago. My internet was cut yesterday by line workers for about 2 hours, and the CC app was running at the time.  I'm guessing that caused this issue. 

Any thoughts?  

File sync








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation