I can't install PS and LR on Sierra and High Sierra

New Here ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

Hi,

I had my iMac mid 2010 in the service. They formatted my HDD and did clean install of Mac OS Sierra 10.12.6. 

Unfortunately, I can't install PS and LR apps now because they are not compatible with Sierra or High Sierra anymore. The minimum system requirements are version 10.14.0. now.

But I can't update my Mac OS to 10.14.0 because it's older iMac and the highest available Mac OS is High Sierra. I pay for the LR and PS but I can't use them now.

 

What is the solution, please? 

TOPICS
Installation

Views

44

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

Direct Download Links https://prodesigntools.com/tag/ddl MAY help
-you MUST do what it says in Note: Very Important Instructions
-https://prodesigntools.com/adobe-cc-2015-direct-download-links.html#download-instructions
When you do have a download, be sure to copy it to at least one external device
-a usb flash drive or hard drive, or write to a DVD

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines