Highlighted

install previous version compatible with Win7

New Here ,
May 03, 2020

Copy link to clipboard

Copied

Hello,

I know the latest 2020 versions require Window10, but I'm stuck (because of multiple reasons) with Windows7 on my laptop.

I see a lot of similar questions in the previous years, but I'm not able to follow any those.

I'd be intestered in video editors, so any of the Premiere versions.

I manged to download the Creative cloud app but I don't see any option for installing old version of the softwares. I was hoping to at least install a free trial, and they potentially buy the full license.

Is that even possible now? Is there any workaround?

 

thanks

TOPICS
Creative Cloud, Installation

Views

99

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

install previous version compatible with Win7

New Here ,
May 03, 2020

Copy link to clipboard

Copied

Hello,

I know the latest 2020 versions require Window10, but I'm stuck (because of multiple reasons) with Windows7 on my laptop.

I see a lot of similar questions in the previous years, but I'm not able to follow any those.

I'd be intestered in video editors, so any of the Premiere versions.

I manged to download the Creative cloud app but I don't see any option for installing old version of the softwares. I was hoping to at least install a free trial, and they potentially buy the full license.

Is that even possible now? Is there any workaround?

 

thanks

TOPICS
Creative Cloud, Installation

Views

100

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 03, 2020 0
Most Valuable Participant ,
May 03, 2020

Copy link to clipboard

Copied

Sorry... no

 

Adobe only offers the current  and ONE older version, nothing old enough to run on Win7

 

I think Premiere Elements also requires Win10, but go there to check

Here Elements http://www.adobe.com/products/elements-family.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 03, 2020 2