Latest Updates for Creative Cloud

New Here ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

My Creative Cloud Updater says that updates are available, but PS V22, LightR Classic V10 & LightR V4 are incompatible.

What does this mean?

TOPICS
Creative Cloud, Installation

Views

44

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Oct 26, 2020 Oct 26, 2020
This means that the new updates can't be installed on your computer as you don't meet the minimum required hardware/software requirements. Check the minimum system requirements at the following link https://helpx.adobe.com/creative-cloud/system-requirements.html -Manan

Likes

Translate

Translate
Adobe Community Professional ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

LATEST

This means that the new updates can't be installed on your computer as you don't meet the minimum required hardware/software requirements. Check the minimum system requirements at the following link

https://helpx.adobe.com/creative-cloud/system-requirements.html

-Manan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines