Photoshop 2021 ships with an old and known vulnerable version of Node JS

New Here ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

 

Photoshop 2021 ships with an end of support version of NodeJS that is currently vulnerable to a number of vulnerabilities that will not be fixed. This then results in vulnerability warnings in Microsoft Defender and other vulnerability scanning tools.

C:\Program Files\Adobe\Adobe Photoshop 2021\node.exe: v8.11.1

 

I attempted to talk to both Adobe Customer Support and Security Operations about this, and this is my last resort.

For others experiencing the same problem, I am aware that the node.exe executable can be deleted, or even upgrade NodeJS in place - I did want to bring this to Adobe's notice just on the off chance they can rev Node in a future update.

TOPICS
Feature request, Installation

Views

157

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

these are user-to-user forums.

 

to report to adobe, https://www.adobe.com/products/wishform.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

Thanks for the heads up @kglad 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

LATEST

you're welcome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines