Photoshop says Windows incompatible

New Here ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Hi

Trying to install Photoshop but get message saying need to have Windows 1607 ot later but have checked for updates and Windows is completely up to date. Help!

 

Thanks

 

Martin

TOPICS
Installation

Views

290

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

LATEST

Hi

What exact version of Windows do you have, click on the start button and type winver hit return and you should see this dialog popup

2021-05-10 11_14_18-Workspace - IBM Notes.png

The most recent version of Photoshop requires 1809 or later

https://helpx.adobe.com/photoshop/system-requirements.html

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines