Always use testing server for document source?

Community Beginner ,
Dec 20, 2021 Dec 20, 2021

Copy link to clipboard

Copied

Is there anyway to set Dreamweaver to ALWAYS use the testing server for document source? Even though my site is static, for some reason Dreamweaver insists on mangling the layout (in Live view, don't even mention 'design' view) unless I set it to always using the testing server for document source. As it stands every time I open a document I have to remember to set 'View > Live View Options > Use Testing Server for Document Source', and as you can imagine it's getting old really fast.

Views

90

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 20, 2021 Dec 20, 2021

Copy link to clipboard

Copied

For best results, define your site. Go to Site > New site...  Your local site folder should reside on your primary hard drive.

 

 

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 20, 2021 Dec 20, 2021

Copy link to clipboard

Copied

If you have a local testing server installed, make that your local site folder.

C:\testing_server\default_web_folder\your_site\

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

Thanks Nancy, but setting up Sites > New Site was the first thing I did when I began working on this project (or any project in Dreamweaver) days ago. The local site folder is indeed on my primary hard drive, and the local testing server (macOS Apache) is configured to use that same folder to serve via a localhost alias.

 

The problem is the View > Live View Options > Use Testing Server For Document Source settings are not persistent between sites nor documents within a site. It would be ideal if Dreamweaver made this an option within the Manage Sites > {Site} > Server configuration dialogs so that it would be used by default on all documents within a specific site.

 

If I set 'Use Testing Server For Document Source' Dreamweaver's own testing server mangles the layout in parts (specifically masonry grid layouts that use JS to determine container sizes), but as this setting is not persistent it has now become a mandatory extra step everytime I open a new file (I'm working in split code | live view).

 

FWIW I also tried Dreamweaver Preferences > Real-time Preview > Default to Static Browser Preview setting but that doesn't seem to solve the problem either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

If the preferences are not sticking for you, have you tried to restore them: https://helpx.adobe.com/dreamweaver/kb/restore-preferences-dreamweaver.html ? If not, can you try loading DW in another user profile (even a guest) on your computer and see if you can replicate the issue.  This to me sounds like an OS permissions issue where the preferences are not saving.  At a best case scenario re-creating preferences will do the trick. At a worst case you may need to migrate to a new user account.  As a Mac user myself I've had to go through this in the past when upgrade over upgrade eventually impacts my user account.

 

Also - as a word of advice, unless you are well-versed in the nuances of the Mac OS built-in Apache server, I would highly recommend a third party app like mamp for a testing server as opposed to the built in one.  The built is in very limited out of the box, and can be difficult to manage or customize compared to other options like a MAMP server.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

Thanks Ben. I'll try re-creating the preferences and creating a new user profile, but this is a fresh install (done <1 week ago) of macOS Monterey 12.1 where the drive was fully erased (both partition/drives in the drive group) and the OS was reinstalled via USB.

 

Yeah, I'm aware of the limitations of the macOS supplied version of Apache, but I'm literally only using it to serve static pages and resources from various localhost aliases—so I'm not too concerned about any advanced config or integrating other applications and services. If I need anything more complicated there's always $ brew install httpd and VS Code. 🙂

 

Dreamweaver templates and libraries are a really nice and easy solution for static sites, and don't require any elaborate $ npm install …, configuration, build pipeline, or maintenance. I'm currently migrating a site using 11ty (and various plug-ins) to Dreamweaver (using templates and libraries) in an effort to simplify my life.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

Sadly, deleting the app preferences and switching to a new user account hasn't resolved the problem. Everytime I open a new document I still have to set both View > Live View Options > Use Testing Server For Document Source, and View > Live View Options > Hide Live View Displays.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 23, 2021 Dec 23, 2021

Copy link to clipboard

Copied

Is this happening with all sites or just a particular site that you are working in?  Typically that will resolve the issue, but again if preferences are not sticking, next thing I would recommend considering a re-install because this appears to be a deeper rooted issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 24, 2021 Dec 24, 2021

Copy link to clipboard

Copied

LATEST

which Apache do you rely on, the one provided by default on MacOs, or on a personal stack you installed yourself (MAMP, XAMPP...)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines