• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

My old contact form has stopped working

Participant ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Today I went back to an old site of mine that I had not touched for some time and I find the contact form is failing after submitting it:

  Application Error
     An error has occurred in the program
close sendmail pipe failed, mailprog=[/usr/sbin/sendmail david@higgsy.com] at eval (11) line 108.

 

 

I think the way it works is the form Action is to reach out across the internet and run the FormMail.pl residing in the root of my domain.  The error message above suggest to me there has been a fault whithin the formmail script when it tries to run sendmail

 

Am I on the right track here?  My website is at

http://dave.higgsy.com/ and go to Contact

 

any suggestions as to what area I should investigate would be gratefully recieved, many thanks in advance

Views

427

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Apr 12, 2021 Apr 12, 2021

If the form has suddenly stopped working after working when initially deployed/tested and you have made no recent updates to the code then that points to the server being updated without your knowledge and the script is no longer compatible. This should not happen without your prior knowledge but chances are its a shared server and updates happen 'behind your back'. Having said that FormMail.pl is a very old dated perl script for handling form submissions, it might be time to bite the bullet and

...

Votes

Translate

Translate
Community Expert ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

I don't know anyone who still uses Perl programming (aka cgi-bin) for forms. If your server supports Perl, it very likely supports modern PHP  code too which is what we use to collect & process form data in the 21st century.   But writing secure scripts requires some coding skills.  This PHP mail sending library is the one most web hosts recommend.

https://github.com/PHPMailer/PHPMailer

 

Alternatively, use a new contact form from a 3rd party service like Wufoo.com or JotForm.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

If the form has suddenly stopped working after working when initially deployed/tested and you have made no recent updates to the code then that points to the server being updated without your knowledge and the script is no longer compatible. This should not happen without your prior knowledge but chances are its a shared server and updates happen 'behind your back'. Having said that FormMail.pl is a very old dated perl script for handling form submissions, it might be time to bite the bullet and update the way the information from the form is handled.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Contact the hosting provider to find out which scripts they support.  Some of the cheaper hosting plans don't support scripts to save on overhead.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

many thanks to Nancy and Mr Osgood.  I have begun to look at phpmailer so maybe stand by for questions!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

You might want to investigate if your remote server supports the simple php mail function as that is a lot simpler to deploy than phpMailer.

 

Some hosts stopped supporting the default php mail function by default because a lot of amatuer developers didnt know how to use it responsibly and it was attracting spammers who could send mail through the hosting providers mail service, which potentially would get them blacklisted.

 

If you validate the form information correctly this can't happen but amatuers most would not use any validation, so the form was open to abuse. phpMailer usually requires authentication so its more secure in terms of spamming and less open to being incorrectly deployed by amatuers

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

It is worth keeping an eye on php versions as some can be dropped by hosting companies as they are updated leaving the mail script unusable.

- "Good English is an Art."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

LATEST

thanks GailSECD

they notify me when they are retireing old versions and also try to get me to pay if i need to still use an old version going forward so I'm all up to date on that front - 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines