• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Permissions problem on a new MacBook and DW2020

Explorer ,
May 29, 2020 May 29, 2020

Copy link to clipboard

Copied

Just started using the DW2020 after upgrading from a 10 year old version. Just now I was trying to add a photo onto an existing page and DW said access to the folder that contains the photo is denied. I am the only user on the computer so I can't see how I could be denied anything as I'm also the admin. It could be a problem with my new MacBook but right now I can't add new photos to my website.

TOPICS
Error , Import and export , Performance

Views

945

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , May 29, 2020 May 29, 2020

1. Restart your computer.

2. Launch DW.

3. Define your local site folder. 

     a) Go to Site > New site or Manage sites. 

     b) Tell DW where your local site folder resides on your primary hard drive.  Example:  C:\MySite\

 

That's a critical first step.  Otherwise DW cannot manage assets for you.

 

Post back if you still need help.

 

Votes

Translate

Translate
Community Expert ,
May 29, 2020 May 29, 2020

Copy link to clipboard

Copied

Is the photo within the site?  If it is not, does it reside in the Documents, Downloads, or Desktop Folder?  If it is in one of the latter folders, go to Settings --> Security and Privacy --> Privacy Tab and make sure DW has permission to access those folders. In the newest Mac OS, those are system protected folders that an app must request access to.  DW should have prompted that initially but if it didn't you should be able to grant access there.

 

If it's not any of the above we may need more specifics about the file and where it is on your system.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 29, 2020 May 29, 2020

Copy link to clipboard

Copied

The photo was dragged into the site folder that lives on my desktop. My Dreamweaver does not have "settings" it does have preferences, but preferences doesn't have any security/privacy tab.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 29, 2020 May 29, 2020

Copy link to clipboard

Copied

The settings is your OS settings, not Dreamweaver.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 29, 2020 May 29, 2020

Copy link to clipboard

Copied

OK, I checked them, it says in Privacy>Full Disk access DW is checked, in Files and Folders it says DW has Full Disk Access.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 29, 2020 May 29, 2020

Copy link to clipboard

Copied

1. Restart your computer.

2. Launch DW.

3. Define your local site folder. 

     a) Go to Site > New site or Manage sites. 

     b) Tell DW where your local site folder resides on your primary hard drive.  Example:  C:\MySite\

 

That's a critical first step.  Otherwise DW cannot manage assets for you.

 

Post back if you still need help.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 29, 2020 May 29, 2020

Copy link to clipboard

Copied

LATEST

That did the trick, all good now! Thank you so much Nancy for your help. 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines