Stop DW from reformatting

Explorer ,
Feb 27, 2021 Feb 27, 2021

Copy link to clipboard

Copied

Since you all helped me so much I'm back.
Every time I open DW I notice it has reformatted my text. I know my style is not what Adobe wants, but it is what I am comfortable with. You all helped me update from DW 2015, which did not mess with my formatting like 2021 does. Is there a way to make it stop?

Again, thank you for helping me update from 2015. So simple once you know how.

Rick

Views

135

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 27, 2021 Feb 27, 2021

Copy link to clipboard

Copied

What do you mean it has reformatted your text?  Can you post a screenshot and give us insights into your code?  At its core DW is just a text editor to edit HTML so there is nothing that should be reformatting your pages unless there is an error in your code or something is causing an error in your system/config.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 27, 2021 Feb 27, 2021

Copy link to clipboard

Copied

My formatting
[image: image.png]


DW formatting
[image: image.png]

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 27, 2021 Feb 27, 2021

Copy link to clipboard

Copied

Your images were of no help.

 

Maybe this will help: https://helpx.adobe.com/au/dreamweaver/using/format-css-code.html

Wappler, the only real Dreamweaver alternative.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

This web forum doesn't support email attachments.  So nobody can see your images.

  • From your Document Toolbar, are you in Code view, Design view or Live view?
  • Is this question related to code formatting in the Code view panel?
  • Or is this about how your page content is styled in Design / Live view?
  • Can you show us your code or better yet a URL to your online website?

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

To stop DW from helping you write code...

1.Go to Edit > Preferences
2. Click Code Format
3. Set your prefered Indent and Tab size
4. Click Code Hints
5. Set Close Tags to Never and uncheck both Auto Completion boxes
6. Click Code Rewriting
7. Uncheck "Fix invalidly nested and unclosed tags" (note: this will allow you to write some seriously inalid code without much warning)
8. Hit Apply
9. Go to Tools > Tag Libraries
10. Set the Line Breaks and Contents you would like to use for each tag
11. Hit OK (this will allow DW to Apply Source Formatting in a manner you prefer, when you use the command)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

Jon,

Thank you. Copied your message to Notepad 'cause I know I'll forget. Thanks.

Rick

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

LATEST

Thank you everyone. Thank you Jon. I'm back to my old clumsy style.

Rick

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines