Why won't my website upload onto the web?

New Here ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

Right, I have a site which I want uploading to the web via the Azure webhosting platform.

1) I established a remote server connection which came back with no problems when tested.

2) The Local Folder Directory is set to the Adobe Creative Cloud folder.

3) The Remote Server root directory is "/"

4) My default page is directly in the root folder of the remote server, where it should be.

So why then, won't my website upload when I hit the "Put" button, telling it to upload ALL files from the Local to the Remote Server? I dont understand how a computer, an inanimate object and programmed to do what the user tells it to, behaves like an awkward, disobedient child who won't do as its told?

2018-10-25 (3)_LI.jpg2018-10-25 (2)_LI.jpg2018-10-25 (5)_LI.jpg

Views

346

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

The root directory for azure is -

/wwwroot

not /

for a full explanation see -

https://blogs.msdn.microsoft.com/kaushal/2014/08/01/microsoft-azure-web-site-connect-to-your-site-vi...

Also you may have a problem using php for your mail handler, as azure normally requires .net code for mail, (C# or asp.net).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

Right, so why then do I get this message?2018-10-25 (7)_LI.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

As you have blocked out the ftp address and the web url, I cannot tell you.

It only requires a '/' extra or missing to change the folder for the upload to fail. It may be worth using filezilla as in the demo link, to ensure you have the correct file path. If it does not work in filezilla it certainly will not work in Dw.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

LATEST

See my screenshot below.  Replace public_html/ with wwwroot/

CC-RootFolder.jpg

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines