Highlighted

Adding an Animate CC file to Dreamweaver

Participant ,
Nov 09, 2018

Copy link to clipboard

Copied

I'm testing out adding an animation I made in Animate CC to my website. I have followed all the instructions for publishing in Animate CC as well as adding the .oam file to the website, but it is not working. The file previews in Dreamweaver, but it does not show up when viewing on any web browser. Is there another way to add the animation to a website?

<html>

<head>

<meta charset="utf-8">

<title>Untitled Document</title>

</head>

<body>

<object id="EdgeID" type="text/html" width="1044" height="788" data-dw-widget="Edge" data="../animation_assets/Cyber_Security_Cycle/Assets/Cyber_Security_Cycle.html">

</object>

</body>

</html>

Untitled Document

Okay, I figured out a different way. I ignored the .oam file completely and just focused on the .hmtl file that animate CC created. by using an iframe I can insert the HTML file into my webpage and it will work. 

Views

563

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adding an Animate CC file to Dreamweaver

Participant ,
Nov 09, 2018

Copy link to clipboard

Copied

I'm testing out adding an animation I made in Animate CC to my website. I have followed all the instructions for publishing in Animate CC as well as adding the .oam file to the website, but it is not working. The file previews in Dreamweaver, but it does not show up when viewing on any web browser. Is there another way to add the animation to a website?

<html>

<head>

<meta charset="utf-8">

<title>Untitled Document</title>

</head>

<body>

<object id="EdgeID" type="text/html" width="1044" height="788" data-dw-widget="Edge" data="../animation_assets/Cyber_Security_Cycle/Assets/Cyber_Security_Cycle.html">

</object>

</body>

</html>

Untitled Document

Okay, I figured out a different way. I ignored the .oam file completely and just focused on the .hmtl file that animate CC created. by using an iframe I can insert the HTML file into my webpage and it will work. 

Views

564

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 09, 2018 0
Adobe Community Professional ,
Nov 09, 2018

Copy link to clipboard

Copied

Your animation file itself was either not uploaded, or it was uploaded to the wrong location.

Right now, when I go to the location being referenced by the link in your source, I get a 404 File Not Found error.

Remember, the animation file is not part of the .html file, it's just referenced by it, so it also needs to be uploaded, and to the location that the link points to in your .html file.

It's also possible, with all of the CamelCase in your file names, that you have a case mismatch between the file and the link. On your local computer, that wouldn't be an issue, since Mac and Windows are not case sensitive. Hello.html and HELLO.html would be the same file. Servers are usually CasE SenSiTivE though, so it would treat Hello.html and HELLO.html as two separate files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Participant ,
Nov 09, 2018

Copy link to clipboard

Copied

I did upload it, though. I put all the files in the same folder and uploaded them to the server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Adobe Community Professional ,
Nov 09, 2018

Copy link to clipboard

Copied

You replied while I was editing my post, check for a case mismatch between your file and the link used. Servers are typically case sensitive and would treat any mismatch as a separate file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Adobe Community Professional ,
Nov 09, 2018

Copy link to clipboard

Copied

If all of the files are in the same folder, as you say above, that would mean the link in your .html to the animation is now wrong on the server.

When you upload your local files to the server, they need to have the exact same directory structure, or references within them to other files will break.

You can't have...

page.html
folder
     page2.thml

...locally and then change it to...

folder
     page.html
     page2.html

...without changing the links within the files to point to the right locations.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Participant ,
Nov 09, 2018

Copy link to clipboard

Copied

Did that too. I even deleted all the files and republished just to be sure. I did not hand code it, but went in and clicked on the correct .oam file, so I also know I didn't type it in wrong. And if it was just the html link that didn't work, I would think that I had just typed the path wrong, but the in program preview also doesn't work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Adobe Community Professional ,
Nov 09, 2018

Copy link to clipboard

Copied

Right now, using your .html page linked above, it is saying the path to your animation file is...

../animation_assets/Cyber_Security_Cycle/Assets/Cyber_Security_Cycle.html

This means "move up one directory from this page" (../) and look for a folder called animation_assets, within that folder is another, called Cyber_Security_Cycle and within that another called Assets where you will find a file called Cyber_Security_cycle.html


Right now, when the browser goes to the address given, there's nothing there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Participant ,
Nov 09, 2018

Copy link to clipboard

Copied

I'll create the Assets folder and move things. That was the code that dreamweaver automatically entered itself so I didn't check that. There also wasn't anything in the directs that I would need to create such a folder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Adobe Community Professional ,
Nov 09, 2018

Copy link to clipboard

Copied

DW doesn't add folders that aren't in the local site to file paths.

Are you working from a Defined Site in DW?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Participant ,
Nov 09, 2018

Copy link to clipboard

Copied

Yes, I am aware that DW doesn't create folders on its own. What I'm saying is that the code DW created when I inserted the "Animated Composition" had added folders in the code which I had never created nor do I know why they are there. The animation_assets/Cyber_Security_Cycle/Assets/ is not a path I linked to or created myself. I just attempted to create this path and move the files, but this still did not work.

Yes, I am working in a defined site.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Adobe Community Professional ,
Nov 09, 2018

Copy link to clipboard

Copied

Actually, DW creates folders on its own quite often, when certain features of the program are used, especially "Assets" and "Templates" folders.

What I'm saying is it doesn't add those folders to link paths unless they exist in a site. There would be no way for it to find that location locally, and the file wouldn't work in local previewing, if the directories in the file path didn't exist.

In any case, all you should need to do is simply re-link the source of your <object> tag to the correct location and upload all of the files and folders being used.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Participant ,
Nov 09, 2018

Copy link to clipboard

Copied

Okay, I figured out a different way. I ignored the .oam file completely and just focused on the .hmtl file that animate CC created. by using an iframe I can insert the HTML file into my webpage and it will work. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0