Highlighted

Adobe dreamweaver cs6 has stopped

New Here ,
May 18, 2012

Copy link to clipboard

Copied

Hi,

I'm using Adobe dreamweaver cs6 trial. I open any file, then click View Code. The program is not responding. The error message "Adobe Dreamweaver cs6 stopped" and the program has closed.

I have reinstalled. It crashes DW to close again.

I'm running on Windows 7 x64 sp1 ultimate, cpu corei7 q2630 ,ram8gb ,nvidia gt540m

Thank,

Paul.


I just want to offer my two bits on how I personally seemed to have solved this issue.

Quick background; Dreamweaver would hang every 30 to 90 seconds for about a minute or two each time. It was possibly the worst, constant experience I've ever had with software; especially a piece of software I was using constantly.

This and other theads all seem to agree that the issue is with Dreamweaver "leaving this file" and getting data from outside of this file; like images, scripts, etc.

I turned off all the recommended settings, like not having it run java script, etc. Nothing helped.

Finally it occurred to me that a bunch of the sites I was working on were not defined as "sites" in Dreamweaver. I have been using filezlla for FTP and was simply opening them from filezilla. Dreamweaver was, I guess, treating them all as independent pages rather than part of a site as a while. I'm guessing that because Dreamweaver does not realize that that all the links on the page are local (which makes no sense because the images DO show up.... but whatever), it feels a need to scour the internet or something for these links.

But who knows, it seems to have solved my problem for now. (30 minutes in; fingers crossed).

TL/DR: make sure the page you are working on is part of a defined site by going to the "site" menu and going to "new site" or "manage site".

Views

17.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe dreamweaver cs6 has stopped

New Here ,
May 18, 2012

Copy link to clipboard

Copied

Hi,

I'm using Adobe dreamweaver cs6 trial. I open any file, then click View Code. The program is not responding. The error message "Adobe Dreamweaver cs6 stopped" and the program has closed.

I have reinstalled. It crashes DW to close again.

I'm running on Windows 7 x64 sp1 ultimate, cpu corei7 q2630 ,ram8gb ,nvidia gt540m

Thank,

Paul.


I just want to offer my two bits on how I personally seemed to have solved this issue.

Quick background; Dreamweaver would hang every 30 to 90 seconds for about a minute or two each time. It was possibly the worst, constant experience I've ever had with software; especially a piece of software I was using constantly.

This and other theads all seem to agree that the issue is with Dreamweaver "leaving this file" and getting data from outside of this file; like images, scripts, etc.

I turned off all the recommended settings, like not having it run java script, etc. Nothing helped.

Finally it occurred to me that a bunch of the sites I was working on were not defined as "sites" in Dreamweaver. I have been using filezlla for FTP and was simply opening them from filezilla. Dreamweaver was, I guess, treating them all as independent pages rather than part of a site as a while. I'm guessing that because Dreamweaver does not realize that that all the links on the page are local (which makes no sense because the images DO show up.... but whatever), it feels a need to scour the internet or something for these links.

But who knows, it seems to have solved my problem for now. (30 minutes in; fingers crossed).

TL/DR: make sure the page you are working on is part of a defined site by going to the "site" menu and going to "new site" or "manage site".

Views

17.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 18, 2012 0
New Here ,
May 18, 2012

Copy link to clipboard

Copied

I have a problem with the php file with character set = utf-8.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
Adobe Community Professional ,
May 18, 2012

Copy link to clipboard

Copied

I know this is not your specific issue, but the KB answers are relevant.  Try #12 and #4:

http://helpx.adobe.com/dreamweaver/kb/troubleshoot-javascript-errors-dreamweaver-cs4.html

If that doesn't work, try using DW in a new user account on Windows to rule out user profile corruption.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
New Here ,
May 18, 2012

Copy link to clipboard

Copied

Not work for me.

I have reinstalled Windows. It crashes DW to close again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2012 0
New Here ,
May 23, 2012

Copy link to clipboard

Copied

I'm having the same issue at the original poster, except if I wait a while it will end up loading. Any change I make requires a 30 second wait with the "not responding" message until it takes effect.

This is extremely annoying. I've been saving my money to buy CS6 Design Premium in a few more weeks.... now I'm hesitant to do so. Please fix this so I don't have to buy CS5

I'm running Windows 7 x64 sp1 pro, core i7 960, 12gb ram, nvidia gtx570, current updates and drivers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 23, 2012 0
Adobe Community Professional ,
May 23, 2012

Copy link to clipboard

Copied

Any change I make requires a 30 second wait with the "not responding" message until it takes effect.

Does this happen in Code View?  Design View?  Live View?

Some people have reported issues in Design View when their code contained links to external scripts like Facebook Badges, ADD THIS widgets, etc...

Go to View > un-tick Display External Files.

Similarly, Live View can get sluggish when these same pages are allowed to execute external JavaScripts.  What worked for me is going to View > Live View Options > turning off JavaScripts.

Nancy O.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 23, 2012 0
New Here ,
May 23, 2012

Copy link to clipboard

Copied

While I think you're on the right track, changing those options didn't help.

To help clarify on the issue I'm having, I'm using code view, and it locks up when I hit delete or backspace. I think it freezes for a while with other keys, but I don't recall now that I've stopped using it. It doesn't happen when I'm editing a new xhtml template file, but when I'm working on a file for my site that uses external CSS and scripts. It also doesn't lock up when adding new code, only when removing code.

Any more ideas?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 23, 2012 0
New Here ,
May 24, 2012

Copy link to clipboard

Copied

Nancy O. wrote:

Any change I make requires a 30 second wait with the "not responding" message until it takes effect.

Does this happen in Code View?  Design View?  Live View?

Some people have reported issues in Design View when their code contained links to external scripts like Facebook Badges, ADD THIS widgets, etc...

Go to View > un-tick Display External Files.

Similarly, Live View can get sluggish when these same pages are allowed to execute external JavaScripts.  What worked for me is going to View > Live View Options > turning off JavaScripts.

Nancy O.

Work for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 24, 2012 0
Adobe Community Professional ,
May 24, 2012

Copy link to clipboard

Copied

Jay Forte wrote:

While I think you're on the right track, changing those options didn't help.

Any more ideas?

Try this help article.  Replace CS5  with CS6 in the instructions.  Then restart PC.

DW Hangs when opening document

http://kb2.adobe.com/cps/887/cpsid_88742.html

Nancy O.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 24, 2012 0
New Here ,
Jun 04, 2012

Copy link to clipboard

Copied

I have had this 'fenomenon' since DW4 ...

Even if I use a state-of-the-art muscle workstation with dual-sixcore Intel CPUs running in nearly 4GHz and having 32GB high-speed low-latency RAM, using gigabit ethernet connection to the fileserver I still have to wait up to 1 minute for a standard-size file (50KB) to be loaded !!

 

I think it have something to do with the network-mounted disk I use. When I use Wireshark to monitor the network connection (while opening a file in the DW6) I see MASSIVE of connectioins to the fileserver.

It loads ALL <CFINCLUDE>s, CSSs, JavaScripts and external links (somtimes even <A></A> records!)....

Due to the fact that open/close every single network transaction per line and file in a very in-effective way and makes analyzes on each and every result; it takes a LOT of time to process.

 

When I copy a file from/to the directory in the mounted disk, outside DW6, I can read/write in more than 100MB per second.

I really think this is a bug or an "unwanted feature" in DW. I haven't (yet) found any way to turn this "feature" off.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2012 0
New Here ,
Jun 04, 2012

Copy link to clipboard

Copied

Update: I tried the registry edit "fix" that Nancy O. posted and it unfortunately didn't solve the issue... This is the first time I've had this problem and I've been using Dreamweaver for 10 years.....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2012 0
New Here ,
Jun 05, 2012

Copy link to clipboard

Copied

I made some deep analyzes using a network sniffer and found that DW6 checks/reads almost ALL files in the working directory every time you open a .cfm file!

The larger your project is, the longer it takes.

You may see for your self in http://46b445c30ff17ae0.paste.se/

In the above example I just opened ONE (1) 40Kbyte .cfm file into DW6.

The network interactions between Windows7 and DW6 seems to be VERY crappy...

I've got 977 "IPv4:  Bad checksum":s while opening a less than 40 Kbyte file

And lots of issues like;

SMB      93     Trans2 Response, GET_DFS_REFERRAL, Error: STATUS_NOT_FOUND

SMB      93     Trans2 Response, QUERY_PATH_INFO, Error: STATUS_OBJECT_NAME_NOT_FOUND

etc.

There is NO linked/related/included/referred files in any code that do not exist, so "_NOT_FOUND" is NOT related to any real missing files.

And NO, it is NOT my local network. I have this problem on several worksations in various offices/locations. They all have good network connections. No problems what-so-ever outside Dreamweaver.

And YES, I have tried ALL tips and trixs in the book (read: Internet). You may minimize the impact of this issue by turning off vairous features in DW, but still the main problem still exists, and it's network-related.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2012 0
New Here ,
Jun 05, 2012

Copy link to clipboard

Copied

As a note to help any confused readers just jumping into this thread:

This is for files other than .cfm as well. My specific issue is related to .html / .htm files that are linking to javascript files. As garpenholm previously mentioned it appears to be due to linked files creating a large number of connections as the files are analyzied.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2012 0
Adobe Employee ,
Jun 05, 2012

Copy link to clipboard

Copied

Have you tried disabling Related Files?

It's in the General section of the Preferences, under Document Options.

After you disable it, be sure to close any open documents (or restart Dreamweaver) to determine if it helps or not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2012 0
New Here ,
Jun 05, 2012

Copy link to clipboard

Copied

That didn't work but it led me to figure out what it was. I noticed that it only seemed to happen with certain files and not others, so it most likely wasn't a dreamweaver problem. I opened one of the files that were causing it to come up as "not responding" and started removing scripts one by one. It turns out a script I was using for hellobar (see hellobar.com) was causing the problem. I will paste the script below to hopefully help others with this issue, but I'm wondering why it would cause DW to stop responding for specific minor changes to the document (like deleting a line/paragraph/whatever).

<script type="text/javascript" src="//www.hellobar.com/hellobar.js"></script>
<script type="text/javascript">
    new HelloBar(44940,61865);
</script>

Thanks for everyone's help. I hope this is the source of your issue as well Garpenholm!

Jay Forte

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2012 0
New Here ,
Oct 10, 2012

Copy link to clipboard

Copied

This didn't help either. The files I'm opening are H5BP files (html5 boiler plate) and each file takes around 30 seconds to open (right click + open in dreamweaver).

One workaround I found out is to create a Site (Site > New Site) then point it to where your HTML files are. The file should open properly without any delays, but still this is not the ideal experience as I don't want to create Site for each folders I'm working on.

Hope they fix this bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2012 0
Community Beginner ,
Jun 09, 2012

Copy link to clipboard

Copied

I am having this same problem trying to edit a wordpress php template ... I have gone into DW prefs and turned OFF (both either unchecked, or checked and in drop down 'disabled'); and it appears in CODE VIEW trying to edit the single.php template, DW hangs when opening ("not responding" error in Windows frame for app). I am running the full cloud license version of CS6 V12 bulid 5808, Win7/64, Core i7, 32GB RAM, SSD OS and WD velociraptor. It does appear to be a bug, as I never had this isssue with editing wordpress php files since 2005.   This needs to be addressed in an update ASAP. I can edit in Textpad in 20 sec., it takes 5 minutes to deal with couple of copy-paste items in WD, which is annoying since I just paid full upgrade from CS5 to CS6 cloud; and uninstalled DW/CS5.5. ARGH.

Each time an edit is made there is a short buffer effect, as if the program is trying to do something. I first noticed this when trying to save something and the * stayed in file name, like it was thinking about the doc before letting me save. But today, it became a big problem with one file, as EVERY TIME I make an edit, it either immediately times out, or I can type in a couple of words ... then ... wait ... freeze ... wait ..... wait .... wait .... okay works again. Phone home making text edits? Very frustrating. Can't use DW to update my site today due to this bug.

It does appear that any php file with code that references javascript .,.. mine has calls to (1) addthis button, (2) twitter.com/share and (3) facebook (//connect.facebook.net) elements .... but hey... this is CODE view, why try to connect to those items in code view when trying to edit TEXT ?

BUG. BUG. BUG. Please fix. Make DW CS6 have complete *unhook* option from any "go out and look for stuff on web/net" ... options in DW6 panel obviously do NOT work in build 5808.

THANK YOU!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2012 1
Adobe Community Professional ,
Oct 10, 2012

Copy link to clipboard

Copied

It does appear that any php file with code that references javascript .,.. mine has calls to (1) addthis button, (2) twitter.com/share and (3) facebook (//connect.facebook.net) elements ....

You might try commenting out the code to external widgets (addthis, twitter, etc...) as these are known culprits.

Also do the following:

Go to View > Display External Files and disable (remove check mark).

Use the instructions below and substitute paths to CS5 or CS5.5 with CS6

http://helpx.adobe.com/dreamweaver/kb/hang-opening-document-dreamweaver-cs5.html

Hope this helps,

Nancy O.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2012 1
New Here ,
Feb 13, 2013

Copy link to clipboard

Copied

Had the same problem with CS6. I modified my registry as recommended in Nancy O's link to no avail.

Here's what worked for me:

  • The hang started when I switch sites and DW tried to update the site cache.
  • After numerous restarts, reboots, and the registry mod I got smart.
  • I went to C:\Users\MyUserName\AppData\Roaming\Adobe\Dreamweaver CS6\en_US\Configuration\SiteCache
  • I deleted the cache folder for the offending site, as well as the corresponding .dws file for the site.
  • DW CS6 now works.

Hopefully this helps anyone else encounter the hang issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2013 0
Explorer ,
May 20, 2013

Copy link to clipboard

Copied

I just want to offer my two bits on how I personally seemed to have solved this issue.

Quick background; Dreamweaver would hang every 30 to 90 seconds for about a minute or two each time. It was possibly the worst, constant experience I've ever had with software; especially a piece of software I was using constantly.

This and other theads all seem to agree that the issue is with Dreamweaver "leaving this file" and getting data from outside of this file; like images, scripts, etc.

I turned off all the recommended settings, like not having it run java script, etc. Nothing helped.

Finally it occurred to me that a bunch of the sites I was working on were not defined as "sites" in Dreamweaver. I have been using filezlla for FTP and was simply opening them from filezilla. Dreamweaver was, I guess, treating them all as independent pages rather than part of a site as a while. I'm guessing that because Dreamweaver does not realize that that all the links on the page are local (which makes no sense because the images DO show up.... but whatever), it feels a need to scour the internet or something for these links.

But who knows, it seems to have solved my problem for now. (30 minutes in; fingers crossed).

TL/DR: make sure the page you are working on is part of a defined site by going to the "site" menu and going to "new site" or "manage site".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 20, 2013 0
New Here ,
Apr 16, 2014

Copy link to clipboard

Copied

Yes!!! Thank you! It's been driving me insane and nuts at the same time and reading through all the threads of people experiencing the same problem and having to apply registery fixes, file dumps, changes etc... NUTS! Your solution worked like a charm! Al I did was go to "new site" and then added one called "someidiotnotdoinghisjobatadobe", FIXED... you can call it anything but I thought it was suitable at the time LOL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2014 0
Explorer ,
Apr 16, 2014

Copy link to clipboard

Copied

Glad I could help! Since this is so clearly easily solvable, and it seems it would happen to every single person in this circumstance, I'm suprised Adobe hasn't implmented a fix, or at least a warning to define a site. About 50% of my decision to buy a new computer last year was based on my inability to figure this out and therefore my assumption it was some kind of weird hardware problem that simply reinstalling windows and adobe CS had failed to solve. Ugh. I do like my new computer though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2014 0
New Here ,
Oct 08, 2019

Copy link to clipboard

Copied

Doesn't work for me I'm afraid 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2019 0