Highlighted

Bootstrap - "component is not fully compatible with current bootstrap"

New Here ,
Apr 24, 2018

Copy link to clipboard

Copied

Everything was working great using Bootstrap 4. I had left my project for one week and when I returned, the navigation bar had reverted back to a simple text format. I tried to troubleshoot what happened and decided to delete the entire 'Navbar' (fixed to top) and start over. When I added the new 'Navbar' the following error came up:

"The component is not fully compatible with the current Bootstrap CSS/JS file (lower than v3.0). A new Bootstrap CSS/JS file will be created and linked from the document."

I was still unable to add a 'Navbar' with the styling it is supposed to have. I moved on to add a 'Grid Row With Column' and again the same error came up. I was also unable to see the Div unless I added text within it. Before I was at least able to see a blue border around the div with the ability to scale the columns in or out. After the error began this was also affected.

I have screenshots, if needed.

Please help!

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Bootstrap version 3 is not compatible with version 4. 

You should  have only one reference to Bootstrap, Popper and jQuery. 

Also check your code for validation errors.

Views

531

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Bootstrap - "component is not fully compatible with current bootstrap"

New Here ,
Apr 24, 2018

Copy link to clipboard

Copied

Everything was working great using Bootstrap 4. I had left my project for one week and when I returned, the navigation bar had reverted back to a simple text format. I tried to troubleshoot what happened and decided to delete the entire 'Navbar' (fixed to top) and start over. When I added the new 'Navbar' the following error came up:

"The component is not fully compatible with the current Bootstrap CSS/JS file (lower than v3.0). A new Bootstrap CSS/JS file will be created and linked from the document."

I was still unable to add a 'Navbar' with the styling it is supposed to have. I moved on to add a 'Grid Row With Column' and again the same error came up. I was also unable to see the Div unless I added text within it. Before I was at least able to see a blue border around the div with the ability to scale the columns in or out. After the error began this was also affected.

I have screenshots, if needed.

Please help!

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Bootstrap version 3 is not compatible with version 4. 

You should  have only one reference to Bootstrap, Popper and jQuery. 

Also check your code for validation errors.

Views

532

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 24, 2018 0
Adobe Community Professional ,
Apr 24, 2018

Copy link to clipboard

Copied

Make sure that you are in Live view and try again.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2018 1
New Here ,
Apr 25, 2018

Copy link to clipboard

Copied

Yes, I have tried this with no success. I have tried a few things from forum posts with the same situation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2018 0
Adobe Community Professional ,
Apr 25, 2018

Copy link to clipboard

Copied

I thought that I would try it myself and, as I thought, no problems.

If my Dreamweaver came with the problems that you are describing, then I would go through a list, namely

  • site setup
  • preferences
  • cache file
  • configuration folder
  • Adobe cleaner tool

Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2018 1
Adobe Community Professional ,
Apr 25, 2018

Copy link to clipboard

Copied

Bootstrap version 3 is not compatible with version 4. 

You should  have only one reference to Bootstrap, Popper and jQuery. 

Also check your code for validation errors.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2018 2
Adobe Employee ,
Apr 26, 2018

Copy link to clipboard

Copied

Hi,

Thanks for reporting. Could you please check that if you have used bootstrap.css in your file which is of version lower than 3.0.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 1