Highlighted

Chrome preview not updating

Enthusiast ,
May 14, 2018

Copy link to clipboard

Copied

It's driving me insane as to why, but my chrome preview will not update when I change my CSS. Firefox and Safari update, but not chrome. I've restarted my Mac, but nothing happened.

What can I do within Chrome to clear the cache (or whatever) for a specific site rather than have to clear for all sites?

Adobe Community Professional
Correct answer by Jon_Fritz_II | Adobe Community Professional

Chrome's cache is ridiculously sticky now and likely a sign of things to come with other browsers as well.

One of the better ways to deal with it, during development, is to turn on Chrome's Development Tools by hitting F12. You can then click on the "Network" heading and check the box for "Disable cache". While the Dev Tools are open, Chrome will essentially have no cache. When you turn the dev tools off, it goes back to the latest and greatest sticky cache.

Views

475

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Chrome preview not updating

Enthusiast ,
May 14, 2018

Copy link to clipboard

Copied

It's driving me insane as to why, but my chrome preview will not update when I change my CSS. Firefox and Safari update, but not chrome. I've restarted my Mac, but nothing happened.

What can I do within Chrome to clear the cache (or whatever) for a specific site rather than have to clear for all sites?

Adobe Community Professional
Correct answer by Jon_Fritz_II | Adobe Community Professional

Chrome's cache is ridiculously sticky now and likely a sign of things to come with other browsers as well.

One of the better ways to deal with it, during development, is to turn on Chrome's Development Tools by hitting F12. You can then click on the "Network" heading and check the box for "Disable cache". While the Dev Tools are open, Chrome will essentially have no cache. When you turn the dev tools off, it goes back to the latest and greatest sticky cache.

Views

476

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 14, 2018

Copy link to clipboard

Copied

Chrome's cache is ridiculously sticky now and likely a sign of things to come with other browsers as well.

One of the better ways to deal with it, during development, is to turn on Chrome's Development Tools by hitting F12. You can then click on the "Network" heading and check the box for "Disable cache". While the Dev Tools are open, Chrome will essentially have no cache. When you turn the dev tools off, it goes back to the latest and greatest sticky cache.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Enthusiast ,
May 14, 2018

Copy link to clipboard

Copied

Thanks Jon, That was driving me mad. Even locating the 'Disable Cache' button was painful because the developer pane wasn't wide enough, and it doesn't scroll sideways to reveal content displayed off the page. I just had to widen the pane to display that and other buttons!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
May 14, 2018

Copy link to clipboard

Copied

I usually just refresh using CTRL-F5.  On a Mac, it's Apple+R or command+R.  This forces the browser to refresh with grabbing all content from the webserver instead of using cached data.

HTH,

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 14, 2018

Copy link to clipboard

Copied

Perhaps one need to verify on modern version of browser, but usually Force refresh just reload the main document but some peripherical document (as Json file, Json-ld, XML, CSS...) don't reload...

I had a lot of trouble with this context...

so usually I use the don't use cache network developer tool's feature... (as pointed at Jon)... or I also often use a clear cache mecanism (browser add ons)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
May 14, 2018

Copy link to clipboard

Copied

I have set Internet Explorer to never use cache, so I know that every page refresh is grabbing content from the webserver.  However, in FireFox I just use CTRL-F5.  I have never experienced any peripheral documents (XML, CSS, JSON) not reloading by using CTRL-F5.

I try to keep as few plugins / extensions as possible for all my browsers that I test with (IE, FF, Ch, Edge).  Less bloat, less likely to be spied upon. 

V/r,

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 14, 2018

Copy link to clipboard

Copied

thanks WolfShade for this confirmation,

Firefox was precisely the browser that caused me the most problems with not reloading peripheral files including external data loaded on the fly by apps (json, json-ld, xml... and also CSS...). which led me to use add ons

so it's cool to see that Firefox doesn't cause this kind of trouble anymore.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 24, 2020

Copy link to clipboard

Copied

Amazing! Thanks for the disable cache tip! Cmd/Ctrl+F5 was not working at all, and it was retreiving content from days ago, without any way to update.... With cache disabled, it works perfectly!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...