Highlighted

Compatibility with Dreamweaver CS6

New Here ,
Jan 21, 2020

Copy link to clipboard

Copied

Folks, I am new to web development but learning fast and have a basic question. I have a website that used “Dreamweaver CS6” to build the site and there have been several Dreamwaeaver “Extensions” used in the development of the site. 

Additional information (if it helps)

  • Languages used are HTML, PHP
  • the query language used is MYSQL along with a little javascript. 
  • The styling used is “Bootstrap 3.2” (CSS).
  • There is a custom CSS style sheet that sets some styles that bootstrap does not cover (public view pages).
  • Styling in the administration area is stored in custom built CSS files 

 

My question

I have been advised by the original developer (non IT expert - learned by himself) that I need Dreamweaver 6 to carry on maintaining the code. Can someone confirm for me if that is correct and if so where I can get this version as I suspect it is very old. Or which readily available version provide backwards compatibility?

TOPICS
Code

Views

160

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Compatibility with Dreamweaver CS6

New Here ,
Jan 21, 2020

Copy link to clipboard

Copied

Folks, I am new to web development but learning fast and have a basic question. I have a website that used “Dreamweaver CS6” to build the site and there have been several Dreamwaeaver “Extensions” used in the development of the site. 

Additional information (if it helps)

  • Languages used are HTML, PHP
  • the query language used is MYSQL along with a little javascript. 
  • The styling used is “Bootstrap 3.2” (CSS).
  • There is a custom CSS style sheet that sets some styles that bootstrap does not cover (public view pages).
  • Styling in the administration area is stored in custom built CSS files 

 

My question

I have been advised by the original developer (non IT expert - learned by himself) that I need Dreamweaver 6 to carry on maintaining the code. Can someone confirm for me if that is correct and if so where I can get this version as I suspect it is very old. Or which readily available version provide backwards compatibility?

TOPICS
Code

Views

161

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 21, 2020 0
Adobe Community Professional ,
Jan 21, 2020

Copy link to clipboard

Copied

CS6 is no longer available from any vendor, retailer or country. 

 

The deprecated server-behavior panels in DW CS6 produced outdated and non-secure code.  The site must be rebuilt to modern code standards in MySQLi (improved) or PDO.  I also recommend upgrading to the latest Bootstrap 4 and jQuery but that's not nearly as essential as the PHP and MySQL connections.  

 

You can manually re-code the site or purchase 3rd party extensions from WebAssist or DMX Zone to assist you.  

 

============

Beware of fake Adobe reps offering to sell you Creative Suite.  It's a scam.  Run away!

Avoid Phishing: 3 Easy Ways to Identify Genuine Adobe Staff

 

https://community.adobe.com/t5/community-help/avoid-phishing-3-easy-ways-to-identify-adobe-staff/td-...

 

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 21, 2020 0
New Here ,
Jan 22, 2020

Copy link to clipboard

Copied

@Nancy O'Shea, thanks for your answer and we are putting funding together to this upgraded but we need to maintian the site and basic code in the meantime. I just need a basic code capability to maintain minor tweaks and corrections. Can you not recommend a version of DreamWeaver that will cover the basics please?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Adobe Community Professional ,
Jan 22, 2020

Copy link to clipboard

Copied

Any version of DW can help you tweak the code. But you won't have support for deprecated features like Spry or Server-Behaviors. 

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Adobe Community Professional ,
Jan 21, 2020

Copy link to clipboard

Copied

WebAssist's MySQLi extension for DW CC

http://www.webassist.com/dreamweaver-extensions/mysqli

 

DMX Zone's Database Connect 2

https://www.dmxzone.com/go/33136/dmxzone-database-connector-2/

 

Another option is to re-build the backend with Wappler visual app creator.

https://wappler.io/

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 21, 2020 0