Highlighted

cPanel

Explorer ,
May 13, 2018

Copy link to clipboard

Copied

Hi,

I'm new to the cPanel interface, Im not sure if I'm doing something wrong in there or what..

When I preview my site in a browser from Dreamweaver, everything looks fine, but, then when I upload the site to cPanel and view the site online, everything looks messed up.. the css is not functioning right and the html is missing most of its parts.. what am I doing wrong..?

Can anybody save me from myself..!? This is driving me crazy.

<!doctype html>
<!--[if lt IE 7 ]> <html class="ie6" lang="fr"> <![endif]-->
<!--[if IE 7 ]>    <html class="ie7" lang="fr"> <![endif]-->
<!--[if IE 8 ]>    <html class="ie8" lang="fr"> <![endif]-->
<!--[if IE 9 ]>    <html class="ie9" lang="fr"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="fr"> <!--<![endif]-->
<!--[if lte IE 8]><script src="js/libs/selectivizr.js"></script><![endif]-->
<!--[if lt IE 9]>
<script src="dist/html5shiv.js"></script>
<![endif]-->
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width,initial-scale=1">
<meta name="author" content="net-solutions.ca">
<!-- TemplateBeginEditable name="doctitle" -->
<title>Services De Nettoyage Résidentiel, Commercial Et Industriel.</title>
<!-- TemplateEndEditable -->
<link href="../_css/main.css" rel="stylesheet" type="text/css">
<link href="../_css/animate.css" rel="stylesheet" type="text/css">
<!--[if lt IE 9]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>
<!-- TemplateBeginEditable name="head" -->
<meta name="description" content="services spécialisés en nettoyage résidentiel, commercial et industriel dans la grande région de Montréal et ses environs.">
<meta name="keywords" content="Nettoyage Montreal, nettoyage tapis, nettoyage vitres, nettoyage des bureaux">
<!-- TemplateEndEditable -->

</head>

Adobe Community Professional
Correct answer by BenPleysier | Adobe Community Professional

You will need to force using HTTPS. This can be done by adding the following to your .htaccess file

RewriteEngine on

RewriteCond %{HTTPS} !on

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

If you use html5-boilerplate/.htaccess at master · h5bp/html5-boilerplate · GitHub, then you need to unmark lines 351-355

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

cPanel

Explorer ,
May 13, 2018

Copy link to clipboard

Copied

Hi,

I'm new to the cPanel interface, Im not sure if I'm doing something wrong in there or what..

When I preview my site in a browser from Dreamweaver, everything looks fine, but, then when I upload the site to cPanel and view the site online, everything looks messed up.. the css is not functioning right and the html is missing most of its parts.. what am I doing wrong..?

Can anybody save me from myself..!? This is driving me crazy.

<!doctype html>
<!--[if lt IE 7 ]> <html class="ie6" lang="fr"> <![endif]-->
<!--[if IE 7 ]>    <html class="ie7" lang="fr"> <![endif]-->
<!--[if IE 8 ]>    <html class="ie8" lang="fr"> <![endif]-->
<!--[if IE 9 ]>    <html class="ie9" lang="fr"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="fr"> <!--<![endif]-->
<!--[if lte IE 8]><script src="js/libs/selectivizr.js"></script><![endif]-->
<!--[if lt IE 9]>
<script src="dist/html5shiv.js"></script>
<![endif]-->
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width,initial-scale=1">
<meta name="author" content="net-solutions.ca">
<!-- TemplateBeginEditable name="doctitle" -->
<title>Services De Nettoyage Résidentiel, Commercial Et Industriel.</title>
<!-- TemplateEndEditable -->
<link href="../_css/main.css" rel="stylesheet" type="text/css">
<link href="../_css/animate.css" rel="stylesheet" type="text/css">
<!--[if lt IE 9]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>
<!-- TemplateBeginEditable name="head" -->
<meta name="description" content="services spécialisés en nettoyage résidentiel, commercial et industriel dans la grande région de Montréal et ses environs.">
<meta name="keywords" content="Nettoyage Montreal, nettoyage tapis, nettoyage vitres, nettoyage des bureaux">
<!-- TemplateEndEditable -->

</head>

Adobe Community Professional
Correct answer by BenPleysier | Adobe Community Professional

You will need to force using HTTPS. This can be done by adding the following to your .htaccess file

RewriteEngine on

RewriteCond %{HTTPS} !on

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

If you use html5-boilerplate/.htaccess at master · h5bp/html5-boilerplate · GitHub, then you need to unmark lines 351-355

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 13, 2018 0
Adobe Community Professional ,
May 13, 2018

Copy link to clipboard

Copied

If you defined your site in DW, you don't need to use C-Panel to transfer files to your server.

Go to Site > New Site or Manage Sites...  see screenshots.

Tell DW where your local site folder is located on your computer.   Example, C:\MyTestSite\

CC-localsite.jpg

Under servers, enter your FTP log-in credentials supplied by your hosting provider.   Root folder varies by hosting plan.  If unsure what to use here, ask your host.

CC-RootFolder.jpg

When you're done, hit the TEST button to confirm DW is able to connect to server.

From the Files Panel, click on your local site folder and hit the UP arrow to upload files to server.   Below is my Files panel expanded to show Remote Server on the left and Local Files on the right.   The file structure should be nearly identical on both sides.

CC-FilesPanel-expanded.jpg

If you're still having trouble, please post the URL to your site.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2018 1
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

Hi Nancy,

Thank you so much for taking your time to clearly demonstrate directions in resolving this issue.

I had already defined the site and connected to the server successfully. However, the site still does not go live to the browser correctly, even though in Dreamweaver's preview in browser it looks fine.. after uploading it and viewing it in a browser, it seems the CSS file is missing..at other attempts when trying to resolve it, the CSS comes in with weird styles.

In cPanel I created a folder in the public_html that holds all the site files, could this be an issue..?

Thank you tremendously for your support !

Services De Nettoyage et Entretien Ménager à Montreal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
LEGEND ,
May 14, 2018

Copy link to clipboard

Copied

I cannot access your website from where I work - the domain is proxy blocked.  However, before I received the blocked message my browser gave this important piece of information:  "The owner of geniux.ca has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website."

This makes me suspect that the CSS issue is SSL/TLS related.  Check all of your paths to make sure that they are pointing to the correct files.  If you are using the FQDN (geniux.ca) as part of the path, either check to make sure they are all https, or use protocol agnostic links (ie, starts with //, not http:// or https://:  //geniux.ca/path/style.css)

Also, check your SSL/TLS certificate.  It looks as though it's not registered to your domain.

HTH,

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 1
LEGEND ,
May 14, 2018

Copy link to clipboard

Copied

Further investigation into this matter produced the following URL:

https://support.mozilla.org/en-US/kb/mixed-content-blocking-firefox?redirectlocale=en-US&as=u&redire...

This indicates mixed protocols (http and https in the code).  Images, CSS files, anything.  Check all of your href and src attributes to make sure they are all using the same protocol.  I prefer protocol agnostic paths, myself.

HTH,

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 1
LEGEND ,
May 14, 2018

Copy link to clipboard

Copied

Here is part of the problem.  You are using both http and https.  Mixed content.

<!--[if lt IE 9]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>

V/r,

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 1
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

Hi WolfShade,

I just want to thank you very much for the time you took trying to help me out with this issue.

I think you are onto something with this, I called GoDaddy to check my SSL certificate, they say it is working fine, that the padlock is showing in the browser, however when I click on the McAfee link at the bottom of the page / verify / visit site / from this point in the browser I can see an ! before the url and it gives me a notice that my connection to the site is not secure.

In the cPanel when I drag and drop files from the folder that I created into the public_html it seems to produce the pages online but still get weird css styles. I tried changing the name from ../_css to just _css/ but that does not seem to correct my issue either. I created a file .htaccess  from the directions: Redirect my website to HTTPS in cPanel/Linux | Linux Hosting (cPanel) - GoDaddy Help CA but this does not help me to link my pages to the CSS. I just dont know what to do anymore...

Thank you once again for all your much appreciated support !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Adobe Community Professional ,
May 14, 2018

Copy link to clipboard

Copied

Also fix your code errors.  You have quite a few of them in the HTML.

Showing results for http://geniux.ca/ - Nu Html Checker

Also check your _css/main.css  for errors.

The images referenced in your CSS file are 404 not found on server like this one.

images/AdobeStock_49595512_Preview(1).jpg

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 1
LEGEND ,
May 14, 2018

Copy link to clipboard

Copied

Not any of the above - the css file link should have been:

_css/main.css

not ../_css/main.css

as it originally was.

Page is working fine now OP has changed the css link.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

Thank you so much Nancy !

I will use the link to verify any corrections.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 1
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

Hi Osgood_

I tried to change the fille path ../_css to just _css but this did not seem to correct the issue I'm having.

Thanks for the time you took to verify.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
LEGEND ,
May 14, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/Chanel+B  wrote

Hi Osgood_

I tried to change the fille path ../_css to just _css but this did not seem to correct the issue I'm having.

Somehow it obviously DID: So whatever you changed in the dwt template corrected the path link to the css, now just _css as opposed to ../_css and that is why the page now looks ok.

<!-- InstanceEndEditable -->

<link href="_css/main.css" rel="stylesheet" type="text/css">

<link href="_css/animate.css" rel="stylesheet" type="text/css">

<link href="_css/template.css" rel="stylesheet" type="text/css">

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

I just tried once again like you said, it is now back to the format you suggested, but I dont see my navigation, the page has a black background and white space that does not include images, its just weird, some css styles are shown but the page does not look the way it should...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
LEGEND ,
May 14, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/Chanel+B  wrote

but the page does not look the way it should...

in your main css file you have background-color: #F8F8F8; set on the container <div> (a light greyish color) which obscures the black background you have applied to the <body> tag.

Also you have at least 2 background images set on your body tag in the main.css file. If you want the page background to be black then they cant be there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 1
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

Thanks for bringing it to my attention, I will go back and fix this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

Can anybody understand why when I update my SSL certificate it gives me this error...

This SSL certificate was already installed.

The SSL website is now active and accessible via HTTPS on this domain:

The SSL website is also accessible via this domain, but the certificate does not support it. Web browsers will show a warning when accessing this domain via HTTPS:The SSL certificate also supports this domain, but this domain does not refer to the SSL website mentioned above:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Adobe Community Professional ,
May 14, 2018

Copy link to clipboard

Copied

You will need to force using HTTPS. This can be done by adding the following to your .htaccess file

RewriteEngine on

RewriteCond %{HTTPS} !on

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

If you use html5-boilerplate/.htaccess at master · h5bp/html5-boilerplate · GitHub, then you need to unmark lines 351-355


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 2
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

Thank you sir !

This WORKED

Thank you so much !!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Explorer ,
May 14, 2018

Copy link to clipboard

Copied

The css works in internet explorer and Firefox, but does not display styles in Chrome...

Does anyone know why Chrome wont link to my stylesheet..?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Adobe Community Professional ,
May 14, 2018

Copy link to clipboard

Copied

Open Chrome and type the following line into the address bar

chrome://settings/clearBrowserData

In the window that pops up, make sure that cached images is checked and click on Clear Data

Now try you site again.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 2
Explorer ,
May 15, 2018

Copy link to clipboard

Copied

Unfortunately this did not work...

I will save that tip as it might come in handy.

Thanks for your time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0
Chanel B LATEST
Explorer ,
May 15, 2018

Copy link to clipboard

Copied

I went into the advanced and just cleared everything, this worked.

Have a great day Ben and Thank you for everything !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0