Highlighted

Cursor position while editing in Design mode

Explorer ,
Nov 06, 2017

Copy link to clipboard

Copied

I have the latest version of Dreamweaver installed (18.0). When in design mode and editing text, the cursor is off by one position from the location the character is actually inserted/deleted/replaced. The cursor shows one character to the right of where it should be.

Community Beginner
Correct answer by yakvan | Community Beginner

I am also using 150% and the Dreamweaver problem seems to go away if Windows display set to 100% (although have not tested it thoroughly to say for sure). But I dont want to use 100% since I its too hard to read. Every other app (like Word etc) has no problem with scaling set to 150%. I also have new Dell laptop with driver all up to date and display is 1920x1080.

Views

4.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Cursor position while editing in Design mode

Explorer ,
Nov 06, 2017

Copy link to clipboard

Copied

I have the latest version of Dreamweaver installed (18.0). When in design mode and editing text, the cursor is off by one position from the location the character is actually inserted/deleted/replaced. The cursor shows one character to the right of where it should be.

Community Beginner
Correct answer by yakvan | Community Beginner

I am also using 150% and the Dreamweaver problem seems to go away if Windows display set to 100% (although have not tested it thoroughly to say for sure). But I dont want to use 100% since I its too hard to read. Every other app (like Word etc) has no problem with scaling set to 150%. I also have new Dell laptop with driver all up to date and display is 1920x1080.

Views

4.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 06, 2017 0
Adobe Employee ,
Nov 06, 2017

Copy link to clipboard

Copied

I am on Dreamweaver CC 2018 and I am unable to reproduce the issue that you speak of.

Can you try restoring preferences to see if that helps improve your situation? Unusual behavior in Dreamweaver? Try restoring preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Explorer ,
Nov 06, 2017

Copy link to clipboard

Copied

Sorry, restoring the preferences DID NOT resolve the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Adobe Community Professional ,
Nov 06, 2017

Copy link to clipboard

Copied

Which operating system?

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Explorer ,
Nov 06, 2017

Copy link to clipboard

Copied

Windows 10 - Latest updates applied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Adobe Community Professional ,
Nov 06, 2017

Copy link to clipboard

Copied

Do you see a green checkmark in a circle under your document window denoting error free code?

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Explorer ,
Nov 06, 2017

Copy link to clipboard

Copied

No green circle with check mark.  I have a red circle with 'X'. Clicking on it I get a whole series of error messages. They all seem to relate to the case of my HTML tags and placement of quotation marks.  The code in question has been in use for several years. Don't remember seeing the error condition in previous versions of Dreamweaver.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Adobe Community Professional ,
Nov 06, 2017

Copy link to clipboard

Copied

Previous versions of DW were much more forgiving of code errors.  The current versions don't like errors which also leads to unexpected behaviors in DW & modern browsers.   Suggest you tidy up the errors and see where that takes you.

Nancy

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 1
Explorer ,
Nov 06, 2017

Copy link to clipboard

Copied

I have cleaned up the source code so that I now get the green circle and check mark. However, when editing in Design mode, the cursor still appears one position to the right of where the next character is to be added/deleted/replaced.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

Try Restoring Preferences.

Unusual behavior in Dreamweaver? Try restoring preferences.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Explorer ,
Nov 07, 2017

Copy link to clipboard

Copied

Done for the second time.  No change.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Employee ,
Nov 07, 2017

Copy link to clipboard

Copied

Hi,

Did you try quit Dreamweaver and relaunching it.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

OK.  Let's try something different.

  1. Close DW.
  2. Restart your computer.
  3. Open DW.
  4. Go to File > New > HTML document >  Framework: NONE.  Hit the CREATE button. 
  5. Switch to Code View and delete everything.
  6. Paste the following code into your blank document and  SaveAs test.html

<!doctype html>

<html lang="en">

<head>

<meta charset="utf-8">

<meta http-equiv="X-UA-Compatible" content="IE=edge">

<meta name="viewport" content="width=device-width, initial-scale=1">

<title>Test Document</title>

<style>

body {width: 70%; margin:0 auto;}

</style>

</head>

<body>

<h3>Hello World!</h3>

<p>Lorem ipsum dolor sit amet, consectetur adipisicing elit. Sunt illum quo dolore consectetur asperiores quibusdam voluptatum quasi, mollitia, ea quidem similique ipsam itaque minima et voluptates numquam aspernatur qui consequuntur.</p>

</body>

</html>

Now switch to Split View.  See my screenshot below.  I clicked in the middle of a word in my Design panel.  My cursor is located between the S & E in both Code and Design view exactly as expected.   

What are your results?

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Explorer ,
Nov 07, 2017

Copy link to clipboard

Copied

With that test sample, my results are the same as yours.  However, with my production site, I get the results shown below. You'll observe that the cursor in the design view is between the 'h' and 'a' of the word 'has' on the first line of the design view, but to the left of the 'h' in the code view.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

I can't explain it other than to say there's something different about your code that DW doesn't like.  I suspect  all the deprecated HTML formatting (bgcolor, bordercolor, etc... ) is causing your grief.

If you're going to use deprecated code, you should probably drop back to an older version of DW. 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 1
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

I used to have a lot of issues with DW CS4 throwing fits if I mixed too much of the old html attributes (like bgcolor, align and width) in tables that I was trying to control with CSS in the head or external .css file.

There was never a definitive answer as to what caused it and it wasn't repeatable in an "add this attribute and it breaks, take it out and it works" sort of way to file a true bug report. Design View was just periodically impossible to use until I cleaned up the code and let css control everything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 1
New Here ,
Apr 25, 2018

Copy link to clipboard

Copied

I have exactly the same problem, which has lasted for maybe few months. The issue started after one of the latest updates of Dreamweaver. It is a hassle to edit text in the design view, since you never can place the cursor correctly. It looks correctly, but when you start typing, you most likely will type letters at the wrong place. It works fine if I go to code view, but if you have other letters than the English alphabet, you are in trouble again, since they are not translated automatically as if you type them in design view. It regards all web projects I have. I thought maybe it had something to do with Bootstrap, but I just edited a plain newsletter page with only few css styles and no link to any Bootstrap and the issue is still there. Many times the cursor is also just blinking in the middle of a letter and I need to guess if it will type to the left or to the right.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2018 0
Adobe Community Professional ,
Apr 25, 2018

Copy link to clipboard

Copied

Which version of DW?

Which operating system?

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2018 0
New Here ,
Apr 26, 2018

Copy link to clipboard

Copied

Dreamweaver CC ver. 18.1

Window 10 Pro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 26, 2018 0
Adobe Community Professional ,
Apr 27, 2018

Copy link to clipboard

Copied

Have you validated your code and fixed all reported errors?

Does this happen with all files in all sites or just certain ones?

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2018 0
New Here ,
Apr 27, 2018

Copy link to clipboard

Copied

It happens on all files, except for old ones created for 5 years ago. There is no code errors. Have a nice green check mark symbol. You may copy the codes from a newsletter that is to be released and see by yourself how the cursor is not displayed correctly. I use a split window with Design view on the left and code view on the right. If I edit in the Design view, the cursor is in the middle of a letter, while it looks correctly in code view. The link is: Newsletter E-Mail :: Child Africa

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2018 0
Adobe Community Professional ,
Apr 27, 2018

Copy link to clipboard

Copied

Actually have code errors.  See link below for details.

[Invalid] Markup Validation of https://www.childafrica.org/previewnewsletter.aspx?reference=53afbbd4...

Emails don't support JavaScript so I don't understand why you would have scripts in an email newsletter.   And you've got them at the top of your document which is wrong.  Try removing the first 3 lines of external scripts and CSS code from the top of your document.  The doc type declaration needs to be on the first line of code. 

Even with the code problems mentioned above, my DW has no cursor problems.   It displays the cursor exactly where I put it.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2018 0
New Here ,
Apr 28, 2018

Copy link to clipboard

Copied

Hi and thanks for going through this thoroughly. I believe the DOCTYPE is set for HTML5, where all the other things are not needed, but I replaced it with HTML 4.01 Transitional to see if any difference, but there were none.

The JavaScript is only located on the web version of the email and not in the email itself. To see the web version, the user clicks a link in the email to preview it in the web browser, where they again can click to preview a smaller image as a bigger image. The JavaScript is used for this image pop-up functionality that is only on the web preview version and the code is inserted automatically on that page, so I am not working on the JavaScript version locally. I will ask the programmer to change the placement of the scripts, as I did not check for that.

Below you can see how the cursor is in the middle of the letter "S" in the Design view and correctly displayed in the Code view. I had no cursor issues with this few months ago, but have issues now if I open those files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2018 0
Adobe Community Professional ,
Apr 28, 2018

Copy link to clipboard

Copied

I can't reproduce it on my system.  Try testing on another computer if you have one.  Or revert to an older version of DW from your Creative Cloud Desktop App.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2018 0
New Here ,
Apr 28, 2018

Copy link to clipboard

Copied

I am using two screens, one DELL 32" 4k screen and the other one is a DELL 24" HD screen. When you asked me to try another computer, it hit me that maybe it has something to do with the screen, so I moved my DW window from my 4k screen over to my HD screen, and suddenly the cursor was placed correctly. Really strange. Looks like there may be some trouble between DW and the driver for the screen. It works fine in other programs like Photoshop, InDesign etc. Only DM that has these cursor issues.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2018 0
Adobe Community Professional ,
Apr 28, 2018

Copy link to clipboard

Copied

The first thing I would do is update graphics drivers.  If no new ones are available, try dropping back to an older one.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2018 0
New Here ,
Jun 21, 2018

Copy link to clipboard

Copied

I'm having the same problem using Dreamweaver Creative Cloud 2018 on a Windows 10 Microsoft Surface Pro 4 PC. I tried updating the graphics driver and that didn't work, either. It's very hard to work this way. Can Adobe please try to fix this in future updates?!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2018 0
Adobe Community Professional ,
Jun 22, 2018

Copy link to clipboard

Copied

If this is repeatable in all documents, submit a bug report with details so the product team can try & reproduce it.

CC-submitBug.jpg

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2018 0
Adobe Employee ,
Jun 24, 2018

Copy link to clipboard

Copied

Hi,

Thanks for reporting.

We are sorry that you are facing problems with Dreamweaver.

We have a similar bug  reported with us. We are prioritising it and looking into it. We will update you once it is fixed.

Thanks for your patience.

Thanks

Kratika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2018 0
Community Beginner ,
Aug 29, 2018

Copy link to clipboard

Copied

Was this ever resolved and if so what is the solution. I have the exact same problem on a new Windows 10 Dell laptop. It is maddening and only happens with Dreamweaver. It is like the cursor is 1 character off but only sometimes. I suspect it has to do with a combination of screen resolution and system font size, since it seems to go away if I change those (BUT I dont want to change those).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2018 0
Explorer ,
Aug 29, 2018

Copy link to clipboard

Copied

I still have the problem, almost a year after I made the initial post. Nothing I’ve tried has resolved it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2018 0
New Here ,
Sep 14, 2018

Copy link to clipboard

Copied

New to CC - having the same issue.  The cursor is behind the characters (to the right) by at least 2 spaces.  Very hard to edit and type.  Starting to regret my upgrades..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
Adobe Community Professional ,
Sep 14, 2018

Copy link to clipboard

Copied

What kind of display do you have?

Which operating system?

Have you updated your graphics drivers?

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
New Here ,
Sep 14, 2018

Copy link to clipboard

Copied

I have a new Dell XPS - Windows 10 pro.. all drivers are up to date.  Expanded to a Samsung 4K Monitor using a thunderbolt dock.  This error is only occurring with in the interface of Dreamweaver CC (newest release being used). It is really frustrating to try to correct or edit or even type anything.  It is doing the same thing when I use the laptop only but the cursor is off in a different spot. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
New Here ,
Sep 14, 2018

Copy link to clipboard

Copied

DW-ss1.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
New Here ,
Sep 14, 2018

Copy link to clipboard

Copied

The cursor mark is a good character space to the right.  If I ht backspace it will delete the "." at this point. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
Adobe Community Professional ,
Sep 14, 2018

Copy link to clipboard

Copied

In Windows Display settings, are you using Normal (100%) zoom?

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 1
New Here ,
Sep 14, 2018

Copy link to clipboard

Copied

No - I was using a larger display as the recommended size is super small on the screen when set at 100% - I moved it from 200% down to 150% and that does seem to help some.  But now the text is tiny! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
Community Beginner ,
Sep 14, 2018

Copy link to clipboard

Copied

I am also using 150% and the Dreamweaver problem seems to go away if Windows display set to 100% (although have not tested it thoroughly to say for sure). But I dont want to use 100% since I its too hard to read. Every other app (like Word etc) has no problem with scaling set to 150%. I also have new Dell laptop with driver all up to date and display is 1920x1080.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
Adobe Community Professional ,
Sep 14, 2018

Copy link to clipboard

Copied

You can report the problem by going to the Help menu item. Perhaps Preran​ can help expedite the correction of the problem.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
Community Beginner ,
Sep 15, 2018

Copy link to clipboard

Copied

I found a solution (I think) which is to disable Windows system scaling for Dreamweaver only. To do this, find the Dreamweaver executable, right click the exe file then select PROPERTIES, in the properties dialog pick Compatibility then check "Override High dpi scaling behavior"  and choose SYSTEM (instead of application).

This can be done for any program and is how you can exclude an individual application from using Windows display scaling. It seems to work (so far) and Dreamweaver still looks ok (fonts are too distorted nor not to tiny to read). Maybe this will cause other problems but for now Dreamweaver is usable and I still get 150% scaling on all other apps (so text is not tiny...yeah).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2018 1
New Here ,
Sep 15, 2018

Copy link to clipboard

Copied

Yakvan - thank you.. This seems to work!  Yeah!  I will test it out the next couple days and provide an update.. Thank you very much for this great work around! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2018 0
Adobe Employee ,
Sep 17, 2018

Copy link to clipboard

Copied

Like Ben said, the most efficient way for you to register your request is through this link Adobe Dreamweaver CC: Feature Ideas

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2018 0