Highlighted

design/live view only shows 404 for all pages

Explorer ,
Sep 08, 2018

Copy link to clipboard

Copied

help! did it accidentally click something? I cannot view any of my web pages in design live view, it show my 404 error pages.

TOPICS
Dreamweaver | Mac OS issues

Views

883

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

design/live view only shows 404 for all pages

Explorer ,
Sep 08, 2018

Copy link to clipboard

Copied

help! did it accidentally click something? I cannot view any of my web pages in design live view, it show my 404 error pages.

TOPICS
Dreamweaver | Mac OS issues

Views

884

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 08, 2018 0
Adobe Community Professional ,
Sep 08, 2018

Copy link to clipboard

Copied

Such a broad question requires a broad answer.

Technically, an Error 404 is a client-side error, implying that the page you were trying to reach on a website couldn't be found on the server.

For a more specific answer, please give us a few leads to work from, such as

  • does the error occur in Dreamweaver or in a browser
  • does the error occur locally or remotely
  • what is the URL to the site.

Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 08, 2018 1
Explorer ,
Sep 10, 2018

Copy link to clipboard

Copied

the 404 is only inside of Dreamweaver.  My website is fine, but I cannot view pages inside of Dreamweaver using Live view. It's doing this with only two of my websites, not a third website. So it's a Dreamweaver "issue," not an actual website issue.  Live view is taking me inside of Dreamweaver to my 404 error page that I have set up on my server.

I do not have a local server set up either. i cannot find in Dreamweaver how to change it back, whatever I may have clicked? I prefer to be able to toggle from "Code/Split/lLive" view to actually "See" my pages inside of Dreamweaver.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2018 0
Explorer ,
Sep 10, 2018

Copy link to clipboard

Copied

AND! when I try to open the page inside of Dreamweaver using the "open in browser" option, it takes me to my 404 page. LOL. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2018 0
Adobe Community Professional ,
Sep 10, 2018

Copy link to clipboard

Copied

Do you have an .htaccess file in your local site folder?

If yes, I urge you to delete or rename it to abc.htaccess.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2018 1
Explorer ,
Sep 10, 2018

Copy link to clipboard

Copied

I do have an .htacess, tried your suggestion.  no change. 

it appears to be how Dreamweaver thinks it's suppose to open the live view. I have searched for days trying to find how to tell Dreamweaver to open the page in live view. I cannot find anything that would give me the option to view the path inside of the program.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2018 0
Adobe Community Professional ,
Sep 10, 2018

Copy link to clipboard

Copied

What file type is your document?

Can you copy and paste the code into a forum reply?  Don't use email, it won't come through.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2018 0
Adobe Community Professional ,
Sep 10, 2018

Copy link to clipboard

Copied

We are guessing in the dark, you can see what is happening, we cannot.

The only spot where Dreamweaver has any influence on the path of your document is in site setup - have a look here for a static site How to set up a local version of your web site using Dreamweaver or here for a dynamic site How to set up a testing server in Dreamweaver

Just to be sure, have a look at the site setup for the site that has no problems and compare that to the site setup of the other two sites.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2018 1
Adobe Community Professional ,
Sep 11, 2018

Copy link to clipboard

Copied

LifeisRosie  wrote

AND! when I try to open the page inside of Dreamweaver using the "open in browser" option, it takes me to my 404 page. LOL. 

Are you using Real-Time Preview or right-click > Open in Browser?   There is a difference.

CC-Preview-in-browser.jpg

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2018 1
Explorer ,
Sep 20, 2018

Copy link to clipboard

Copied

When I do as you suggested, it opens my browser of choice and I tried all three, and it goes to my 404 error page on my server.

This is the browser path address it uses:

https://paulhowardmd.com/C:/Users/Pamela/Documents/PaulHowardMD%20Responsive%20Web/htdocs/financial....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Explorer ,
Sep 20, 2018

Copy link to clipboard

Copied

I've been using Dreamweaver for 10 years, never had this happen. I manage multiple sites.  It pulls this stunt on me for two of my sites, but not the others. Hopefully this screen shot will help better communicate my issue.  My pages are all fine on the server, but I do not like to use "design view." I don't think any Dreamweaver user cares for "design view." lol

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Adobe Community Professional ,
Sep 20, 2018

Copy link to clipboard

Copied

Local preview should never take you to the remote site.  I think something is messed up in your site definition. 

CC-localsite.jpg

CC-RootFolder.jpg

You do not need a local testing server to work with static HTML files.   If you have defined one, turn it off.

CC-testingServer-final.jpg

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Explorer ,
Sep 20, 2018

Copy link to clipboard

Copied

Here's one more screen shot to show how crazy this is.  When I hold my mouse over the address/title of the page, it shows the correct path address that Dreamweaver should be using to show live view, but Live View actually opens the page by placing the full index page address in front of that Dreamweaver path.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Explorer ,
Sep 20, 2018

Copy link to clipboard

Copied

I've never had a testing site set up for any of my sites. Never needed to. Don't have a testing site set up for my sites that Dreamweaver isn't doing this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Adobe Community Professional ,
Sep 20, 2018

Copy link to clipboard

Copied

Well that URL is a total mashup of remote + local path.  No wonder you're geetting 404 errors.

REMOTE Path  (spaces added to show URL)

https: // paulhowardmd. com / financial.html

LOCAL Path

C:/Users/Pamela/Documents/PaulHowardMD%20Responsive%20Web/htdocs/ financial.html

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Explorer ,
Sep 20, 2018

Copy link to clipboard

Copied

Exactly, do you happen to know how to change the local path url?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Adobe Community Professional ,
Sep 20, 2018

Copy link to clipboard

Copied

That comes from your site definition.  Maybe it's corrupted.

Incidentally, you have some code errors that need attention.

Showing results for https://paulhowardmd.com/financial.html - Nu Html Checker

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Explorer ,
Sep 20, 2018

Copy link to clipboard

Copied

I've deleted my site from Dreamweaver then added it as a new site.  Same problem. All of my settings are exactly the same on all of my websites. Only two of my sites want to do this "mash up url" mess.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Adobe Community Professional ,
Sep 20, 2018

Copy link to clipboard

Copied

I don't know if this matters, but try removing the canonical URL from your <head> tag and fix your other code errors.

<link rel="canonical" href="https://paulhowardmd.com/financial.html" hreflang="en-us"/>

Save document and Right-Click > Open in Browser.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Explorer ,
Sep 20, 2018

Copy link to clipboard

Copied

didn't work. I will push on. It's clearly a Dreamweaver URL path issue/bug.

Thanks for all of your help.  that error site is very helpful! Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Adobe Community Professional ,
Sep 20, 2018

Copy link to clipboard

Copied

LifeisRosie  wrote

It's clearly a Dreamweaver URL path issue/bug.

Pamela, no it is not. Dreamweaver will only process what it is told to do. Either the site environment or the code will force Dreamweaver to do what it is told.

You have already stated that removing the link to the .htaccess file has made no difference. In that case it must be in the code of your document.

As an example, have a look at lines #16 to #21 of your document

<script>

if (document.location.protocol != "https:")

{

document.location.href = "https://paulhowardmd.com" + document.location.pathname;

};

</script>

The result of the script will cause the link to the document to become

https://paulhowardmd.com/C:/Users/Pamela/Documents/PaulHowardMD%20Responsive%20Web/htdocs/financial....

This document is obviously non-existent hence the 404 error. (Click on the link to verify)

Possible solutions:

  • ignore the problem
  • remove the script
  • change the redirect to exclude local versions of the document

The latter suggestion could include using the .htaccess file to redirect. You could have a local and a remote version for the file. See https://serverguy.com/servers/redirect-http-to-https/ for more.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Adobe Community Professional ,
Sep 20, 2018

Copy link to clipboard

Copied

LifeisRosie  a écrit

I don't think any Dreamweaver user cares for "design view." lol

I particularly like design view, and I only work exclusively in split windows, code / design view...

even if it means opening a polemic, personally I find live view, very badly implemented, very incomplete (absence of developer tools) and ineffective at all... as far as I'm concerned, I use a real-time preview script on the connected devices which is much more significant in my workflow

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Explorer ,
Sep 21, 2018

Copy link to clipboard

Copied

I've already tried removing that script.  That script is required for my SSL to work properly with Network Solutions. Had I known a JS script was required instead of the usual htaccess redirect for HTTPS from HTTP I would have gone elsewhere. I was doing the htaccess redirect and it caused holy hell for me with google. NetSol didn't bother to notify me of this JS script requirement when I purchased the SSL last year. It has cost me ranking in a major way because I did the htaccess code which has useless for a NetSol SSL. Ranking in this business is dog-eat-dog so the HTTPS is critical.

I've tried removing that SSL JS script.  The problem doesn't go away. That was the first thing I did in trying to resolve this issue. I removed that JS script on every page. no change.

Thanks for your input.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 21, 2018 0
Adobe Community Professional ,
Sep 21, 2018

Copy link to clipboard

Copied

Pamela, removing the script does help. After removing the script, save and close the document before re-opening.

As far as redirecting is concerned, there should be no SEO penalties when using the correct .htaccess script. If you have a decent host, you will be able to use the Plesk panel for the setting as per

junk.png


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 21, 2018 0