Highlighted

Dreamweaver Won't Run index.php.

New Here ,
Dec 03, 2018

Copy link to clipboard

Copied

I can open index.php in Dreamweaver and it's code appears in the lower section. But there is nothing in the upper Live section. I tried File>Device Preview>Chrome and I got four small squares that continually appear and disappear, and the cycle repeats indefinitely. I tried the URL: localhost\phptest and I get:" can't connect". phptest is the directory of index.php. (ie. C:\xampp\htdocs\phptest). I aslo tried the URL:localhost and I get the same thing. I did create a Local Testing Server. With that I get in the upper-right corner of the DW screen:

Site Testing Local Server 3 (c:\xampp\hrdocs\phptest) and the file name: index.php, but there is a question mark in front of it.

Any help is appreciated. -Bruce

bruceh67871735  wrote

I can open index.php in Dreamweaver and it's code appears in the lower section. But there is nothing in the upper Live section. I tried File>Device Preview>Chrome and I got four small squares that continually appear and disappear, and the cycle repeats indefinitely. I tried the URL: localhost\phptest and I get:" can't connect". phptest is the directory of index.php. (ie. C:\xampp\htdocs\phptest). I aslo tried the URL:localhost and I get the same thing. I did create a Local Testing Server. With that I get in the upper-right corner of the DW screen:

Site Testing Local Server 3 (c:\xampp\hrdocs\phptest) and the file name: index.php, but there is a question mark in front of it.

Any help is appreciated. -Bruce

Is the local server running?

Can you connect to the file if you type the files localhost address directly in a browers url field?

Views

420

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Dreamweaver Won't Run index.php.

New Here ,
Dec 03, 2018

Copy link to clipboard

Copied

I can open index.php in Dreamweaver and it's code appears in the lower section. But there is nothing in the upper Live section. I tried File>Device Preview>Chrome and I got four small squares that continually appear and disappear, and the cycle repeats indefinitely. I tried the URL: localhost\phptest and I get:" can't connect". phptest is the directory of index.php. (ie. C:\xampp\htdocs\phptest). I aslo tried the URL:localhost and I get the same thing. I did create a Local Testing Server. With that I get in the upper-right corner of the DW screen:

Site Testing Local Server 3 (c:\xampp\hrdocs\phptest) and the file name: index.php, but there is a question mark in front of it.

Any help is appreciated. -Bruce

bruceh67871735  wrote

I can open index.php in Dreamweaver and it's code appears in the lower section. But there is nothing in the upper Live section. I tried File>Device Preview>Chrome and I got four small squares that continually appear and disappear, and the cycle repeats indefinitely. I tried the URL: localhost\phptest and I get:" can't connect". phptest is the directory of index.php. (ie. C:\xampp\htdocs\phptest). I aslo tried the URL:localhost and I get the same thing. I did create a Local Testing Server. With that I get in the upper-right corner of the DW screen:

Site Testing Local Server 3 (c:\xampp\hrdocs\phptest) and the file name: index.php, but there is a question mark in front of it.

Any help is appreciated. -Bruce

Is the local server running?

Can you connect to the file if you type the files localhost address directly in a browers url field?

Views

421

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 03, 2018 0
LEGEND ,
Dec 03, 2018

Copy link to clipboard

Copied

bruceh67871735  wrote

I can open index.php in Dreamweaver and it's code appears in the lower section. But there is nothing in the upper Live section. I tried File>Device Preview>Chrome and I got four small squares that continually appear and disappear, and the cycle repeats indefinitely. I tried the URL: localhost\phptest and I get:" can't connect". phptest is the directory of index.php. (ie. C:\xampp\htdocs\phptest). I aslo tried the URL:localhost and I get the same thing. I did create a Local Testing Server. With that I get in the upper-right corner of the DW screen:

Site Testing Local Server 3 (c:\xampp\hrdocs\phptest) and the file name: index.php, but there is a question mark in front of it.

Any help is appreciated. -Bruce

Is the local server running?

Can you connect to the file if you type the files localhost address directly in a browers url field?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2018 1
New Here ,
Dec 03, 2018

Copy link to clipboard

Copied

I think the local testing server is running because at the upper-right side of the DW screen, the server name is listed along with the path to it, which is C:\xampp\htdocs\phptest

:

I have tried tying the following as a URL in Chrome, without success: http://localhost        http://localhost/phptest    and     http://localhost/xampp/htdocs/phptest

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2018 0
LEGEND ,
Dec 03, 2018

Copy link to clipboard

Copied

Have you set up your site definition, and your testing server in Dw?

Also are you using a wordpress site, or similar cms?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2018 0
Adobe Community Professional ,
Dec 03, 2018

Copy link to clipboard

Copied

I have tried typing the following as a URL in Chrome, without success: http://localhosthttp://localhost/phptest    and     http://localhost/xampp/htdocs/phptest

If none of these are working it sounds as though the testing is either a)  not running or b) not configured correctly.

I don't use Xampp but in the first instance you need to confirm the testing is set up correctly;

You should have configured a path for to your web root either in the apache file or if Xamp has an option for you to configure it.

Create a file, call it say test.php and add something to it, I usually just put this in any test page:

<?php phpinfo(); ?>

Copy  test.php to your webroot folder

Make sure apache is running (and your MySQL server too which I assume you may need also)

Try to access test.php by accessing http://localhost/test.php or http://127.0.0.1/test.php

If you can't access the page what message/error do you get? If the PHP info page loads then your testing server is running and you probably need to check your site settings in Dreamweaver for the testing server as its likely the server folder and/or web url are incorrect.

It sounds to me like your testing server is not running or apache wont start for some reason.

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2018 1
Adobe Community Professional ,
Dec 03, 2018

Copy link to clipboard

Copied

bruceh67871735  wrote

I think the local testing server is running because at the upper-right side of the DW screen, the server name is listed along with the path to it...

The local testing server likely isn't running. You need to start it manually every time the computer is restarted, or after manually turning it off. The path in DW will always show what you have set in your Site Definition and and it really doesn't have any idea whether your server is running or not.

To start your server, right click your XAMPP program icon (or right click the icon in your task bar and right click XAMPP Control Panel again) and choose "Run as administrator".

When the control panel comes up, start Apache...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2018 1
New Here ,
Dec 03, 2018

Copy link to clipboard

Copied

Thank you. You are right. I forgot to run XAMPP. All is well now!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2018 0