Highlighted

DW 21.0, View in Browser doesn't work on my iMac

Explorer ,
Oct 30, 2020

Copy link to clipboard

Copied

Hi all,

I am learning how to use Dreamweaver and recently upgraded to version 21.0.

On my Mabook (mid 2014 - MacOS 10.14.6) it seems to work fine.

But on my iMac (Late 2012 - MacOS 10.14.6) preview in browser doesn't work.

 

I have defined some test sites, without configuring server, only locally.

If I try to preview an html, using the icon at the bottom right of the main window, or from the File-> Open in browser menu, it does nothing, it does not open any of the configured browsers.

 

To try to fix it I have done all this:
- Delete and reconfigure the browsers.
- Uninstall Dreamweaver, delete all preferences, even from previous versions.
- Installed again.

- I have tried turning off the second monitor.

 

But I still can't preview the html in any browser.
I have to open it manually from browsers.

 

Any suggestions of what may be happening on my iMac?
Thank you.

Well, I have solved the problem by reinstalling MacOS, with a clean install, formatting the hard drive, and reinstalling the entire system and applications.

 

I don't know where the problem was, but clearly there was something wrong with it.

 

As we say in Spain: "Muerto el perro, se acabó la rabia"

"Once the dog is dead, the rabies is over." (I don't know if the English translation is correct).

🙂

 

Thank you very much to everyone for your help.

Views

97

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

DW 21.0, View in Browser doesn't work on my iMac

Explorer ,
Oct 30, 2020

Copy link to clipboard

Copied

Hi all,

I am learning how to use Dreamweaver and recently upgraded to version 21.0.

On my Mabook (mid 2014 - MacOS 10.14.6) it seems to work fine.

But on my iMac (Late 2012 - MacOS 10.14.6) preview in browser doesn't work.

 

I have defined some test sites, without configuring server, only locally.

If I try to preview an html, using the icon at the bottom right of the main window, or from the File-> Open in browser menu, it does nothing, it does not open any of the configured browsers.

 

To try to fix it I have done all this:
- Delete and reconfigure the browsers.
- Uninstall Dreamweaver, delete all preferences, even from previous versions.
- Installed again.

- I have tried turning off the second monitor.

 

But I still can't preview the html in any browser.
I have to open it manually from browsers.

 

Any suggestions of what may be happening on my iMac?
Thank you.

Well, I have solved the problem by reinstalling MacOS, with a clean install, formatting the hard drive, and reinstalling the entire system and applications.

 

I don't know where the problem was, but clearly there was something wrong with it.

 

As we say in Spain: "Muerto el perro, se acabó la rabia"

"Once the dog is dead, the rabies is over." (I don't know if the English translation is correct).

🙂

 

Thank you very much to everyone for your help.

Views

98

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 30, 2020 0
Adobe Community Professional ,
Oct 30, 2020

Copy link to clipboard

Copied

On the iMac, can you try logging in as another user and see whether or not the preview works?  This will rule out a corrupt OS user profile.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
Explorer ,
Oct 30, 2020

Copy link to clipboard

Copied

Hi Ben,

 

I have created a new user (I only had one).
I have logged into it and also my Adobe CC account.
I have opened DW and created a new site and a new html.
But the same problem occurs.

 

As a curiosity:
In the iMac, the options "Adobe Online Help Forum" and "Submit errors / feature request" do not work either in the Help menu.

Instead, on the Macbook Pro, these menus do work, but always open Safari, even though I have Chrome as the default browser.

 

Sorry for my bad English, it's not my native language. I am Spanish and I am using Google Translate.

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
Adobe Community Professional ,
Oct 30, 2020

Copy link to clipboard

Copied

Some things to try:

1. Restart your computer.

 

2. Restore Preferences.
https://helpx.adobe.com/dreamweaver/kb/restore-preferences-dreamweaver.html

 

3. Or failing that, use the Adobe Cleaner Tools to remove old Adobe apps before reinstalling.

https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
Adobe Community Professional ,
Oct 30, 2020

Copy link to clipboard

Copied

Try turning off live preview in preferences => real-time preview by checking 'default to static browser preview':

 

realtime preview.jpg

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2020 0
Explorer ,
Nov 07, 2020

Copy link to clipboard

Copied

Sorry for the delay. I've been busy this week.

 

I have tried all your advice:

  • I have restored the preferences and turned off live preview, and it does not solve the problem.
  • I have used Adobe Cleaner Tools and I have removed all Adobe applications and all folders and files from Library that refers to Adobe.
  • Then I rebooted the computer, reinstalled the Adobe Creative Cloud app, and installed only Dreamweaver 2021.
  • I have created a test site, created an html and tested the preview in the browser.

 

And it works but only with Google Chrome. Not with Safari and Firefox.

 

Any more ideas?

I think there is something wrong with my operating system.

 

Thank you very much to all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2020 0
Explorer ,
Nov 07, 2020

Copy link to clipboard

Copied

UPDATE:

I have changed the default browser from MacOS to Safari and now the preview in browser fails again.
I have restored Chrome as the default browser but it still does not work, not even with Chrome.

This is crazy!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2020 0
Adobe Community Professional ,
Nov 07, 2020

Copy link to clipboard

Copied

Try creating a new computer user profile with admin level permissions.

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2020 0
Explorer ,
Nov 08, 2020

Copy link to clipboard

Copied

Well, I have solved the problem by reinstalling MacOS, with a clean install, formatting the hard drive, and reinstalling the entire system and applications.

 

I don't know where the problem was, but clearly there was something wrong with it.

 

As we say in Spain: "Muerto el perro, se acabó la rabia"

"Once the dog is dead, the rabies is over." (I don't know if the English translation is correct).

🙂

 

Thank you very much to everyone for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2020 0