Highlighted

Edited local image not refreshing in live view

Community Beginner ,
Oct 29, 2017

Copy link to clipboard

Copied

I have updated to Dreamweaver CC version 18.

I have inserted an image using a local path. I have amended and re-saved the image (keeping the same name). The image is refreshed in design view but not in live view. I have clicked the refresh (F5) many times and it does not refresh live view.

I know that changing the file name will fix this but I really don't want to do this.

I have inserted a different temporary image with a different name, saved the page, shut down and re-opened Dreamweaver, then replaced the temporary image with the correct one but it still displays the old (now deleted) image in live view.

Is there a way to clear Dreamweaver's browser cache as refresh (F5) is not working?

Views

761

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Edited local image not refreshing in live view

Community Beginner ,
Oct 29, 2017

Copy link to clipboard

Copied

I have updated to Dreamweaver CC version 18.

I have inserted an image using a local path. I have amended and re-saved the image (keeping the same name). The image is refreshed in design view but not in live view. I have clicked the refresh (F5) many times and it does not refresh live view.

I know that changing the file name will fix this but I really don't want to do this.

I have inserted a different temporary image with a different name, saved the page, shut down and re-opened Dreamweaver, then replaced the temporary image with the correct one but it still displays the old (now deleted) image in live view.

Is there a way to clear Dreamweaver's browser cache as refresh (F5) is not working?

Views

762

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 29, 2017 0
Adobe Community Professional ,
Oct 29, 2017

Copy link to clipboard

Copied

If you are using Chrome, then type chrome://settings/clearBrowserData into the address bar and follow the prompts Other browsers should be OK with a refresh or two.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2017 1
Community Beginner ,
Oct 29, 2017

Copy link to clipboard

Copied

Thanks Ben, it displays correctly when viewed in Chrome (after clearing the cache). It's just the live view in Dreamweaver which is not refreshing... looks fine in design view - just not updating in live view.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2017 0
Adobe Community Professional ,
Oct 29, 2017

Copy link to clipboard

Copied

Open Preferences > Real-Time Preview and deselect preview using temporary file.  See screenshot.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2017 1
Community Beginner ,
Oct 29, 2017

Copy link to clipboard

Copied

Thanks Nancy, this was un-checked - when it's checked live view will not display the page. I'm building the site locally using php pages. Strangely however, after about two hours live view started displaying the correct version of the image. I didn't do anything other than work on some other pages. I know it's not a problem with the page code because it displays OK in all the testing browsers (Chrome, Safari etc.). I've just recreated the problem again by altering another image on a different page (while keeping the same file name), and again it works as it should in design view but not updating in live view. I did this about half an hour ago and it's not updated yet (even after restarting Dreamweaver - I haven't restarted the computer)... I'll keep an eye on it. I guess Live View is a kind of built-in browser for Dreamweaver?? It would be good if there was a way to clear its cache. It's not affecting my workflow at all but I wonder if anyone else experiences this issue. I am using a fairly old Mac Pro 2008 running on El Capitan.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2017 0
Adobe Community Professional ,
Oct 30, 2017

Copy link to clipboard

Copied

Which testing server are you using?

Do you keep your local site folder on the testing server?   That way, when you save a file it's automatically saved on the testing server so there's no need to PUSH files to server.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2017 1