Highlighted

Embedded YouTube vid Works in preview, not online

Explorer ,
Sep 14, 2020

Copy link to clipboard

Copied

Hello

Long time since I have (dis)graced these halls.

This page    www.sonnyandperley.com/index.htm

Has 3 embedded YouTube videos at the bottom of the page.  Only one is showing online.  (This is a change from "awhile ago" when all was fine.  Don't know what may have changed.)

 

When I preview from DW in Firefox, I can see the other two videos.  Re-uploaded, but no dice.
What do you know that I don't?

 

TIA

denno

Adobe Community Professional
Correct answer by Ben M | Adobe Community Professional

The issue was not as obvious to me at first, but your include that is not working is using http and not https.  Because you are using a SSL certificate on your site, most modern browsers will block what is called Mixed Content, or basically trying to put insecure content on a secure page.  I would just go and grab new code from Youtube for that video, or simply change the http to https and you should be good to go.

Views

68

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Embedded YouTube vid Works in preview, not online

Explorer ,
Sep 14, 2020

Copy link to clipboard

Copied

Hello

Long time since I have (dis)graced these halls.

This page    www.sonnyandperley.com/index.htm

Has 3 embedded YouTube videos at the bottom of the page.  Only one is showing online.  (This is a change from "awhile ago" when all was fine.  Don't know what may have changed.)

 

When I preview from DW in Firefox, I can see the other two videos.  Re-uploaded, but no dice.
What do you know that I don't?

 

TIA

denno

Adobe Community Professional
Correct answer by Ben M | Adobe Community Professional

The issue was not as obvious to me at first, but your include that is not working is using http and not https.  Because you are using a SSL certificate on your site, most modern browsers will block what is called Mixed Content, or basically trying to put insecure content on a secure page.  I would just go and grab new code from Youtube for that video, or simply change the http to https and you should be good to go.

Views

69

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 14, 2020 0
Adobe Community Professional ,
Sep 14, 2020

Copy link to clipboard

Copied

If you have a good look at the code of the video that works:

 

<iframe width="560" height="315" src="https://www.youtube.com/embed/NRhVUTbU-VM" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

 

and compare that with the code of one of the videos that does not show:

 

<iframe width="640" height="360" src="http://www.youtube.com/embed/GNCumJ-Rbj0?feature=player_embedded" frameborder="0" allowfullscreen></iframe>

 

you may be able to figure out what is wrong.

 

As a side note, have a look at https://validator.w3.org/nu/?doc=https%3A%2F%2Fwww.sonnyandperley.com%2Findex.htm


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2020 0
Adobe Community Professional ,
Sep 15, 2020

Copy link to clipboard

Copied

The issue was not as obvious to me at first, but your include that is not working is using http and not https.  Because you are using a SSL certificate on your site, most modern browsers will block what is called Mixed Content, or basically trying to put insecure content on a secure page.  I would just go and grab new code from Youtube for that video, or simply change the http to https and you should be good to go.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2020 0
Explorer ,
Sep 15, 2020

Copy link to clipboard

Copied

Thank you both.  This is something I would not have observed or known about.  At this point I just update two or three sites for musician friends, including me.

Appreciate the quick look and  quick fix.

 

denno

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2020 0
Adobe Community Professional ,
Sep 16, 2020

Copy link to clipboard

Copied

For future reference, bookmark this link.

https://www.whynopadlock.com/

 

 

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2020 0