Highlighted

Enter after open tag should create indented new line and push close tag to next line

New Here ,
Sep 22, 2018

Copy link to clipboard

Copied

So I have looked through every setting and can't figure this out... I have my code set to create a closing tag right after you close the opening tag. However, when I hit enter to start adding code in the tags, my cursor is right in front of the closing tag. It looks like this:

<html>

|</html>

The pipe is my cursor.... I want to set it so after I type the opening tag and press enter, it does this:

<html>

       |

</html>

Someone please help me with this! It seems to be something with Emmet, but I can't find anything about editing the preferences... Any help would be greatly appreciated.

TOPICS
Dreamweaver | Mac OS issues

Views

212

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Enter after open tag should create indented new line and push close tag to next line

New Here ,
Sep 22, 2018

Copy link to clipboard

Copied

So I have looked through every setting and can't figure this out... I have my code set to create a closing tag right after you close the opening tag. However, when I hit enter to start adding code in the tags, my cursor is right in front of the closing tag. It looks like this:

<html>

|</html>

The pipe is my cursor.... I want to set it so after I type the opening tag and press enter, it does this:

<html>

       |

</html>

Someone please help me with this! It seems to be something with Emmet, but I can't find anything about editing the preferences... Any help would be greatly appreciated.

TOPICS
Dreamweaver | Mac OS issues

Views

213

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 22, 2018 0
Adobe Community Professional ,
Sep 22, 2018

Copy link to clipboard

Copied

There is a feature to turn Emmet off as per

But this will not help with your problem.

I have not been able to supply a solution, hence I would suggest to report the problem by going to


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2018 0
Adobe Community Professional ,
Sep 24, 2018

Copy link to clipboard

Copied

It's not Emmet, but Brackets (DW's code engine).

There's currently no interface-based way to change how it indents as you type (there may be a way to change it in the brackets.json file though).

Going to Edit > Code > Apply Source Formatting should create the indentation based on the settings in your Tag Libraries, which will be closer to what you want, than what you get while typing. You can tie that command to a keyboard shortcut to create indents with a keystroke as you go.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 24, 2018 0