Highlighted

Error Message: Unchecked runtime.lastError

Contributor ,
Apr 19, 2019

Copy link to clipboard

Copied

When I right click my homepage and select Inspect and select the Console tab on top, I get this error message:

index.php:1 Unchecked runtime.lastError: The message port closed before a response was received.

Any ideas?

www.winvoices.com

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

You have duplicate references to different jQuery libraries.  On line 30, you have called jquery 3.4.  On line 34 you are calling jQuery 1.10 from a fancybox folder.    For best results, use only one version of jQuery per document.

<script src="https://code.jquery.com/jquery-3.4.0.min.js" integrity="sha256-BJeo0qm959uMBGb65z40ejJYGSgR7REI4+CW1fNKwOg=" crossorigin="anonymous">

</script>


<script type="text/javascript" src="fancybox/jquery-1.10.2.min.js"></script>

If you're not sure which one to use, look at your plugin's latest documentation.  Some older plugins were built to work with older jQuery.  If the plugin is more than 5 years old, it's probably time to replace it with a more modern one.   I recommend Fancybox 3 as it's a big improvement for mobile device users. 

fancybox - Touch enabled, responsive and fully customizable jQuery lightbox script

Views

5.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Error Message: Unchecked runtime.lastError

Contributor ,
Apr 19, 2019

Copy link to clipboard

Copied

When I right click my homepage and select Inspect and select the Console tab on top, I get this error message:

index.php:1 Unchecked runtime.lastError: The message port closed before a response was received.

Any ideas?

www.winvoices.com

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

You have duplicate references to different jQuery libraries.  On line 30, you have called jquery 3.4.  On line 34 you are calling jQuery 1.10 from a fancybox folder.    For best results, use only one version of jQuery per document.

<script src="https://code.jquery.com/jquery-3.4.0.min.js" integrity="sha256-BJeo0qm959uMBGb65z40ejJYGSgR7REI4+CW1fNKwOg=" crossorigin="anonymous">

</script>


<script type="text/javascript" src="fancybox/jquery-1.10.2.min.js"></script>

If you're not sure which one to use, look at your plugin's latest documentation.  Some older plugins were built to work with older jQuery.  If the plugin is more than 5 years old, it's probably time to replace it with a more modern one.   I recommend Fancybox 3 as it's a big improvement for mobile device users. 

fancybox - Touch enabled, responsive and fully customizable jQuery lightbox script

Views

5.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 19, 2019 0
Adobe Community Professional ,
Apr 19, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2019 1
Contributor ,
Apr 19, 2019

Copy link to clipboard

Copied

I understood nothing on that post.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2019 0
Adobe Community Professional ,
Apr 19, 2019

Copy link to clipboard

Copied

Try using a local source for your jQuery library, so instead of

<script src="https://code.jquery.com/jquery-3.4.0.min.js" integrity="sha256-BJeo0qm959uMBGb65z40ejJYGSgR7REI4+CW1fNKwOg=" crossorigin="anonymous">

have something like

<script src="js/jquery-3.4.0.min.js">

where the file is in a local folder.

Then see if you still get the error message.

Googling the subject may help you to understand better.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2019 1
Adobe Employee ,
Apr 22, 2019

Copy link to clipboard

Copied

Hi Sneedbreedley,

We are sorry for the frustration caused due to "Unchecked runtime.lastError" error message. In addition to what Ben has suggested, would you mind sharing some information like which browser you are using? I am assuming you are using google chrome? If yes, please check this link laravel - How to fix 'Unchecked runtime.lastError: The message port closed before a response was rec...  and let us know if that helps.

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 22, 2019 0
Contributor ,
Apr 22, 2019

Copy link to clipboard

Copied

OK, I turned off each extension and only one absolutely affects the runtime error. It is Ptotopage Start Page. That's what I just started using for my home page when I open Chrome!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 22, 2019 0
Adobe Employee ,
Apr 22, 2019

Copy link to clipboard

Copied

Hi Sneedbreedley,

Thank you for trying these steps, would you mind trying on any other browsers except chrome and check if it's working fine? In case, it didn't work on other browsers as well, please check the contents of the page. It would be great if you could also help us with the screenshot of the error message.

If it worked fine on other browsers, could you please try to open the chrome in incognito mode, where extensions are disabled and see if that's indeed the problem.

Regards,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 22, 2019 1
Adobe Community Professional ,
Apr 22, 2019

Copy link to clipboard

Copied

You have duplicate references to different jQuery libraries.  On line 30, you have called jquery 3.4.  On line 34 you are calling jQuery 1.10 from a fancybox folder.    For best results, use only one version of jQuery per document.

<script src="https://code.jquery.com/jquery-3.4.0.min.js" integrity="sha256-BJeo0qm959uMBGb65z40ejJYGSgR7REI4+CW1fNKwOg=" crossorigin="anonymous">

</script>


<script type="text/javascript" src="fancybox/jquery-1.10.2.min.js"></script>

If you're not sure which one to use, look at your plugin's latest documentation.  Some older plugins were built to work with older jQuery.  If the plugin is more than 5 years old, it's probably time to replace it with a more modern one.   I recommend Fancybox 3 as it's a big improvement for mobile device users. 

fancybox - Touch enabled, responsive and fully customizable jQuery lightbox script

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 22, 2019 1