Highlighted

Fehler bei Datenbankverbindung

Community Beginner ,
Nov 12, 2018

Copy link to clipboard

Copied

Meine PHP Verbindung zur 1und1 MySql Datenbank klappt plötzlich nicht mehr. Trotz korrekter Zugangsdaten erhalte ich folgende Fehlermeldung bei der Testverbindung:

Bild1.jpg

Ich verwende Dreamweaver CS6. Kann mir jemand weiterhelfen?

Danke.

Mac

Correct answer by macavity | Community Beginner

Found the culprit after all:

The web-url in the server settings was still 'http://'. It obviously must be 'https://' now:

Solution.jpg

With https it works fine again. Thanks for all your assistance.
Mac

Views

250

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Fehler bei Datenbankverbindung

Community Beginner ,
Nov 12, 2018

Copy link to clipboard

Copied

Meine PHP Verbindung zur 1und1 MySql Datenbank klappt plötzlich nicht mehr. Trotz korrekter Zugangsdaten erhalte ich folgende Fehlermeldung bei der Testverbindung:

Bild1.jpg

Ich verwende Dreamweaver CS6. Kann mir jemand weiterhelfen?

Danke.

Mac

Correct answer by macavity | Community Beginner

Found the culprit after all:

The web-url in the server settings was still 'http://'. It obviously must be 'https://' now:

Solution.jpg

With https it works fine again. Thanks for all your assistance.
Mac

Views

251

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 12, 2018 0
LEGEND ,
Nov 12, 2018

Copy link to clipboard

Copied

Check with 1 and 1, if they have updated to php 7. If they have your SB's from CS6 will no longer work.

php have discontinued previous version of php including any updates and security updates. If they have updated to php 7, then they may have 'legacy' servers that they can move you to. This is however only a temporary fix as such servers are vulnerable, so you should update to using pdo or mysqli connections, which will require a complete recode of your server/database code.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2018 1
Adobe Community Professional ,
Nov 12, 2018

Copy link to clipboard

Copied

In your Testing Server's Advanced settings, which server model is selected?

CC-testingServer4.jpg

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2018 1
Community Beginner ,
Nov 12, 2018

Copy link to clipboard

Copied

Thanks Nancy. . Server Model IS PHP MySQL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2018 0
Community Beginner ,
Nov 14, 2018

Copy link to clipboard

Copied

Found the culprit after all:

The web-url in the server settings was still 'http://'. It obviously must be 'https://' now:

Solution.jpg

With https it works fine again. Thanks for all your assistance.
Mac

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2018 1