Highlighted

Footer does not show up in Design View/Add a Library item greyed out, said to use Design View

New Here ,
Nov 12, 2020

Copy link to clipboard

Copied

So, when I go to add a Library Item - it is greyed out where I can not. Prior conversations said it has to be done in Design View. That worked for the other Library items... Until...

I wanted to make the Footer a Library item.

For me, in Design View (and the Design part of split view) the Footer doesn't show up. The Footer can only be seen in the code view (which... is then greyed out when I go to add it...).

Version 21.0

Thank you for any help you can provide 🙂

Views

27

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Footer does not show up in Design View/Add a Library item greyed out, said to use Design View

New Here ,
Nov 12, 2020

Copy link to clipboard

Copied

So, when I go to add a Library Item - it is greyed out where I can not. Prior conversations said it has to be done in Design View. That worked for the other Library items... Until...

I wanted to make the Footer a Library item.

For me, in Design View (and the Design part of split view) the Footer doesn't show up. The Footer can only be seen in the code view (which... is then greyed out when I go to add it...).

Version 21.0

Thank you for any help you can provide 🙂

Views

28

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 12, 2020 0
Adobe Community Professional ,
Nov 13, 2020

Copy link to clipboard

Copied

Show us your code please.  It sounds like you're trying to add a library item to a template-driven child page.  Open the Template.dwt file instead of the child page.

 

 

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0
New Here ,
Nov 15, 2020

Copy link to clipboard

Copied

Nancy,
Thank you for your response. As far as I know I'm not using a template. The Footer shows up in code view and in Real-time Preview. But since it won't show up in Design view, I'm unable to make it a Library Item (with the work-around as "Add Object to Library is greyed out for me until I go to Design View". I am not a professional so I appreciate any help 🙂
Attached is the code for one of the pages (I removed the website content as I'm not sure where this will show up - but all the code is there.)
I do not have a Template.dwt file anywhere.
Thank you!!!
(Angela) Werner5FD8

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2020 0
Adobe Community Professional ,
Nov 15, 2020

Copy link to clipboard

Copied

I don't see any code.  Email attachments are not supported by this web forum. 

 

The quickest way for us to help you is if you upload your problem page to a TEST folder on your remote web server and post the URL here.  After your question is answered, you can delete the TEST folder from your server.  

 

Also validate your code and fix reported errors.  Use the validation services below to check your code.

HTML - https://validator.w3.org/

CSS - https://jigsaw.w3.org/css-validator/

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2020 0
New Here ,
Nov 26, 2020

Copy link to clipboard

Copied

Thank you Nancy - I used the W3 validator you provided. The error was in my coding. Fixed it, then used the above work around to get the "Add Object to Library" to show up. Thanks for that link - no wonder no one else had the problem, it was my code 😉

Thank you!!! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2020 0