Highlighted

Funny behavior with spacebar

New Here ,
Nov 09, 2020

Copy link to clipboard

Copied

Using DW 2021, just updated itself. I am in CODE view with VBScript language option in the lower right pulldown.  When I tap the spacebar it does NOT insert a space like every other program in the world does, but it moves the entire line of code like 3 tabs to the right. Even if I try to insert a space somewhere in the middle of the line of code, the whole line moves tabs at a time.  I have another DW installed on another computer under my account, but it is 2020; it does not do this.  I tried to upload the settings from that one and load the setting from the cloud to the 2021 one, but nothing makes a difference unless I change the language to something else like HTML, but then the colors are not right.  I have compared Preference Settings across both computers and I can not figure this one out.  I rarely post to forums, but this one is driving me notes.

Thanks Ahead

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Personally, I prefer left aligned code so I turn off auto indenting in View > Code View Options.  See screenshot.

image.png

 

Check your Preferences > Code Format (Ctrl+U).

 

 

 

 

Views

47

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Funny behavior with spacebar

New Here ,
Nov 09, 2020

Copy link to clipboard

Copied

Using DW 2021, just updated itself. I am in CODE view with VBScript language option in the lower right pulldown.  When I tap the spacebar it does NOT insert a space like every other program in the world does, but it moves the entire line of code like 3 tabs to the right. Even if I try to insert a space somewhere in the middle of the line of code, the whole line moves tabs at a time.  I have another DW installed on another computer under my account, but it is 2020; it does not do this.  I tried to upload the settings from that one and load the setting from the cloud to the 2021 one, but nothing makes a difference unless I change the language to something else like HTML, but then the colors are not right.  I have compared Preference Settings across both computers and I can not figure this one out.  I rarely post to forums, but this one is driving me notes.

Thanks Ahead

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Personally, I prefer left aligned code so I turn off auto indenting in View > Code View Options.  See screenshot.

image.png

 

Check your Preferences > Code Format (Ctrl+U).

 

 

 

 

Views

48

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 09, 2020 0
Adobe Community Professional ,
Nov 09, 2020

Copy link to clipboard

Copied

Personally, I prefer left aligned code so I turn off auto indenting in View > Code View Options.  See screenshot.

image.png

 

Check your Preferences > Code Format (Ctrl+U).

 

 

 

 

Nancy O'Shea, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 2
New Here ,
Nov 10, 2020

Copy link to clipboard

Copied

Nancy - That was it - Auto Indent checked; so simple....  I was so focuced on the PREFERENCES Section and then when it ONLY did it when VBScript language was selected, I thought those deep, dark JSON files 10 directories deep might come into play.  I did extensive earching, rearranging words and phrases before posting this, but found nothing. 

Thank You So Much!   And you sound Irish too 🙂  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Adobe Community Professional ,
Nov 10, 2020

Copy link to clipboard

Copied

When I set a page to VBScript as you descibe, and randomly choose a place to add a space, I'm not seeing the same results (DW 2021 under Windows 10).

It could be an auto-indent issue, along with code errors, causing your specific code to get mangled by a confused DW (pretty much what Nancy is describing). In which cse, turning off auto-indent might do the trick.

It could also be a bad installation of the program or a corrupt Preferences file.

If you haven't yet, it may be worth Restoring Preferences to see if the odd behavior goes away.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 1