Highlighted

Help with bootstrap on new webibsite with xampp php mysql

New Here ,
Jun 04, 2020

Copy link to clipboard

Copied

I outsourced the development of the framework of a website www.ufonewsclipmap.com that utilize php, mysql and googlemap and this website is up and running using xampp.

However, on dreamweaver and by accessing the site locally on chrome via /localhost/ufonewsclipmap/ it isn’t working.

I can now open /localhost/ufonewsclipmap/ home page on chrome after I changed this on the index.php file

$app = require_once __DIR__.'/core/bootstrap/app.php';

to

$app = require_once __DIR__.'/core/resources/views/front/home.blade.php';

But I can’t see graphics or the google map on /localhost/ufonewsclipmap/ home page

On my website ufonewsclipmap.com

The logo link is https://ufonewsclipmap.com/assets/logo.png

While in my desktop it is https://localhost/ufonewsclipmap/%7B%7Burl('/')%7D%7D/assets/logo.png

I think that I should change the link on index.php

require __DIR__.'/core/vendor/autoload.php'; to something else

problem with bootstrap?

TOPICS
Bootstrap, Code, How to

Views

388

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Help with bootstrap on new webibsite with xampp php mysql

New Here ,
Jun 04, 2020

Copy link to clipboard

Copied

I outsourced the development of the framework of a website www.ufonewsclipmap.com that utilize php, mysql and googlemap and this website is up and running using xampp.

However, on dreamweaver and by accessing the site locally on chrome via /localhost/ufonewsclipmap/ it isn’t working.

I can now open /localhost/ufonewsclipmap/ home page on chrome after I changed this on the index.php file

$app = require_once __DIR__.'/core/bootstrap/app.php';

to

$app = require_once __DIR__.'/core/resources/views/front/home.blade.php';

But I can’t see graphics or the google map on /localhost/ufonewsclipmap/ home page

On my website ufonewsclipmap.com

The logo link is https://ufonewsclipmap.com/assets/logo.png

While in my desktop it is https://localhost/ufonewsclipmap/%7B%7Burl('/')%7D%7D/assets/logo.png

I think that I should change the link on index.php

require __DIR__.'/core/vendor/autoload.php'; to something else

problem with bootstrap?

TOPICS
Bootstrap, Code, How to

Views

389

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 04, 2020 0
Adobe Community Professional ,
Jun 05, 2020

Copy link to clipboard

Copied

 

problem with bootstrap?

 

Nope.

 

It looks like a PHP framework has been used. Personally I would get in touch with the developer to ask him how you can setup your local machine. Xamp is not what is driving the site, it is Apache


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2020 1
osgood- LATEST
Participant ,
Jun 05, 2020

Copy link to clipboard

Copied

To me it looks like maybe Laravel and Blade templating, neither of which I know anything about, as you say its best to go back to the developer and ask some questions.

 

In days gone by this would not have happened, the set up for such a simple website would never have used a framework and templating engine. Developers these days make everything more complex than they should be for some reason.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2020 0
Adobe Community Professional ,
Jun 05, 2020

Copy link to clipboard

Copied

Does your local site folder reside inside the xampp/htdocs folder?  See screenshots.  That's my recommended set-up. It's one less thing to think about.  No need to PUSH files to server each time you make changes.

 

Site > Manage SitesSite > Manage Sites

 

In addition, turn off Real-Time Preview. 

 

Edit > Preferences > Real-Time PreviewEdit > Preferences > Real-Time Preview

 

 

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2020 0