Highlighted

How Do I permanently disable live view in Dreamweaver?

Community Beginner ,
Oct 03, 2017

Copy link to clipboard

Copied

Ive looked online for answers to this but couldn't find the answer so I'm asking here...

I am using Adobe DreamWeaver CC -- (latest version) (2017.5)

Every time i create a new PHP document (or any web document) it opens in split view with live view on top and code on the bottom....

I do not like that it does that, and i never use it, and i don't like it as it sometimes prevents me from editing my file....

I need a way to permanently disable the Live View feature from my Dreamweaver. I do not like the WYSIWYG features/programs, i find them very inaccurate and less controllable.

Having to switch from the split view to the Code view every time I open a document is very annoying...

even if removing Live View from Dreamweaver is unable to be done I would like to at least have Dreamweaver open to Code view only on every startup and file creation.

Thanks.

It'd be nice if there was some file you could edit in the program that i could just change a few lines of code to have it open in Code only view on file creation. If there is I would love to know it. thanks.

Adobe Community Professional
Correct answer by Jon Fritz II | Adobe Community Professional

If you're not using one, try making a custom Workspace, maybe that's the difference here.

1. First, make sure you have a check by your Document Toolbar under Window > Toolbars > Document
2. Change the setting in the toolbar to Code or Split with Design on the right

3. Make sure all your other windows are set the way you want them (locked to the app frame, floating or closed)
4. Go to Window > Workspace Layout > New Workspace

5. Give your Workspace a name and hit OK

That "should" save your workspace exactly as it stands, with the toolbar showing either Code or Split/Design it shouldn't be able to open with Live anymore.

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How Do I permanently disable live view in Dreamweaver?

Community Beginner ,
Oct 03, 2017

Copy link to clipboard

Copied

Ive looked online for answers to this but couldn't find the answer so I'm asking here...

I am using Adobe DreamWeaver CC -- (latest version) (2017.5)

Every time i create a new PHP document (or any web document) it opens in split view with live view on top and code on the bottom....

I do not like that it does that, and i never use it, and i don't like it as it sometimes prevents me from editing my file....

I need a way to permanently disable the Live View feature from my Dreamweaver. I do not like the WYSIWYG features/programs, i find them very inaccurate and less controllable.

Having to switch from the split view to the Code view every time I open a document is very annoying...

even if removing Live View from Dreamweaver is unable to be done I would like to at least have Dreamweaver open to Code view only on every startup and file creation.

Thanks.

It'd be nice if there was some file you could edit in the program that i could just change a few lines of code to have it open in Code only view on file creation. If there is I would love to know it. thanks.

Adobe Community Professional
Correct answer by Jon Fritz II | Adobe Community Professional

If you're not using one, try making a custom Workspace, maybe that's the difference here.

1. First, make sure you have a check by your Document Toolbar under Window > Toolbars > Document
2. Change the setting in the toolbar to Code or Split with Design on the right

3. Make sure all your other windows are set the way you want them (locked to the app frame, floating or closed)
4. Go to Window > Workspace Layout > New Workspace

5. Give your Workspace a name and hit OK

That "should" save your workspace exactly as it stands, with the toolbar showing either Code or Split/Design it shouldn't be able to open with Live anymore.

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 03, 2017 0
Adobe Community Professional ,
Oct 03, 2017

Copy link to clipboard

Copied

DW is supposed to remember the last view you were using and use that view for each subsequent document you open.

If you switch from using Live View on HTML pages, then want to open a PHP page, you'll get the annoying pop up. But if you are using Code View or Split/Design, it should come up in that same view for each additional document you open.

At least, that's how it functions in CC2017.5 under Windows 7.

If you're getting something else, it may be worthwhile to clear your program cache:

Deleting a corrupted cache file

or restore preferences...

Unusual behavior in Dreamweaver? Try restoring preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
Community Beginner ,
Oct 03, 2017

Copy link to clipboard

Copied

neither one worked, i still get the split view on every file creation. i reset dreamweaver and deleted that cache file. still the same issue

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
Community Beginner ,
Oct 03, 2017

Copy link to clipboard

Copied

i think there is some function that loads the split view after every file creation.

after i press save (because that is what it forces me to do on every file creation) it then goes to code and then shifts the layout to load the split view automatically... but when it is showing the save file toolbar it doesnt have the split view (after file creation screen it shows the code and instantly pops  up the save file screen.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
Adobe Community Professional ,
Oct 03, 2017

Copy link to clipboard

Copied

I don't have that behavior at all.

Once I switch my view, it stays there until I switch it again. Even if I close the program entirely, the next file I open with DW, whether New or from the Files panel, is in the same view.

What OS are you on?

I am also using a custom workspace, maybe that's the difference?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
Community Beginner ,
Oct 03, 2017

Copy link to clipboard

Copied

im using windows 10

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
Adobe Employee ,
Oct 03, 2017

Copy link to clipboard

Copied

Hi Chuck,

Which workspace of DW are you using? In standard workspace, all documents will open in split view. If you switch to "Developer" workspace, all documents will come up in full code view, until you switch to split or live view.

You can switch workspace in DW from right top corner, hope this helps.

-Lalita

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
Community Beginner ,
Oct 03, 2017

Copy link to clipboard

Copied

I am using the Developer workspace

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 0
LEGEND ,
Oct 03, 2017

Copy link to clipboard

Copied

chuckc97610624  wrote

It'd be nice if there was some file you could edit in the program that i could just change a few lines of code to have it open in Code only view on file creation. If there is I would love to know it. thanks.

Try the simple steps first before doing anything drastic:

Go to View >> Code

Make sure Code is selected under views.  See this picture:

view-code.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2017 1
Community Beginner ,
Oct 04, 2017

Copy link to clipboard

Copied

Yeah that is what i have to do every time i create a new file is to go there.

What i want is where it defaults to that on every file creation and not to live view...

could it be because i have dreamweaver set to automatically save the php file to my custom site... via ftp?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2017 0
Adobe Community Professional ,
Oct 04, 2017

Copy link to clipboard

Copied

If you're not using one, try making a custom Workspace, maybe that's the difference here.

1. First, make sure you have a check by your Document Toolbar under Window > Toolbars > Document
2. Change the setting in the toolbar to Code or Split with Design on the right

3. Make sure all your other windows are set the way you want them (locked to the app frame, floating or closed)
4. Go to Window > Workspace Layout > New Workspace

5. Give your Workspace a name and hit OK

That "should" save your workspace exactly as it stands, with the toolbar showing either Code or Split/Design it shouldn't be able to open with Live anymore.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2017 1
Community Beginner ,
Oct 04, 2017

Copy link to clipboard

Copied

still does it.. im going to record my screen and upload it to youtube to show in detail whats going on...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2017 0
Community Beginner ,
Oct 04, 2017

Copy link to clipboard

Copied

your fix worked...

all i had to do was just restart dreamweaver after creating the new workspace and it is fixed...

Thank you very much

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 04, 2017 0