Highlighted

How do I stop Dw from..

LEGEND ,
Feb 19, 2020

Copy link to clipboard

Copied

Hello, all,

 

I'm used to working in Dw CS6, but am being forced to use Dw CC 2018 at work.  Of the long list of annoyances I have with Dw CC 2018 is how whenever I type " or ', it automatically adds a closing " or '.

 

How do I prevent this from happening?

 

V/r,

 

^ _ ^

Adobe Community Professional
Correct answer by Jon_Fritz_II | Adobe Community Professional

I never could get it to straighten up and fly right, but I did find this before I gave up on it...

1. On a PC, go to C: > Users > your user name > AppData (make sure hidden files are turned on if you don't see this folder) > Roaming > Adobe > Dreamweaver CC 2018 > your language > Configuration > Brackets > brackets.json

1a. On a Mac, this "should" be... (I don't have a Mac)
a. do a search for ~/Library/Application Support (make sure the ~ is there)
b. hit Go
c. next, go to Adobe > Dreamweaver CC 2018 > your language > Configuration > Brackets > brackets.json


2. (make a back-up first so you can go back if you goof) Open the file in something other than DW


3. If the option for closeBrackets doesn't already exist, add a comma to the last item on the list, then add the following to the end of the file, before the closing } ...


"closeBrackets": false,

 

You may also need a line for...

"autoCloseBraces":false,

and

"autoCloseQuotes":false,


3. Save and open DW

 

Topics

Bootstrap, Browser, Code, Download install and licensing, Error, Extensions, How to, Import and export, Interface, Other, Performance, Preview, Product issue, Publish, Server side applications

Views

558

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How do I stop Dw from..

LEGEND ,
Feb 19, 2020

Copy link to clipboard

Copied

Hello, all,

 

I'm used to working in Dw CS6, but am being forced to use Dw CC 2018 at work.  Of the long list of annoyances I have with Dw CC 2018 is how whenever I type " or ', it automatically adds a closing " or '.

 

How do I prevent this from happening?

 

V/r,

 

^ _ ^

Adobe Community Professional
Correct answer by Jon_Fritz_II | Adobe Community Professional

I never could get it to straighten up and fly right, but I did find this before I gave up on it...

1. On a PC, go to C: > Users > your user name > AppData (make sure hidden files are turned on if you don't see this folder) > Roaming > Adobe > Dreamweaver CC 2018 > your language > Configuration > Brackets > brackets.json

1a. On a Mac, this "should" be... (I don't have a Mac)
a. do a search for ~/Library/Application Support (make sure the ~ is there)
b. hit Go
c. next, go to Adobe > Dreamweaver CC 2018 > your language > Configuration > Brackets > brackets.json


2. (make a back-up first so you can go back if you goof) Open the file in something other than DW


3. If the option for closeBrackets doesn't already exist, add a comma to the last item on the list, then add the following to the end of the file, before the closing } ...


"closeBrackets": false,

 

You may also need a line for...

"autoCloseBraces":false,

and

"autoCloseQuotes":false,


3. Save and open DW

 

Topics

Bootstrap, Browser, Code, Download install and licensing, Error, Extensions, How to, Import and export, Interface, Other, Performance, Preview, Product issue, Publish, Server side applications

Views

559

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 19, 2020

Copy link to clipboard

Copied

  1. Go to Edit > Preferences > Code Hints.
  2. Auto completion:  Disable Auto Insert Quotes.

While you're at it, you might want to explore all the other Preferences in DW CC. 

 

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 19, 2020

Copy link to clipboard

Copied

That option wasn't added to DW until CC2019.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 19, 2020

Copy link to clipboard

Copied

Sorry about that.  I guess I skipped 2018 due to problems I had with it.   For me anyway, 2019 was more stable.

 

 

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 19, 2020

Copy link to clipboard

Copied

Hi, Nancy,

 

I disabled code hints and description tooltips, and it's still doing it.

 

NoCodeHints.png

 

V/r,

 

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 19, 2020

Copy link to clipboard

Copied

I never could get it to straighten up and fly right, but I did find this before I gave up on it...

1. On a PC, go to C: > Users > your user name > AppData (make sure hidden files are turned on if you don't see this folder) > Roaming > Adobe > Dreamweaver CC 2018 > your language > Configuration > Brackets > brackets.json

1a. On a Mac, this "should" be... (I don't have a Mac)
a. do a search for ~/Library/Application Support (make sure the ~ is there)
b. hit Go
c. next, go to Adobe > Dreamweaver CC 2018 > your language > Configuration > Brackets > brackets.json


2. (make a back-up first so you can go back if you goof) Open the file in something other than DW


3. If the option for closeBrackets doesn't already exist, add a comma to the last item on the list, then add the following to the end of the file, before the closing } ...


"closeBrackets": false,

 

You may also need a line for...

"autoCloseBraces":false,

and

"autoCloseQuotes":false,


3. Save and open DW

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 19, 2020

Copy link to clipboard

Copied

Jon to the rescue!  That was exactly what I was looking for.  Thank you!  It works.

 

V/r,

 

^ _ ^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Learn Resources
Add a group