Highlighted

Live Preview Shows design then changes to displaying DIV regions

Explorer ,
Sep 14, 2018

Copy link to clipboard

Copied

Help please.

I have a layout that uses a HTML5 bootstrap theme. On my old workstation dreamweaver shows everything fine, however, my new Mac with dreamweaver shows the layout when I refresh the view with F5, then changes to showing dotted lines and div shapes.

What is going on? Why does it not do that on my old Mac running exactly the same version of dreamweaver CC?

Please see screen shots attached.

Thanks

load 1.pngload 2.png

Hi

Well, I've discovered the culprit... it is Dreamweaver CC 2018. Everything views absolutely fine in Dreamweaver CC 2017.

This is an issue that I find hard to believe has not been experienced by other users. I wish I could explain the issue better but Dreamweaver CC 2018 most definitely has an issue with Live View and HTML templates built with Bootstrap.

I shall just continue working in Dreamweaver CC 2017.

TOPICS
Dreamweaver | Mac OS issues, Learn Dreamweaver

Views

836

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Live Preview Shows design then changes to displaying DIV regions

Explorer ,
Sep 14, 2018

Copy link to clipboard

Copied

Help please.

I have a layout that uses a HTML5 bootstrap theme. On my old workstation dreamweaver shows everything fine, however, my new Mac with dreamweaver shows the layout when I refresh the view with F5, then changes to showing dotted lines and div shapes.

What is going on? Why does it not do that on my old Mac running exactly the same version of dreamweaver CC?

Please see screen shots attached.

Thanks

load 1.pngload 2.png

Hi

Well, I've discovered the culprit... it is Dreamweaver CC 2018. Everything views absolutely fine in Dreamweaver CC 2017.

This is an issue that I find hard to believe has not been experienced by other users. I wish I could explain the issue better but Dreamweaver CC 2018 most definitely has an issue with Live View and HTML templates built with Bootstrap.

I shall just continue working in Dreamweaver CC 2017.

TOPICS
Dreamweaver | Mac OS issues, Learn Dreamweaver

Views

837

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 14, 2018 0
Adobe Employee ,
Sep 17, 2018

Copy link to clipboard

Copied

What happens when you preview your design in the browser? Does it appear as intended?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2018 0
Explorer ,
Sep 19, 2018

Copy link to clipboard

Copied

The entire content build is in my iCloud drive folder. I have copied all the files to a folder on my desktop to ensure it wasn't a problem with being on my iCloud Drive folder but the problem persists.

When I open the html file in any browser everything loads fine.

When I open the html file on my Mac at work the Live Preview in Dreamweaver loads everything perfect.

I have  uninstalled Dreamweaver and re-installed it and nothing resolves the problem.

Please see the screen shot attached. It shows the live preview with all dashed lines not showing the content properly. It shows browser window (top one) that has the html file directly opened and views perfect. And it shows another browser window (bottom one) that has opened the content via OptF12, this displays the loaded page but is missing some linked symbols (down arrows and Facebook f symbol) that I know are linking to an online location.

Why would the page not load properly on 127.0.0.1 when its a loop back?

I think the issue maybe a network issue, but I don't know how to resolve this.

Screen Shot 2018-09-19 at 21.20.51.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2018 0
Adobe Community Professional ,
Sep 19, 2018

Copy link to clipboard

Copied

Can you upload your problem page to your remote server and post the URL?

But before doing that, please validate your code and fix reported problems.

CC-BugReport.jpg

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2018 0
Explorer ,
Sep 19, 2018

Copy link to clipboard

Copied

Hi

The html is a thewagon template I purchased.

The website is live and works fine, you can see it at:

http://www.classic-occasions.co.uk

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2018 0
Adobe Community Professional ,
Sep 20, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Explorer ,
Sep 25, 2018

Copy link to clipboard

Copied

I contacted Themewagon and the 3 errors would not cause the issue. They have said it is an issue with Dreamweaver

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2018 0
Explorer ,
Sep 19, 2018

Copy link to clipboard

Copied

Hi

One other point, I disconnected my Mac from my network at home, then connected via hotspot from my phone to see if my hub/network was causing it, and the html file opened exactly the same, not display Live Preview.

Don't know if that helps at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2018 0
Explorer ,
Sep 25, 2018

Copy link to clipboard

Copied

Hi

Well, I've discovered the culprit... it is Dreamweaver CC 2018. Everything views absolutely fine in Dreamweaver CC 2017.

This is an issue that I find hard to believe has not been experienced by other users. I wish I could explain the issue better but Dreamweaver CC 2018 most definitely has an issue with Live View and HTML templates built with Bootstrap.

I shall just continue working in Dreamweaver CC 2017.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2018 0
Adobe Community Professional ,
Sep 17, 2018

Copy link to clipboard

Copied

Have you tried checking your paths?  I noticed that your screenshot shows that your Files Panel is not set to your current file's project (1); this means that Dreamweaver may not be tracking the paths to your style sheets and assets properly if you don't have absolute paths in place (2):

See what happens if you select your site definition from the Files Panel's project drop down list...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2018 1
Explorer ,
Sep 19, 2018

Copy link to clipboard

Copied

Hi,

first I'd like to say thanks for giving this some time.

Unfortunately, setting the site up in dreamweaver does not resolve the issue. I don't believe that is what is causing the problem as the html and all assets are stored in the same directory so the route is as shown. Basically, the folder is on my iCloud drive as I work on this during my lunch break at work and at home. When I view it in dreamweaver at work it loads perfectly. It only does this when I view in dreamweaver at home.

Now, when I view any of the pages in a web browser the files load perfect.

My understanding from a post I put up on virgin media, my ISP, I believed the problem may have been caused by new hub, but I've been informed that Live Preview in Dreamweaver requires a network connection to work and loads via 127.0.0.1. So maybe the problem is a network issue.

Additionally, I've discovered that the view in browser (opt F12) doesn't work properly either, it loses assets that are not locally.  The page loads on 127.0.0.1 in the address bar and I'm told this is a local IP loop back. I don't know what any of that means.

I've updated my DNS in my network settings to include 8.8.8.8 and 1.1.1.1 and still the preview does not work in Dreamweaver....well its does for 3 seconds, then switches to the screenshot I showed.

I have no idea what is happening, but believe the issue is network related rather than Dreamweaver, so maybe I'm asking in the wrong place. The problem is I don't know where to ask for help regarding Dreamweaver and Networking?

Any help greatly appreciated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2018 0
Explorer ,
Sep 25, 2018

Copy link to clipboard

Copied

Thanks for trying to help. It turns out to be Dreamweaver CC 2018. The problem does not happen when I open the files in Dreamweaver CC 2017.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2018 0
Adobe Community Professional ,
Sep 25, 2018

Copy link to clipboard

Copied

This must be unique to that particular Template because I cannot reproduce it at my end.  And I use Bootstrap!

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2018 0