Highlighted

MAMP works but NOT within DW CC2018.

Engaged ,
Jul 12, 2018

Copy link to clipboard

Copied

Hi,

I set up my DW CC 2018 (v. 18.2) with the MAMP. I made some test files with php, html, php includes. I guess everything is set up correctly the MAMP in the Dreamweaver. The problem is with the PREVIEW. When clicking the LIVE VIEW, it shows totally blank page (and before a message that the URL could not found.) Curiously, the DESIGN VIEW shows me the file but is not so reliable. Most important is the browser, right?

HOWEVER, when I open the browser (Chrome, Opera...) FROM THE FINDER, the files are there! I can also see the directory list in /localhost/ If I select any of the html or php files from that list, I can see all of them rendered properly, so the local server IS WORKING, but there is something wrong with the DW interface that gives me those errors mentioned. I also tried in preferences > Generate temporal file for preview, I tried changing the ports, 80... 8888... etc. but same story. Should I go to the terminal and type sudo and so on...? Attach image of the problem. Or I can find a way how to make preview in the localhost URL just clicking something. Thanks for your patience.

dw-error-local.jpg

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Ditto what Jon said.  Real-Time preview does not play nice with my localhost.  

Live view should render PHP pages  just fine.  If not, your site is not set-up correctly.

CC-testingServer1.jpg

TOPICS
Dreamweaver | Mac OS issues, Learn Dreamweaver

Views

998

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

MAMP works but NOT within DW CC2018.

Engaged ,
Jul 12, 2018

Copy link to clipboard

Copied

Hi,

I set up my DW CC 2018 (v. 18.2) with the MAMP. I made some test files with php, html, php includes. I guess everything is set up correctly the MAMP in the Dreamweaver. The problem is with the PREVIEW. When clicking the LIVE VIEW, it shows totally blank page (and before a message that the URL could not found.) Curiously, the DESIGN VIEW shows me the file but is not so reliable. Most important is the browser, right?

HOWEVER, when I open the browser (Chrome, Opera...) FROM THE FINDER, the files are there! I can also see the directory list in /localhost/ If I select any of the html or php files from that list, I can see all of them rendered properly, so the local server IS WORKING, but there is something wrong with the DW interface that gives me those errors mentioned. I also tried in preferences > Generate temporal file for preview, I tried changing the ports, 80... 8888... etc. but same story. Should I go to the terminal and type sudo and so on...? Attach image of the problem. Or I can find a way how to make preview in the localhost URL just clicking something. Thanks for your patience.

dw-error-local.jpg

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Ditto what Jon said.  Real-Time preview does not play nice with my localhost.  

Live view should render PHP pages  just fine.  If not, your site is not set-up correctly.

CC-testingServer1.jpg

TOPICS
Dreamweaver | Mac OS issues, Learn Dreamweaver

Views

999

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 12, 2018 0
Adobe Community Professional ,
Jul 12, 2018

Copy link to clipboard

Copied

Adobe's Real Time Preview (middle panel of your image) tends to not get along with .php driven pages as well as the old Preview in Browser did.

Try right clicking the file's name in the Files window, or right clicking the file's named tab (if you have your documents set as tabs in DW) and choose Open In Browser (formerly Preview in Browser) instead. That will open your file locally instead of running it through Adobe's servers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 12, 2018 2
Adobe Community Professional ,
Jul 12, 2018

Copy link to clipboard

Copied

Ditto what Jon said.  Real-Time preview does not play nice with my localhost.  

Live view should render PHP pages  just fine.  If not, your site is not set-up correctly.

CC-testingServer1.jpg

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 12, 2018 0
Engaged ,
Jul 13, 2018

Copy link to clipboard

Copied

Hi, @Nancy. I solved the issue, but still it's of my interest. About your image above, The "www" is equivalent to the "htdocs" in MAMP for Mac? Your are setting the project straight to the test server, right? I'll do the same. The project folder I set up straight on the test server folder MAMP > htdocs > My-Project-Directory.

Finally, I just added my project directory to the URL set up. So it's not  just "localhost", it is: http://localhost/My-Project-Directory. Now, I can see the php files rendered properly and also in the browser, using the DW buttons. This is what I set up on the interface following your picture above and works... so far... apearently... Thanks a lot!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Engaged ,
Jul 13, 2018

Copy link to clipboard

Copied

I did that, unfortunately, same result. Files open in 127.0.0.1 with no found URL message. The trick was to add the project folder to the URL in the set up. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Engaged ,
Jul 13, 2018

Copy link to clipboard

Copied

Thanks for your replies. I solved the issue, just adding the project folder to the URL path as shown in the attached pics. The name of my project directory is MAGIC2018.dw-setup2018.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 1
Explorer ,
Jan 27, 2019

Copy link to clipboard

Copied

I am having this issue again. But here is something that help me before I updated XAMPP 731 :

To preview remote site in browser with DW CC 2018

If F12 shows in Live preview

The F12 shortcut was given to Live Preview in CC2017 and continues to be one of the inaccessible keyboard shortcuts in the preferences, so there's no way built into the program interface to change it back to the old Preview in Browser. That doesn't mean you can't change it though. If you have full admin access to your computer, you can make a tiny text change to one of DW's program files to permanently give F12 back to Preview in Browser.

To re-map the old Preview in Browser (Open in Browser) to F12 rather than Live Preview...

1. Close DW and go to...

    Windows: C: > Program Files > Adobe > Adobe Dreamweaver CC 2017 > configuration > Menus > MM

    Mac: Applications > Adobe Dreamweaver CC 2017 > configuration > Menus > MM

    (I think, I don't have a Mac to test)

2. Open the file "PIB_Dynamic.js"

2a. As always, make a backup in case something goes sideways. Add _old at the end of the file name.

3. Search for the text "dw.browseDocument". There are 3 spots with that code, but the first two are just comments. The right one should be on or about line 433, and change the text "isPIB" to "true"

The finished line of code will look like..

dw.browseDocument(dw.getDocumentPath('document'),theBrowser, "-1"/*help argument*/, false /*use temp doc*/, true);

4. Save the file to your desktop

5. Drag the file into the original location from Step 1. You will be prompted for your Admin credentials in order to make the copy/replacement

I do have accesses to:
http://localhost/dashboard/

but not for any other project under :
http://localhost/ProjectNameHere

as sugested.

But I hope the little "hack" help others too!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2019 0