Highlighted

Menu stopped working on all pages

New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

I'm new to Dreamweaver and HTML, so excuse my ignorance when it comes to the problem I'm having. I was tasked with updating a webpage for work. Everything was going fine until I had to create a new page. I duplicated an existing page (so as not to recreate the wheel) and added the new content. At that time, however, I realized that the menu on the page was no longer visible. I looked at the other pages, and the menu bar was gone from those as well. I had not touched the menu html file, nor the css file, nor the spry file.

I uploaded one of the pages to the server, thinking maybe it was a fluke and the menu bar would magically reappear (wishful thinking), but it's still broken. I have no idea what I did to break it. Any help??

The page I am referring to is here: Puget Sound Nearshore Ecosystem Restoration Project

Where the menu should be is an error message, "an error occurred while processing this directive".

Thank you in advance!

lindseyd25963997  wrote

Hey folks, you are right, the code for #include virtual was slightly different between the broken page and the working page.

Working Page

<tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE"><!--#include virtual="/esrp/esrp_menu_bar.html" --></td>

  </tr>

Broken Page

<tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE"><!--#include virtual="esrp_menu_bar.html" --></td>

  </tr>

I tried changing the code to be the same as the working page, and it didn't work. I'm ready to throw this webpage away.

So you have now changed the broken page to:

<td valign="top" bgcolor="#7CBEDE"><!--#include virtual="/esrp/esrp_menu_bar.html" --></td>

Have you uploaded it to the remote and tested?

If that doesnt work try adding the full link to the include file:

<td valign="top" bgcolor="#7CBEDE"><!--#include virtual="http://www.Puget Sound Nearshore Ecosystem Restoration Project /esrp/esrp_menu_bar.html" --></td>

Well you get the idea use the direct link: (remove the spaces in the file name)

http:// www. pugetsoundnearshore.org/esrp/esrp_menu_bar.html

Also check for browser caching. You may have put it right but you might still be seeing the previous version of the page in your browser. Empty the browsers cache or view in another browser if possible, just to make sure.

TOPICS
Create menus in Dreamweaver

Views

755

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Menu stopped working on all pages

New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

I'm new to Dreamweaver and HTML, so excuse my ignorance when it comes to the problem I'm having. I was tasked with updating a webpage for work. Everything was going fine until I had to create a new page. I duplicated an existing page (so as not to recreate the wheel) and added the new content. At that time, however, I realized that the menu on the page was no longer visible. I looked at the other pages, and the menu bar was gone from those as well. I had not touched the menu html file, nor the css file, nor the spry file.

I uploaded one of the pages to the server, thinking maybe it was a fluke and the menu bar would magically reappear (wishful thinking), but it's still broken. I have no idea what I did to break it. Any help??

The page I am referring to is here: Puget Sound Nearshore Ecosystem Restoration Project

Where the menu should be is an error message, "an error occurred while processing this directive".

Thank you in advance!

lindseyd25963997  wrote

Hey folks, you are right, the code for #include virtual was slightly different between the broken page and the working page.

Working Page

<tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE"><!--#include virtual="/esrp/esrp_menu_bar.html" --></td>

  </tr>

Broken Page

<tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE"><!--#include virtual="esrp_menu_bar.html" --></td>

  </tr>

I tried changing the code to be the same as the working page, and it didn't work. I'm ready to throw this webpage away.

So you have now changed the broken page to:

<td valign="top" bgcolor="#7CBEDE"><!--#include virtual="/esrp/esrp_menu_bar.html" --></td>

Have you uploaded it to the remote and tested?

If that doesnt work try adding the full link to the include file:

<td valign="top" bgcolor="#7CBEDE"><!--#include virtual="http://www.Puget Sound Nearshore Ecosystem Restoration Project /esrp/esrp_menu_bar.html" --></td>

Well you get the idea use the direct link: (remove the spaces in the file name)

http:// www. pugetsoundnearshore.org/esrp/esrp_menu_bar.html

Also check for browser caching. You may have put it right but you might still be seeing the previous version of the page in your browser. Empty the browsers cache or view in another browser if possible, just to make sure.

TOPICS
Create menus in Dreamweaver

Views

756

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

This looks like an SSI issue. I'm assuming you have been including the nav bar in your pages with something like this?:

<!--#include file="menu.html" -->

or something like this if the files is another directory

<!--#include virtual="/directory/menu.html" -->

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 1
New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

You are exactly right! How do I fix an SSI issue? Any documents you could point me to?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

So have you got any live pages where the SSI include IS working correctly and the menu bar still shows without errors?

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

try renaming a page with extenion .shtml uploading it to the host and see if that works.

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 1
New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

Can you post the source code of a broken page? (Copy from Dreamweaver in code view).

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
LEGEND ,
Jan 17, 2019

Copy link to clipboard

Copied

What's in your index.html in the esrp folder after the last line of code below which is line 50. Theres a whole chunk of code missing in your 'shore_friendly.html' file  after that line - so its an include of some kind.

<body bgcolor="#206180" leftmargin="0" topmargin="0" marginheight="0">

<table width="1000" border="0" align="center" cellpadding="0" cellspacing="0">

 
 
<tr>

  
  
<td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

   <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

   <td valign="top" bgcolor="#7CBEDE">

This is the missing code which is another file, which is called into the page.

<table width="600" border="0" cellspacing="1" cellpadding="2">

  <tr>

   <td bgcolor="#7CBEDE"><ul id="MenuBar2" class="MenuBarHorizontal">

   <li><a href="http://www.pugetsoundnearshore.org/esrp/index.html">Home</a> </li>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/about.html" class="MenuBarItemSubmenu">About Us</a>

   <ul>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/history.html">History and Mission</a></li>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/how.html">How We Work</a></li>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/program_partners.html">Program Partnerships</a></li>

   </ul>

   </li>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/nearshore.html">About the Nearshore</a> </li>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/grants.html">Grants</a>

   <ul>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/application_process.html">Grant Application Process</a></li>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/application_materials.html">Application and Contract Material</a></li>

   </ul>

   </li>

  
  
<li><a href="http://www.pugetsoundnearshore.org/esrp/resources.html">Resources</a>  </li>

   <li><a href="http://www.pugetsoundnearshore.org/esrp/story_maps.html">Story Maps</a></li>

   </ul></td>

  </tr>

</table>

<script type="text/javascript">

<!--

var MenuBar1 = new Spry.Widget.MenuBar("MenuBar2", {imgDown:"http://www.pugetsoundnearshore.org/includes/SpryMenuBarDownHover.gif", imgRight:"http://www.pugetsoundnearshore.org/includes/SpryMenuBarRightHover.gif"});
//-->
</script>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

Here's the code from Dreamweaver. *Note, this isn't code for the entire page, just the top portion with the menu.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"

"http://www.w3.org/TR/html4/loose.dtd">

<html>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

<title>Puget Sound Nearshore Ecosystem Restoration Project</title>

<link rel="stylesheet" href="../includes/psnpstyles_new.css"  type="text/css">

<script src="../includes/SpryTabbedPanels.js" type="text/javascript"></script>

<script src="../includes/SpryMenuBar.js" type="text/javascript"></script>

<script type="text/javascript">

  var _gaq = _gaq || [];

  _gaq.push(['_setAccount', 'UA-32285023-1']);

  _gaq.push(['_trackPageview']);

  (function() {

    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;

    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';

    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);

  })();

</script>

<link href="../includes/SpryTabbedPanels.css" rel="stylesheet" type="text/css">

<link href="../includes/esrp_menu.css" rel="stylesheet" type="text/css">

<link href="../includes/MenuBarVertical.css" rel="stylesheet" type="text/css">

<style type="text/css">

<!--

body {

background-image: url();

background-repeat: no-repeat;

margin-top: 0px;

margin-left: 0px;

margin-right: 0px;

margin-bottom: 0px;

}

-->

</style>

</head>

<body bgcolor="#444444" leftmargin="0" topmargin="0" marginheight="0">

<table width="1000" border="0" align="center" cellpadding="0" cellspacing="0">

 

  <tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE">

    <!--#include virtual="esrp_menu_bar.html" --></td>

  </tr>

 

 

    <td colspan="7" bgcolor="#FFFFFF"><table width="100%" border="0" cellspacing="0" cellpadding="0">

      <tr>

        <td valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0">

          <tr>

            <td valign="top">

                  <table width="100%" border="0" cellspacing="0" cellpadding="0">

                  

                    <tr>

                      <td valign="top"><table width="100%" border="0" cellspacing="1" cellpadding="25">

                        <tr>

                          <td><span class="subhead">Estuary and Salmon Restoration Program (ESRP)

  &raquo;

                            Shore Friendly Program                            </span>

                            <p class="headline">Creating healthier shorelines</p>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
LEGEND ,
Jan 17, 2019

Copy link to clipboard

Copied

Is the below line of code in your 'shore_friendly.html' file after <td valign="top" bgcolor="#7CBEDE"> which is at line 50?

<!--#include virtual="esrp_menu_bar.html" -->

If its working in the 'index.html' file you posted a link to it should be working in your 'shore_friendly.html' file

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

<!--#include virtual="esrp_menu_bar.html" -->

This is the bit that wrong. include virtual is for including files in other folders

Where is esrp_menu_bar.html located, same directory as other files?

Compare this line with a working page and see what the difference is

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

osgood_ Yes, the next line of code after <td valign="top" bgcolor="#7CBEDE"> is <!--#include virtual="esrp_menu_bar.html"-->

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

so this line:

<!--#include virtual="esrp_menu_bar.html"-->

is it the same in working pages?

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
LEGEND ,
Jan 17, 2019

Copy link to clipboard

Copied

Energize  wrote

<!--#include virtual="esrp_menu_bar.html" -->

This is the bit that wrong. include virtual is for including files in other folders

Where is esrp_menu_bar.html located, same directory as other files?

Compare this line with a working page and see what the difference is

the index.html file, which presumably includes <!--#include virtual="esrp_menu_bar.html" --> is in the esrp folder as is the shore_friendly.html - so both should be working if they are in the same location and the include link is identical in both of them

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

Maybe post the source code of a working page too, and I'm sure we can sort this out very quickly for you.

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

the index.html file, which presumably includes <!--#include virtual="esrp_menu_bar.html" --> is in the esrp folder as is the shore_friendly.html - so both should be working if they are in the same locat

Yes I know they are in the same directory but the new files being uploaded are not working are they, so something is wrong. Whats your point exactly?

I

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

This is the confusing thing: the pages that I never touched in Dreamweaver are broken now too. I only uploaded the Shore Friendly page to the host to see if it would work.

I have not updated the other pages (index, etc.) on the host, so they still work. I'm not sure if this makes sense. Every page of html that is in Dreamweaver has a broken menu now

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
LEGEND ,
Jan 17, 2019

Copy link to clipboard

Copied

Energize  wrote

the index.html file, which presumably includes <!--#include virtual="esrp_menu_bar.html" --> is in the esrp folder as is the shore_friendly.html - so both should be working if they are in the same locat

Yes I know they are in the same directory but the new files being uploaded are not working are they, so something is wrong. Whats your point exactly?

My point is both files obviously are NOT identical otherwise they would both work if they are in the same location. We dont know what the source code is in the index.html file, so it would be helpful to see that and compare it to what source  code the OP has already posted, presumably the shore_friendly.html file - although I can never tell in this forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

My point is both files obviously are NOT identical otherwise they would both work if they are in the same location. We dont know what the source code is in the index.html file, so it would be helpful to see that and compare it to what source  code the OP has already posted, presumably the shore_friendly.html file - although I can never tell in this forum.

Yes we already know all the above, so I still don't understand what yuour point is of gong over ground that we already know?  I'll bug out and leave this one to you close out, as you obviously think you know much better than me and it'll just get confusing if you butt in with nonsense

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

My suggestion; Download a GOOD file, open it in notepad check the line that starts with <!--#include virtual ... And compare that line with a broken file.

My guess is Dreamweaver has changed the path in this line

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

I really appreciate the help from you two. I will be busy with meetings for the next few hours, but I will download a good file and will check it out in notepad to see if anything has changed. Great suggestion. I will post an update after I've done that.

Thank you so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
LEGEND ,
Jan 17, 2019

Copy link to clipboard

Copied

Energize  wrote

My point is both files obviously are NOT identical otherwise they would both work if they are in the same location. We dont know what the source code is in the index.html file, so it would be helpful to see that and compare it to what source  code the OP has already posted, presumably the shore_friendly.html file - although I can never tell in this forum.

Yes we already know all the above, so I still don't understand what yuour point is of gong over ground that we already know?  I'll bug out and leave this one to you close out, as you obviously think you know much better than me and it'll just get confusing if you butt in with nonsense

What is a matter with you?

Im just trying to help as you are trying to and neither of us to date is able to because we cant get the right information from the OP. Don't take your childish frustration out on me please. You seem to jump out of your cot at every concievable opportunity that affords you.

Where did I say I know much better than you - thats just a figment of your imagination or one that shows lack of confidence in ones ability so you get aggresive when there is no need to.

I didnt know there was a policy in this forum which says only one person per thread was allowed to provide help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
Adobe Community Professional ,
Jan 17, 2019

Copy link to clipboard

Copied

What is a matter with you?

Im just trying to help as you are trying to and neither of us to date is able to because we cant get the right information from the OP. Don't take your childish frustration out on me please. You seem to jump out of your cot at every concievable opportunity that affords you.

Where did I say I know much better than you - thats just a figment of your imagination or one that shows lack of confidence in ones ability so you get aggresive when there is no need to.

I didnt know there was a policy in this forum which says only one person per thread was allowed to provide help

... and I'm childish .... Lets just not speak, I'm not wasting my energy, you are always right aren't you after all .... You wont get a repsonse from me again, this forum is cluttered with too many arguments, you are in a lot more of them than me

Paul-M, ACP

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
LEGEND ,
Jan 17, 2019

Copy link to clipboard

Copied

Energize  wrote

What is a matter with you?

Im just trying to help as you are trying to and neither of us to date is able to because we cant get the right information from the OP. Don't take your childish frustration out on me please. You seem to jump out of your cot at every concievable opportunity that affords you.

Where did I say I know much better than you - thats just a figment of your imagination or one that shows lack of confidence in ones ability so you get aggresive when there is no need to.

I didnt know there was a policy in this forum which says only one person per thread was allowed to provide help

... and I'm childish .... Lets just not speak, I'm not wasting my energy, you are always right aren't you after all .... You wont get a repsonse from me again, this forum is cluttered with too many arguments, you are in a lot more of them than me

Try to be more civil then in your responses. I was trying to help resolve an issue, not looking for yet another argument, which your tone of response is bound to contribute towards and cause.

And yes to finish on a civil note - I agree with you, now the OP has declared none of the local files are working the suggestion that they download a working file from the remote server is the right way to go because something has changed between local and remote.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
New Here ,
Jan 17, 2019

Copy link to clipboard

Copied

Hey folks, you are right, the code for #include virtual was slightly different between the broken page and the working page.

Working Page

<tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE"><!--#include virtual="/esrp/esrp_menu_bar.html" --></td>

  </tr>

Broken Page

<tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE"><!--#include virtual="esrp_menu_bar.html" --></td>

  </tr>

I tried changing the code to be the same as the working page, and it didn't work. I'm ready to throw this webpage away.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
LEGEND ,
Jan 17, 2019

Copy link to clipboard

Copied

lindseyd25963997  wrote

Hey folks, you are right, the code for #include virtual was slightly different between the broken page and the working page.

Working Page

<tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE"><!--#include virtual="/esrp/esrp_menu_bar.html" --></td>

  </tr>

Broken Page

<tr>

  

    <td rowspan="2" valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_left.jpg" width="200" height="200"></td>

    <td valign="top" bgcolor="#7CBEDE"><img src="graphics/esrp_masthead_right.jpg" width="800" height="161"></td>

  </tr>

  <tr>

    <td valign="top" bgcolor="#7CBEDE"><!--#include virtual="esrp_menu_bar.html" --></td>

  </tr>

I tried changing the code to be the same as the working page, and it didn't work. I'm ready to throw this webpage away.

So you have now changed the broken page to:

<td valign="top" bgcolor="#7CBEDE"><!--#include virtual="/esrp/esrp_menu_bar.html" --></td>

Have you uploaded it to the remote and tested?

If that doesnt work try adding the full link to the include file:

<td valign="top" bgcolor="#7CBEDE"><!--#include virtual="http://www.Puget Sound Nearshore Ecosystem Restoration Project /esrp/esrp_menu_bar.html" --></td>

Well you get the idea use the direct link: (remove the spaces in the file name)

http:// www. pugetsoundnearshore.org/esrp/esrp_menu_bar.html

Also check for browser caching. You may have put it right but you might still be seeing the previous version of the page in your browser. Empty the browsers cache or view in another browser if possible, just to make sure.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0
ALsp LATEST
Mentor ,
Jan 17, 2019

Copy link to clipboard

Copied

Energize  wrote

... and I'm childish .... Lets just not speak, I'm not wasting my energy, you are always right aren't you after all .... You wont get a repsonse from me again, this forum is cluttered with too many arguments, you are in a lot more of them than me

Damn. I thought I was always right. I guess I was wrong.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2019 0