Highlighted

PHP 7

Community Beginner ,
May 24, 2020

Copy link to clipboard

Copied

With the PHP version set to 7.1, Dreamweaver does not appear to recognize all of 7.1 feathers.

for example, declaring visibility in classes for const the line --- protected const MY_CONST = 123; --- shows as an error.  Also, it does not seem to recognize the intdiv (Integer division) command.

Correct answer by RodneyH2 | Community Beginner

Found the problem.  The version has to be set with the site in addition to Dreamweaver's preference. 

Solved.

Topics

Code, Product issue

Views

288

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PHP 7

Community Beginner ,
May 24, 2020

Copy link to clipboard

Copied

With the PHP version set to 7.1, Dreamweaver does not appear to recognize all of 7.1 feathers.

for example, declaring visibility in classes for const the line --- protected const MY_CONST = 123; --- shows as an error.  Also, it does not seem to recognize the intdiv (Integer division) command.

Correct answer by RodneyH2 | Community Beginner

Found the problem.  The version has to be set with the site in addition to Dreamweaver's preference. 

Solved.

Topics

Code, Product issue

Views

289

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
May 24, 2020

Copy link to clipboard

Copied

Found the problem.  The version has to be set with the site in addition to Dreamweaver's preference. 

Solved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Learn Resources
Add a group