Highlighted

PHP Temp files execute on server when files are opened!!!!!

New Here ,
Aug 17, 2020

Copy link to clipboard

Copied

Every time I open a PHP script on my local machine, a Temp file EXECUTES on the server!  I have "Preview using temp file" OFF.  I "opened" a php script recently in Dreamweaver and the "######_asdfs9eee.php" temp file executed on our server sending out over 1,000 emails.  Obviously it was not my intention to EXCECUTE the script.  Only edit it. 

 

We are running Windows 10, DW version 20.2

 

Until this gets fixed I will not be able to use DW to edit our websites.  Please help.  Thanks!

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PHP Temp files execute on server when files are opened!!!!!

New Here ,
Aug 17, 2020

Copy link to clipboard

Copied

Every time I open a PHP script on my local machine, a Temp file EXECUTES on the server!  I have "Preview using temp file" OFF.  I "opened" a php script recently in Dreamweaver and the "######_asdfs9eee.php" temp file executed on our server sending out over 1,000 emails.  Obviously it was not my intention to EXCECUTE the script.  Only edit it. 

 

We are running Windows 10, DW version 20.2

 

Until this gets fixed I will not be able to use DW to edit our websites.  Please help.  Thanks!

Views

52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 17, 2020 0
Adobe Community Professional ,
Aug 17, 2020

Copy link to clipboard

Copied

I can honestly say I've NEVER had a script execute while I was editing it in DW or any other code editor.  For context, I use Wamp server on my computer's primary hard drive for local testing.  The remote server is on a separate commercial web host.  So whatever happens on the local server cannot possibly impact what's happening on the remote and vice versa.

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0
New Here ,
Aug 17, 2020

Copy link to clipboard

Copied

Thanks again Nancy.  I do realize this is very strange.  I run DW on a local windows 10 pc.  I edit the files "localy" and they upload on save.  When I do this our server log shows a script running with the same file name but the random temp file stuff added on.  It does this every single time. 


Is there a way to stop the creation of the temp files???  I think that would fix it but the only setting I know of is the "Preview using temp file" setting and that is off.

 

I will say I think this started happening after we upgraded to 20.2.

 

I do appreciate your thoughts on this Nancy! 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0
Adobe Community Professional ,
Aug 17, 2020

Copy link to clipboard

Copied

"I edit the files "locally" and they upload on save. "

What does that mean exactly?  Do they upload to your testing server on save or do they upload to your remote server on save? 

 

I discourage uploading files to remote server on save.  Like it or not, it's an open invitation for trouble.

 

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0
New Here ,
Aug 18, 2020

Copy link to clipboard

Copied

Thanks Nancy.  I tried disabling auto push but it is still uploading to the server on save. 

 

Manage Sites-> Edit Site -> Servers -> Select remote server -> Edit -> Advanced -> Uncheck "Automatically upload files to server on save"

 

I did this and it is still uploading on save.  I have either not editing the correct setting or this is the wrong setting?

 

I notice that every time I save a file locally, the Get files/Put files, up/down arrow icons go from solid to greyed out.  Which to me would mean the files are getting automatically "put".  I've tried disconnecting from the remote server, but everytime I save a file it reconnects to the server automatically.

 

 

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 18, 2020 0
Adobe Community Professional ,
Aug 17, 2020

Copy link to clipboard

Copied

There are a couple of things that I would like to know, namely

1. Do you use a version manager and if so, what is the name

2. What is the gist of the content of the emails

3, Are the emails sent to known addressees.

 

In the meantime, do as Nancy suggests, do not upload automatically after a save.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0
New Here ,
Aug 18, 2020

Copy link to clipboard

Copied

Thanks Ben.  I'm going to try to just disable Auto Upload on save. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 18, 2020 0