Highlighted

"dynamically -related files could not be resolved because the site..." Wordpress & Dreamweaver [locked]

Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

I am trying to set up a Wordpress and Dreamweaver workflow and I am using MAMP to locally host Wordpress so I can do Theme Development. I have Run into this Error "dynamically -related files could not be resolved because the site definition is not correct for this server."

I have set up a testing Server in SITES > MANAGE SITES. After clicking on my "site" I go to the server and set the

Server Name: Wordpress Basics

Connection using: Local/Network
Server Folder: /Applications/MAMP/htdocs/Wordpress-Basic           (Wordpress-Basic is the Name of the Root Folder where the WordPress files are included)
Web URL: http://localhost:8888/Wordpress-Basic/

Now on the top of my screen, there is the Error message
"dynamically -related files could not be resolved because the site definition is not correct for this server. Retry | Setup"

Of course, I tried both "Retry" shows up with the same message, and "StepUp" takes me back to the SITES > MANAGE SITES > SERVER

I have also tried

Server Name: Wordpress Basics

Connection using: Local/Network
Server Folder: /Applications/MAMP/htdocs         
Web URL: http://localhost:8888/Wordpress-Basic/

And Clicked on both Retry and Setup. Both remain the same I also tried just doing it in the wp_content and that did the same thing but without the Retry option.

I am running Wordpress 5.2.2 using the Lates version of MAMP as of Aug 10, 2019, and using Dreamweaver 2019.
I am also using Understrap Theme and Child Theme of Understrap.

If anyone has an Idea what maybe wrong let me know I have everything I understand setup correctly and watch many tutorials that I have followed.

Wish I can say that I found an answer but I did it again the same way that I have done it 20 times and it worked.

Server Name: Wordpress Basics

Connection using: Local/Network
Server Folder: /Applications/MAMP/htdocs/Wordpress-Basic           (Wordpress-Basic is the Name of the Root Folder where the WordPress files are included)
Web URL: http://localhost:8888/Wordpress-Basic/


These are the correct set of information. I kept flipping in and out of the root and eventually one landed one time working

Views

947

Likes

Translate

Translate

Report

Report
This conversation has been locked.

"dynamically -related files could not be resolved because the site..." Wordpress & Dreamweaver [locked]

Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

I am trying to set up a Wordpress and Dreamweaver workflow and I am using MAMP to locally host Wordpress so I can do Theme Development. I have Run into this Error "dynamically -related files could not be resolved because the site definition is not correct for this server."

I have set up a testing Server in SITES > MANAGE SITES. After clicking on my "site" I go to the server and set the

Server Name: Wordpress Basics

Connection using: Local/Network
Server Folder: /Applications/MAMP/htdocs/Wordpress-Basic           (Wordpress-Basic is the Name of the Root Folder where the WordPress files are included)
Web URL: http://localhost:8888/Wordpress-Basic/

Now on the top of my screen, there is the Error message
"dynamically -related files could not be resolved because the site definition is not correct for this server. Retry | Setup"

Of course, I tried both "Retry" shows up with the same message, and "StepUp" takes me back to the SITES > MANAGE SITES > SERVER

I have also tried

Server Name: Wordpress Basics

Connection using: Local/Network
Server Folder: /Applications/MAMP/htdocs         
Web URL: http://localhost:8888/Wordpress-Basic/

And Clicked on both Retry and Setup. Both remain the same I also tried just doing it in the wp_content and that did the same thing but without the Retry option.

I am running Wordpress 5.2.2 using the Lates version of MAMP as of Aug 10, 2019, and using Dreamweaver 2019.
I am also using Understrap Theme and Child Theme of Understrap.

If anyone has an Idea what maybe wrong let me know I have everything I understand setup correctly and watch many tutorials that I have followed.

Wish I can say that I found an answer but I did it again the same way that I have done it 20 times and it worked.

Server Name: Wordpress Basics

Connection using: Local/Network
Server Folder: /Applications/MAMP/htdocs/Wordpress-Basic           (Wordpress-Basic is the Name of the Root Folder where the WordPress files are included)
Web URL: http://localhost:8888/Wordpress-Basic/


These are the correct set of information. I kept flipping in and out of the root and eventually one landed one time working

Views

948

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Adobe Community Professional ,
Aug 10, 2019

Copy link to clipboard

Copied

I haven't an english version underhand right now, but in french, did you went on the menu

Site > Site Options (2 menu item from the bottom menu) > First menu item of the last sub menu

and there you select Wordpress...

did that correct your trouble ?

Likes

Translate

Translate

Report

Report
Aug 10, 2019 1
Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

Yes it is the same process I think you are describing I did above in the Post.

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Adobe Community Professional ,
Aug 10, 2019

Copy link to clipboard

Copied

joshm33313852  a écrit

Yes it is the same process I think you are describing I did above in the Post.

nope I don't think that we talk about the same dialog... but anyway I re read your post, and I don't think that your problem comes from there.

Likes

Translate

Translate

Report

Report
Aug 10, 2019 1
Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

Yes that what i did have selected and tried even the folder before and the wp-content

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
LEGEND ,
Aug 10, 2019

Copy link to clipboard

Copied

Have you just tried localhost without the :8888

This looks like a mac set up and l cant recall needing the :8888 infront of localhost.

What happens if you just call the website in a browser

localhost/Wordpress-Basic/

Likes

Translate

Translate

Report

Report
Aug 10, 2019 1
Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

I have Not ill give this a shot... So that did not work what that does is stops showing the home page and shows a blank preview with the same error message. Localhost:8888

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Adobe Community Professional ,
Aug 10, 2019

Copy link to clipboard

Copied

Is the local testing server launched and are all Apache processes  running?

In my experience, you don't need Real-Time Preview with a local testing server.  It's best if you disable it in Preferences.   See screenshot.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Aug 10, 2019 1
LEGEND ,
Aug 10, 2019

Copy link to clipboard

Copied

After reading up on Mamp installation it definitely suggests the address should be localhost:8888/ but my installation of Mamp works without it, maybe Mamp recognises the default port, with or with out it, not sure.

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

Just tried this and didn’t see a difference

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
LEGEND ,
Aug 10, 2019

Copy link to clipboard

Copied

So this is a DW configuration issue not a Mamp/browser issue as you can access the website directly via the browser?

In that case l'll leave the 2 other responders to try and resolve the issues as its a long time since l last used DW.

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

Yes I think so because I can see the site live in my browser and able to see it in the live view in dreamweaver but still get the error message

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Adobe Community Professional ,
Aug 10, 2019

Copy link to clipboard

Copied

joshm33313852  wrote

I can see the site live in my browser and able to see it in the live view in dreamweaver but still get the error message

You're only using DW to customize a child theme.  So ignore the error message.  It's not important.  WordPress has includes within includes within includes and permalinks which DW can't always cope with.  Trust the code.  Don't worry about dynamically related files...  

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
LEGEND ,
Aug 10, 2019

Copy link to clipboard

Copied

Was this a discussion or a question and should the OP be marking their own response as correct or do you and Ben have issues with that. Im just surprised you havent already locked the thread in protest as no one marked your posts as being helpful.

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Adobe Community Professional ,
Aug 10, 2019

Copy link to clipboard

Copied

osgood_  wrote

Was this a discussion or a question and should the OP be marking their own response as correct or do you and Ben have issues with that. Im just surprised you havent already locked the thread in protest as no one marked your posts as being helpful.

I hope this is a facetious comment, in which case I will excuse you for bringing Nancy into this.

In case the question was asked in earnest, please let me enlighten you once again:

  1. it is a question directly related to Dreamweaver
  2. being a question it can be marked as 'Correct Answer'
  3. the OP marked the question 'Correct Answer' to show others that he no longer needed assistance
  4. I applaud the OP for showing this courtesy, many others don't bother

Ben

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
LEGEND ,
Aug 10, 2019

Copy link to clipboard

Copied

No it was a serious comment. It seems you and Nancy have taken it upon yourselves to decide if what was posted is a discussion or a question, regardless if you are then informed by the OP which one it was.

Im just a bit concerned that both you and Nancy are losing your ability to think sensibly as a result of what l view as personal grievances, thats all. I expressed that exact same concern to Nancy directly although she decided it was not to her liking and deleted the post, further clarifying that this forum is not open to opinions, views other than those who are ACPs.

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Adobe Community Professional ,
Aug 10, 2019

Copy link to clipboard

Copied

You poor little whingeing englishman, how do you know that it was Nancy that deleted the post and not me or another moderator who saw your post as an harassment.

Anyway gone too far Post has been answered and locked


Ben

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

Screen Shot 2019-08-10 at 3.17.31 PM.pngScreen Shot 2019-08-10 at 3.16.51 PM.pngScreen Shot 2019-08-10 at 3.16.29 PM.pngScreen Shot 2019-08-10 at 3.16.15 PM.pngScreen Shot 2019-08-10 at 3.16.01 PM.png

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0
Explorer ,
Aug 10, 2019

Copy link to clipboard

Copied

Wish I can say that I found an answer but I did it again the same way that I have done it 20 times and it worked.

Server Name: Wordpress Basics

Connection using: Local/Network
Server Folder: /Applications/MAMP/htdocs/Wordpress-Basic           (Wordpress-Basic is the Name of the Root Folder where the WordPress files are included)
Web URL: http://localhost:8888/Wordpress-Basic/


These are the correct set of information. I kept flipping in and out of the root and eventually one landed one time working

Likes

Translate

Translate

Report

Report
Aug 10, 2019 0