Highlighted

Some HTML breaks spell checking in DW 20.2?

New Here ,
Sep 15, 2020

Copy link to clipboard

Copied

I am having issues with getting spell check to work for certian HTML documents. DW 20.2 build 15263 

 

I have certain documents that, in Design view, present a blank white window. They look fine in Live mode.

 

When I try to spell check the documents that produce the blank white window (mindful that spell check works only in Design view) I get a dialouge box that says "Spelling check complete." The trouble is that no spelling check has taken place because none of the mispelled words in the document are flagged.

 

I have created a simple HTML document as a test. That document does appear appropriately in Design view and spell check will flag mis-spelled words in it as it should. 

 

So I guess that

 

1) Some aspect of the code in the files that present a blank white window in Design view is breaking Design view.

 

2) Spell check is not working when/because Design view is broken.

 

I'll note that one the troublesome files makes use of Google fonts and when I select Design view I get a note that says "Web Fonts are not rendered in Design view. Please switch to Live view to preview Web Fonts", however I can create a test file that uses Google fonts that does not generate that note and for which spell check works.

 

I very much need spell check to work and this circumstance is rather frustrating and suprising behaviour in a application as mature as Dreamweaver. When DM says a spell check have been completed I need to be able to believe that.

 

Can anyone explain what might be going on and steps to remedy? What HTML code might break Design view? Any help greatfully received.

TOPICS
Product issue

Views

50

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Some HTML breaks spell checking in DW 20.2?

New Here ,
Sep 15, 2020

Copy link to clipboard

Copied

I am having issues with getting spell check to work for certian HTML documents. DW 20.2 build 15263 

 

I have certain documents that, in Design view, present a blank white window. They look fine in Live mode.

 

When I try to spell check the documents that produce the blank white window (mindful that spell check works only in Design view) I get a dialouge box that says "Spelling check complete." The trouble is that no spelling check has taken place because none of the mispelled words in the document are flagged.

 

I have created a simple HTML document as a test. That document does appear appropriately in Design view and spell check will flag mis-spelled words in it as it should. 

 

So I guess that

 

1) Some aspect of the code in the files that present a blank white window in Design view is breaking Design view.

 

2) Spell check is not working when/because Design view is broken.

 

I'll note that one the troublesome files makes use of Google fonts and when I select Design view I get a note that says "Web Fonts are not rendered in Design view. Please switch to Live view to preview Web Fonts", however I can create a test file that uses Google fonts that does not generate that note and for which spell check works.

 

I very much need spell check to work and this circumstance is rather frustrating and suprising behaviour in a application as mature as Dreamweaver. When DM says a spell check have been completed I need to be able to believe that.

 

Can anyone explain what might be going on and steps to remedy? What HTML code might break Design view? Any help greatfully received.

TOPICS
Product issue

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 15, 2020 0
Adobe Community Professional ,
Sep 16, 2020

Copy link to clipboard

Copied

If there is missing content in Design View it could very well need a server to process the data to show, thus the information is not actually on your page, but maybe available via an include.  In that case you would need to run a spellcheck on your included page and not the page doing the include.

 

Could you post a link to a sample page and we would be able to confirm this and show you were you should be spellchecking?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2020 0
Adobe Community Professional ,
Sep 16, 2020

Copy link to clipboard

Copied

Spell check works for me.  Are you working with a valid document?

When Design view goes blank, it's usually because of critical code errors above the fold.

 

  1. Go to Window > Results > Validation.
  2. Click the white triangle to check document. 
  3. Or if document contains server-side code like PHP, use Check Live Document.
  4. Also ensure that server-side includes are visible.  See screenshot.
    image.png

 

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2020 0
New Here ,
Oct 26, 2020

Copy link to clipboard

Copied

Nancy,

 

Thanks so much for the information. Your information helped me troubleshoot the issue and now spell check works.

 

The problem was <!--- instead of <!-- 

 

Sorry for the long delay I am the web person . . . and the photographer . . . and the social media person . . . and the videographer . . . and the pr writer for the small theatre company I work for.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 26, 2020 0